regression: ibus ignores keyboard layout

Bug #1302353 reported by Rolf Leggewie on 2014-04-04
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
ibus (Ubuntu)
Undecided
Unassigned
unity-settings-daemon (Ubuntu)
High
William Hua

Bug Description

The recent update of unity packages introduced a bad regression for ibus users. I assume the fault lies with unity since ibus hasn't been updated for several weeks and my machine was fine until about two days ago around which time some unity updates rolled in.

I have a German keyboard layout (QWERTZ not QWERTY as in the US case). I use anthy and mozc for Japanese input. Since two days ago the default layout with the Japanese IME are a US layout throwing me off when blind-typing. To look into the matter, I opened ibus-setup and there are three Input methods listed there: English - English (US), Japanese - Anthy and Japanese -Mozc. German was conspicuously absent . I eventually managed to add a German layout to it and delete the US layout. I then restart ibus with "ibus restart" only to find the US keyboard layout not only back but it's default again. Argh! In other words, the explicit choice I'm trying to force doesn't stick.

There are four keyboard layouts currently defined in "System Settings - Text Entry - Input sources to use", none of them have anything to do with a US-layout; de1, de2, anthy and mozc. I cycle through them via Super+Space. Anthy is set to use the system default layout. The regression is that it currently inists on US layout with no way to even override this silly choice.

Related branches

Rolf Leggewie (r0lf) on 2014-04-04
description: updated
description: updated
description: updated
Rolf Leggewie (r0lf) on 2014-04-04
description: updated
Rolf Leggewie (r0lf) wrote :

Here's a hack I learned about in #ibus that gets things working as they should (until the next time the ibus-anthy package is updated, I guess)

First, add 'de' to 'keyboard_layouts' in /usr/share/ibus-anthy/setup/anthyprefs.py
Second, run /usr/lib/ibus/ibus-setup-anthy and really, really force anthy to use the German layout in "Typing Methods - Keyboard layout"

No hack or workaround is currently known for ibus-mozc or any of the other input engines.

Fumihito YOSHIDA (hito) wrote :

Rolf-san,

Probably, #1298740 go some way towards?

Rolf Leggewie (r0lf) wrote :

OK, here's the workaround for mozc. Replace "default" by "de" in the "layout" key in /usr/share/ibus/component/mozc.xml. Just like the change for anthy, this will be probably be overridden the next time you update the ibus-mozc package. And in both cases you need to restart ibus or your computer for the change to take effect.

Many thanks to Fujiwarat from #ibus who helped me figure all this out.

Rolf Leggewie (r0lf) wrote :

Yoshida-san, thank you. That's spot on!

This regression was introduced by

http://paste.debian.net/91595/
unity-settings-daemon (14.04.0+14.04.20140402-0ubuntu1) trusty; urgency=low
[...]
  [ William Hua ]
  * Treat IBus engines with 'default' layouts as 'us'. (LP: #1298740)
 -- Ubuntu daily release <email address hidden> Wed, 02 Apr 2014 11:06:42 +0000

Changed in ibus (Ubuntu):
status: New → Incomplete
affects: unity (Ubuntu) → unity-settings-daemon (Ubuntu)
Changed in unity-settings-daemon (Ubuntu):
importance: Undecided → High
milestone: none → ubuntu-14.04
status: New → Triaged
Rolf Leggewie (r0lf) wrote :

Nevermind the paste.debian.net URL in above comment, that got in there accidentally

William Hua (attente) on 2014-04-04
Changed in unity-settings-daemon (Ubuntu):
assignee: nobody → William Hua (attente)
Changed in ibus (Ubuntu):
status: Incomplete → Invalid
William Hua (attente) wrote :

My apologies for this, in case Rolf's workarounds don't work for all IMs, I've uploaded a PPA that reverts the change.

To revert the regression until the fix is released:

sudo add-apt-repository ppa:attente/1302353
sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-mark hold unity-settings-daemon
restart unity-settings-daemon

Once the fix is released, you can unhold the package:

sudo apt-mark unhold unity-settings-daemon

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-settings-daemon - 14.04.0+14.04.20140407-0ubuntu1

---------------
unity-settings-daemon (14.04.0+14.04.20140407-0ubuntu1) trusty; urgency=low

  [ William Hua ]
  * Revert regression caused by commit 4033. (LP: #1302353)
 -- Ubuntu daily release <email address hidden> Mon, 07 Apr 2014 14:55:36 +0000

Changed in unity-settings-daemon (Ubuntu):
status: Triaged → Fix Released
Andrey Rozenberg (jaera) wrote :

I'm experiencing the same problem in Ubuntu 13.10: my keyboard is German and I use ibus-m17n to input Hebrew and Russian. When one of them is selected the actual behaviour is as if I had an English keyboard. In ibus-setup "Use system keyboard layout" is checked.

no longer affects: unity-settings-daemon
tags: added: regression-update
removed: regression-release
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers