unity-settings-daemon crashed with SIGABRT in g_assertion_message()

Bug #1298024 reported by Jorg Last on 2014-03-26
184
This bug affects 26 people
Affects Status Importance Assigned to Milestone
unity-settings-daemon (Ubuntu)
Medium
Unassigned

Bug Description

Im unsure of the consequences of this crash

ProblemType: Crash
DistroRelease: Ubuntu 14.04
Package: unity-settings-daemon 14.04.0+14.04.20140310-0ubuntu2
ProcVersionSignature: Ubuntu 3.13.0-19.39-generic 3.13.6
Uname: Linux 3.13.0-19-generic x86_64
ApportVersion: 2.13.3-0ubuntu1
Architecture: amd64
CrashCounter: 1
Date: Sun Mar 23 20:57:52 2014
ExecutablePath: /usr/lib/unity-settings-daemon/unity-settings-daemon
InstallationDate: Installed on 2014-03-23 (2 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140323)
ProcCmdline: /usr/lib/unity-settings-daemon/unity-settings-daemon
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_GB.UTF-8
 SHELL=/bin/false
Signal: 6
SourcePackage: unity-settings-daemon
StacktraceTop:
 g_assertion_message () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_assertion_message_expr () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 gnome_rr_config_load_current () from /usr/lib/libgnome-desktop-3.so.7
 gnome_rr_config_new_current () from /usr/lib/libgnome-desktop-3.so.7
 gnome_rr_config_load_filename () from /usr/lib/libgnome-desktop-3.so.7
Title: unity-settings-daemon crashed with SIGABRT in g_assertion_message()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Related branches

Jorg Last (cssprod) wrote :
Changed in unity-settings-daemon (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
information type: Private → Public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-settings-daemon (Ubuntu):
status: New → Confirmed
Eleuterio Buquiz (ucjdgm) wrote :

I got these problem after software update. And after I reboot hence this problem. Can't do anything. Can't reformat. I did several time but to no avail. What I did was to get one SDXC 32 GB from Staple. It cost me $38.13 include tax.

B.J. Herbison (bj-herbison) wrote :

I see this fairly often when I unlock my computer.

dazza5000 (darran-kelinske) wrote :

getting this on 15.10 running the latest packages

It says that they can't reproduce it at will, but I can. Happens at every start and if I run it from the terminal

Sebastien Bacher (seb128) wrote :

not exactly the same in fact, different error...

Changed in unity-settings-daemon (Ubuntu):
status: Confirmed → In Progress
status: In Progress → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-settings-daemon - 15.04.1+15.10.20151008-0ubuntu1

---------------
unity-settings-daemon (15.04.1+15.10.20151008-0ubuntu1) wily; urgency=medium

  [ Bastien Nocera ]
  * housekeeping: Don't follow symlinks to subdirectories, that can lead
    to data being deleted that shouldn't
  * media-keys: Postpone initialisation of libcanberra

  [ Carlos Garnacho ]
  * [xsettings] backport some small fixes from upstream, should fix
    issues where settings changes are delayed

  [ Cosimo Cecchi ]
  * housekeeping: Don't follow symlinks to subdirectories, that can lead
    to data being deleted that shouldn't

  [ Florian Müllner ]
  * [xsettings] backport some small fixes from upstream, should fix
    issues where settings changes are delayed

  [ Jan Alexander Steffens (heftig) ]
  * [xsettings] backport some small fixes from upstream, should fix
    issues where settings changes are delayed

  [ Kalev Lember ]
  * [xsettings] backport some small fixes from upstream, should fix
    issues where settings changes are delayed

  [ Matthias Clasen ]
  * [xsettings] backport some small fixes from upstream, should fix
    issues where settings changes are delayed

  [ Peter Hutterer ]
  * Backport changes from upstream git and
    https://bugzilla.gnome.org/show_bug.cgi?id=724789 to better handle
    XError

  [ Ryan Lortie ]
  * [xsettings] backport some small fixes from upstream, should fix
    issues where settings changes are delayed

  [ Sebastien Bacher ]
  * [orientation] tweaked version of upstream fix for settings updates
  * [xrandr] slightly updated version of an upstream bugfix for a
    segfault issue (LP: #1298024)

 -- Sebastien Bacher <email address hidden> Thu, 08 Oct 2015 16:15:07 +0000

Changed in unity-settings-daemon (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.