Unable to make screenshot with <PrintScreen> key in Unity session in Trusty

Bug #1282649 reported by Norbert on 2014-02-20
114
This bug affects 25 people
Affects Status Importance Assigned to Milestone
unity-settings-daemon (Ubuntu)
High
Unassigned

Bug Description

In Trusty with all installed updates it is not possible to make ScreenShot with <Print Screen> keyboard button.

The sound /usr/share/sounds/ubuntu/stereo/dialog-error.ogg is played and desired screenshot is not saved in ~/Pictures.
Tested in guest and normal sessions.

Please fix this bug. Do not forget about <Alt+PrintScreen>, <Ctrl+PrintScreen> and <Ctrl+Shift+PrintScreen>.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: unity 7.1.2+14.04.20140218.1-0ubuntu2
ProcVersionSignature: Ubuntu 3.13.0-11.31-generic 3.13.3
Uname: Linux 3.13.0-11-generic i686
.tmp.unity.support.test.0:

ApportVersion: 2.13.2-0ubuntu5
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Thu Feb 20 19:40:24 2014
DistUpgraded: 2013-11-19 13:23:13,179 DEBUG enabling apt cron job
DistroCodename: trusty
DistroVariant: ubuntu
GraphicsCard:
 NVIDIA Corporation GF108M [GeForce GT 425M] [10de:0df0] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: Sony Corporation Device [104d:907a]
InstallationDate: Installed on 2013-10-20 (123 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release i386 (20131016.1)
MachineType: Sony Corporation VPCF13Z1R
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-11-generic root=UUID=1d9289fd-0252-4f52-9d1e-fe6baf51083a ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: Upgraded to trusty on 2013-11-19 (93 days ago)
dmi.bios.date: 10/20/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: R0190Y9
dmi.board.asset.tag: N/A
dmi.board.name: VAIO
dmi.board.vendor: Sony Corporation
dmi.board.version: N/A
dmi.chassis.asset.tag: N/A
dmi.chassis.type: 10
dmi.chassis.vendor: Sony Corporation
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrR0190Y9:bd10/20/2010:svnSonyCorporation:pnVPCF13Z1R:pvrC607OEHZ:rvnSonyCorporation:rnVAIO:rvrN/A:cvnSonyCorporation:ct10:cvrN/A:
dmi.product.name: VPCF13Z1R
dmi.product.version: C607OEHZ
dmi.sys.vendor: Sony Corporation
version.compiz: compiz 1:0.9.11+14.04.20140218-0ubuntu1
version.libdrm2: libdrm2 2.4.52-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.1.0~rc1-1ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.1.0~rc1-1ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.15.0-1ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.3.0-1ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.910-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu2
xserver.bootTime: Thu Feb 20 19:32:11 2014
xserver.configfile: default
xserver.errors:
 Failed to load module "nvidia" (module does not exist, 0)
 Failed to load module "nvidia" (module does not exist, 0)
xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.15.0-1ubuntu6
xserver.video_driver: nouveau

Related branches

Norbert (nrbrtx) on 2014-02-20
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Iain Lane (laney) wrote :

Thanks, this is a bug in unity-settings-daemon that is fixed in lp:~laney/unity-settings-daemon/always-gnome-screenshot which should be uploaded to trusty soon

affects: unity (Ubuntu) → unity-settings-daemon (Ubuntu)
Changed in unity-settings-daemon (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-settings-daemon - 14.04.0+14.04.20140221-0ubuntu1

---------------
unity-settings-daemon (14.04.0+14.04.20140221-0ubuntu1) trusty; urgency=low

  [ Iain Lane ]
  * Always use gnome-screenshot directly, not the gnome-shell screenshot
    interface. We aren't using the legacy keygrabber under Unity, but
    neither can we use gnome-shell's interface since Unity doesn't
    implement it. (LP: #1282649)
 -- Ubuntu daily release <email address hidden> Fri, 21 Feb 2014 13:48:58 +0000

Changed in unity-settings-daemon (Ubuntu):
status: Triaged → Fix Released
Norbert (nrbrtx) wrote :

Thank you for the fix. <PrintScreen> now works in Unity session.

I did some tests (see my Google Docs table - https://docs.google.com/spreadsheet/ccc?key=0Ao5e713Ig9g_dHpGYVlMZ2JuYXdXdEtmUi1QbGxsYXc&usp=sharing).

In Ubuntu 12.04 (with no matter Unity or GNOME sessions) the full working list of shortcuts used for screenshoting is as follows:
* PrintScreen
* Alt+PrintScreen
* Ctrl+PrintScreen
* Shift+PrintScreen
* Ctrl+Alt+PrintScreen
* Ctrl+Shift+PrintScreen
All these hotkeys work normally in 14.04 too on GNOME FlashBack session (Compiz and Metacity), but
the following hotkeys for screenshots do not work in Unity session:
* Ctrl+PrintScreen,
* Ctrl+Alt+PrintScreen,
* Ctrl+Shift+PrintScreen

I can report separate bugs for them if you ask. Please support all screenshot hotkeys.

Norbert (nrbrtx) wrote :

On today's clean install of trusty daily-image (2014-03-16) the following hotkeys for screenshots do not work in Unity session:
* Ctrl+PrintScreen,
* Ctrl+Alt+PrintScreen,
* Ctrl+Shift+PrintScreen

Please fix the bug for them.

Norbert (nrbrtx) wrote :

I reported separate bug about making screenshots to clipboard in Unity session - this is bug 1295592.

Norbert (nrbrtx) wrote :

Made a clean install of 14.04 beta2 (4cf9e5ef2c1c362317c90312c76cfda0 *ubuntu-14.04-beta2-desktop-i386.iso) and got all shortcuts for screenshots working on all sessions - Unity, GMOME Compiz, GNOME Metacity.
It's great! Thank you!

Installed trusty final and upgraded to the latest packages provided by apt, and I can confirm that the bug isn't fixed.

formax (formax-tiscali) wrote :

Clean Trusty install, bug is still there.
My current unity-settings-daemon package is 14.04.0+14.04.20140414-0ubuntu1.

I confirm that the bug persists.
I am currently running Ubuntu14.04 upgraded from Ubuntu 13.10.
Strangely, under my system, I found out that the PrintScreen button works under the Fn+Del key combination. No idea why this happens.

Mario Martins (mariom93-d) wrote :

I am currently running Ubuntu14.04 upgraded from Ubuntu 13.10 too. And the bug persists. As well as Arthur, the PrintScreen button works under the Fn+Del key combination.

Norbert (nrbrtx) wrote :

Dear Arthur and Mario!
For me it seems that this is a hardware issue (keyboard, keyboard driver or something).

As far I can understand Mario has Pavilion DV6 (keyboard photo is here - http://www.nix.ru/include/view-photo.html?good_id=118704&pid=2253). According to photo of the keyboard Fn+Delete combination is an undocummented combination. May be keyboard driver identifies keyboard hardware layout wrong.

Could you, guys please install 'x11-utils' package (with 'sudo apt-get install x11-utils') and run 'xev' program?
This program collects all graphics server input events (keyboard, touchpad, mouse and other buttons). Please do the following steps:
1. Open gnome-terminal
2. Send command 'xev -event keyboard'
3. Press PrintScreen button on keyboard. Copy 'xev' output below KeyRelease somewhere (text editor or launchpad comment).
4. Clear gnome-terminal from which 'xev' was started (Terminal - Reset and clear or <Alt>,<t>,<l>).
5. Press Fn+Del button on keyboard. Copy 'xev' output below KeyRelease somewhere (text editor or launchpad comment).

I have Asus UX32a laptop (keyboard photo is here http://www.nix.ru/include/view-photo.html?good_id=148803&pid=2253).
I can make a screenshot only with <PrintScreen> key on any session of Ubuntu 14.04 and 12.04.

For <PrintScreen> button 'xev' produces the following output:
    KeyRelease event, serial 44, synthetic NO, window 0x3e00001,
        root 0x9d, subw 0x0, time 2797480, (-339,166), root:(448,218),
        state 0x0, keycode 107 (keysym 0xff61, Print), same_screen YES,
        XLookupString gives 0 bytes:
        XFilterEvent returns: False

On my laptop <Fn+Del> means <Insert> (see keyboard photo), so it does not work as <PrintScreen>, 'xev' reports the following:
    KeyRelease event, serial 44, synthetic NO, window 0x3e00001,
        root 0x9d, subw 0x0, time 2894533, (-324,567), root:(463,619),
        state 0x0, keycode 118 (keysym 0xff63, Insert), same_screen YES,
        XLookupString gives 0 bytes:
        XFilterEvent returns: False

I have a Hp Pavilion dv7 and I am experiencing the same problem... But in 13.10 all worked fine..

Download full text (4.0 KiB)

Same problem in hp-pavilion-g6. It worked fine in precise.

On Fri, Apr 25, 2014 at 1:08 PM, Marcuz93 <email address hidden> wrote:
> I have a Hp Pavilion dv7 and I am experiencing the same problem... But
> in 13.10 all worked fine..
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1282649
>
> Title:
> Unable to make screenshot with <PrintScreen> key in Unity session in
> Trusty
>
> Status in "unity-settings-daemon" package in Ubuntu:
> Fix Released
>
> Bug description:
> In Trusty with all installed updates it is not possible to make
> ScreenShot with <Print Screen> keyboard button.
>
> The sound /usr/share/sounds/ubuntu/stereo/dialog-error.ogg is played and desired screenshot is not saved in ~/Pictures.
> Tested in guest and normal sessions.
>
> Please fix this bug. Do not forget about <Alt+PrintScreen>,
> <Ctrl+PrintScreen> and <Ctrl+Shift+PrintScreen>.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 14.04
> Package: unity 7.1.2+14.04.20140218.1-0ubuntu2
> ProcVersionSignature: Ubuntu 3.13.0-11.31-generic 3.13.3
> Uname: Linux 3.13.0-11-generic i686
> .tmp.unity.support.test.0:
>
> ApportVersion: 2.13.2-0ubuntu5
> Architecture: i386
> CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
> CompositorRunning: compiz
> CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
> CompositorUnredirectFSW: true
> CurrentDesktop: Unity
> Date: Thu Feb 20 19:40:24 2014
> DistUpgraded: 2013-11-19 13:23:13,179 DEBUG enabling apt cron job
> DistroCodename: trusty
> DistroVariant: ubuntu
> GraphicsCard:
> NVIDIA Corporation GF108M [GeForce GT 425M] [10de:0df0] (rev a1) (prog-if 00 [VGA controller])
> Subsystem: Sony Corporation Device [104d:907a]
> InstallationDate: Installed on 2013-10-20 (123 days ago)
> InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release i386 (20131016.1)
> MachineType: Sony Corporation VPCF13Z1R
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-11-generic root=UUID=1d9289fd-0252-4f52-9d1e-fe6baf51083a ro quiet splash vt.handoff=7
> SourcePackage: unity
> UpgradeStatus: Upgraded to trusty on 2013-11-19 (93 days ago)
> dmi.bios.date: 10/20/2010
> dmi.bios.vendor: American Megatrends Inc.
> dmi.bios.version: R0190Y9
> dmi.board.asset.tag: N/A
> dmi.board.name: VAIO
> dmi.board.vendor: Sony Corporation
> dmi.board.version: N/A
> dmi.chassis.asset.tag: N/A
> dmi.chassis.type: 10
> dmi.chassis.vendor: Sony Corporation
> dmi.chassis.version: N/A
> dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrR0190Y9:bd10/20/2010:svnSonyCorporation:pnVPCF13Z1R:pvrC607OEHZ:rvnSonyCorporation:rnVAIO:rvrN/A:cvnSonyCorporation:ct10:cvrN/A:
> dmi.product.name: VPCF13Z1R
> dmi.product.version: C607OEHZ
> dmi.sys.vendor: Sony Corporation
> version.compiz: compiz 1:0.9.11+14.04.20140218-0ubuntu1
> version.libdrm2: libdrm2 2.4.52-1
> version.libgl1-mesa-dri: libgl1-mesa-dri 10.1.0~rc1-1ubuntu3
> version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
> version.libgl1-mesa-glx: libgl1-mesa-glx 10.1.0~rc1-1ubun...

Read more...

Norbert (nrbrtx) wrote :

Dear guys with HP Pavilions, please collect information about keys as described in comment 14.
It looks really interesting.

Download full text (4.3 KiB)

Here is my print :

KeyRelease event, serial 28, synthetic NO, window 0x4200001,
    root 0xa1, subw 0x0, time 1202331, (831,420), root:(880,472),
    state 0x10, keycode 218 (keysym 0xff61, Print), same_screen YES,
    XKeysymToKeycode returns keycode: 107
    XLookupString gives 0 bytes:
    XFilterEvent returns: False

My fn+print gives insert too.

On Fri, Apr 25, 2014 at 8:58 PM, Norbert <email address hidden> wrote:
> Dear guys with HP Pavilions, please collect information about keys as described in comment 14.
> It looks really interesting.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1282649
>
> Title:
> Unable to make screenshot with <PrintScreen> key in Unity session in
> Trusty
>
> Status in "unity-settings-daemon" package in Ubuntu:
> Fix Released
>
> Bug description:
> In Trusty with all installed updates it is not possible to make
> ScreenShot with <Print Screen> keyboard button.
>
> The sound /usr/share/sounds/ubuntu/stereo/dialog-error.ogg is played and desired screenshot is not saved in ~/Pictures.
> Tested in guest and normal sessions.
>
> Please fix this bug. Do not forget about <Alt+PrintScreen>,
> <Ctrl+PrintScreen> and <Ctrl+Shift+PrintScreen>.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 14.04
> Package: unity 7.1.2+14.04.20140218.1-0ubuntu2
> ProcVersionSignature: Ubuntu 3.13.0-11.31-generic 3.13.3
> Uname: Linux 3.13.0-11-generic i686
> .tmp.unity.support.test.0:
>
> ApportVersion: 2.13.2-0ubuntu5
> Architecture: i386
> CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
> CompositorRunning: compiz
> CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
> CompositorUnredirectFSW: true
> CurrentDesktop: Unity
> Date: Thu Feb 20 19:40:24 2014
> DistUpgraded: 2013-11-19 13:23:13,179 DEBUG enabling apt cron job
> DistroCodename: trusty
> DistroVariant: ubuntu
> GraphicsCard:
> NVIDIA Corporation GF108M [GeForce GT 425M] [10de:0df0] (rev a1) (prog-if 00 [VGA controller])
> Subsystem: Sony Corporation Device [104d:907a]
> InstallationDate: Installed on 2013-10-20 (123 days ago)
> InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release i386 (20131016.1)
> MachineType: Sony Corporation VPCF13Z1R
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-11-generic root=UUID=1d9289fd-0252-4f52-9d1e-fe6baf51083a ro quiet splash vt.handoff=7
> SourcePackage: unity
> UpgradeStatus: Upgraded to trusty on 2013-11-19 (93 days ago)
> dmi.bios.date: 10/20/2010
> dmi.bios.vendor: American Megatrends Inc.
> dmi.bios.version: R0190Y9
> dmi.board.asset.tag: N/A
> dmi.board.name: VAIO
> dmi.board.vendor: Sony Corporation
> dmi.board.version: N/A
> dmi.chassis.asset.tag: N/A
> dmi.chassis.type: 10
> dmi.chassis.vendor: Sony Corporation
> dmi.chassis.version: N/A
> dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrR0190Y9:bd10/20/2010:svnSonyCorporation:pnVPCF13Z1R:pvrC607OEHZ:rvnSonyCorporation:rnVAIO:rvrN/A:cvnSonyCorporation:ct10:cvrN/A:
> dmi.product.name: VPCF13Z1R
> dmi.product.version: C607OEHZ
> dmi.sys...

Read more...

Norbert (nrbrtx) wrote :

@Aaruni
so what is the label on key, which produces "keysym 0xff61, Print"? Does key label equal to its functionality?

Download full text (4.0 KiB)

@Norbert, yes. "prt sc" produces "keysym 0xff61, Print"

On Fri, Apr 25, 2014 at 9:40 PM, Norbert <email address hidden> wrote:
> @Aaruni
> so what is the label on key, which produces "keysym 0xff61, Print"? Does key label equal to its functionality?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1282649
>
> Title:
> Unable to make screenshot with <PrintScreen> key in Unity session in
> Trusty
>
> Status in "unity-settings-daemon" package in Ubuntu:
> Fix Released
>
> Bug description:
> In Trusty with all installed updates it is not possible to make
> ScreenShot with <Print Screen> keyboard button.
>
> The sound /usr/share/sounds/ubuntu/stereo/dialog-error.ogg is played and desired screenshot is not saved in ~/Pictures.
> Tested in guest and normal sessions.
>
> Please fix this bug. Do not forget about <Alt+PrintScreen>,
> <Ctrl+PrintScreen> and <Ctrl+Shift+PrintScreen>.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 14.04
> Package: unity 7.1.2+14.04.20140218.1-0ubuntu2
> ProcVersionSignature: Ubuntu 3.13.0-11.31-generic 3.13.3
> Uname: Linux 3.13.0-11-generic i686
> .tmp.unity.support.test.0:
>
> ApportVersion: 2.13.2-0ubuntu5
> Architecture: i386
> CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
> CompositorRunning: compiz
> CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
> CompositorUnredirectFSW: true
> CurrentDesktop: Unity
> Date: Thu Feb 20 19:40:24 2014
> DistUpgraded: 2013-11-19 13:23:13,179 DEBUG enabling apt cron job
> DistroCodename: trusty
> DistroVariant: ubuntu
> GraphicsCard:
> NVIDIA Corporation GF108M [GeForce GT 425M] [10de:0df0] (rev a1) (prog-if 00 [VGA controller])
> Subsystem: Sony Corporation Device [104d:907a]
> InstallationDate: Installed on 2013-10-20 (123 days ago)
> InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release i386 (20131016.1)
> MachineType: Sony Corporation VPCF13Z1R
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-11-generic root=UUID=1d9289fd-0252-4f52-9d1e-fe6baf51083a ro quiet splash vt.handoff=7
> SourcePackage: unity
> UpgradeStatus: Upgraded to trusty on 2013-11-19 (93 days ago)
> dmi.bios.date: 10/20/2010
> dmi.bios.vendor: American Megatrends Inc.
> dmi.bios.version: R0190Y9
> dmi.board.asset.tag: N/A
> dmi.board.name: VAIO
> dmi.board.vendor: Sony Corporation
> dmi.board.version: N/A
> dmi.chassis.asset.tag: N/A
> dmi.chassis.type: 10
> dmi.chassis.vendor: Sony Corporation
> dmi.chassis.version: N/A
> dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrR0190Y9:bd10/20/2010:svnSonyCorporation:pnVPCF13Z1R:pvrC607OEHZ:rvnSonyCorporation:rnVAIO:rvrN/A:cvnSonyCorporation:ct10:cvrN/A:
> dmi.product.name: VPCF13Z1R
> dmi.product.version: C607OEHZ
> dmi.sys.vendor: Sony Corporation
> version.compiz: compiz 1:0.9.11+14.04.20140218-0ubuntu1
> version.libdrm2: libdrm2 2.4.52-1
> version.libgl1-mesa-dri: libgl1-mesa-dri 10.1.0~rc1-1ubuntu3
> version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
> version.libgl1-mesa-glx: libgl1-mesa...

Read more...

Norbert (nrbrtx) wrote :

@Aaruni
Does this "prt sc" button produce a screenshot?
If not, it looks strange.

I tested Ubuntu 14.04 on 3 my laptops - I'm able to make screenshots on all of them on all sessions (see my comments 5 and 6).

Download full text (4.3 KiB)

@Norbert : "prt sc" does not produce a screenshot, although, <alt>+prt
sc produces a screenshot of the currently active window.

also, not that the behaviour of prt sc in Ubuntu Precise 12.04LTS on
the same computer is as expected, ie, to take a screenshot.

On Sat, Apr 26, 2014 at 12:28 AM, Norbert <email address hidden> wrote:
> @Aaruni
> Does this "prt sc" button produce a screenshot?
> If not, it looks strange.
>
> I tested Ubuntu 14.04 on 3 my laptops - I'm able to make screenshots on
> all of them on all sessions (see my comments 5 and 6).
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1282649
>
> Title:
> Unable to make screenshot with <PrintScreen> key in Unity session in
> Trusty
>
> Status in "unity-settings-daemon" package in Ubuntu:
> Fix Released
>
> Bug description:
> In Trusty with all installed updates it is not possible to make
> ScreenShot with <Print Screen> keyboard button.
>
> The sound /usr/share/sounds/ubuntu/stereo/dialog-error.ogg is played and desired screenshot is not saved in ~/Pictures.
> Tested in guest and normal sessions.
>
> Please fix this bug. Do not forget about <Alt+PrintScreen>,
> <Ctrl+PrintScreen> and <Ctrl+Shift+PrintScreen>.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 14.04
> Package: unity 7.1.2+14.04.20140218.1-0ubuntu2
> ProcVersionSignature: Ubuntu 3.13.0-11.31-generic 3.13.3
> Uname: Linux 3.13.0-11-generic i686
> .tmp.unity.support.test.0:
>
> ApportVersion: 2.13.2-0ubuntu5
> Architecture: i386
> CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
> CompositorRunning: compiz
> CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
> CompositorUnredirectFSW: true
> CurrentDesktop: Unity
> Date: Thu Feb 20 19:40:24 2014
> DistUpgraded: 2013-11-19 13:23:13,179 DEBUG enabling apt cron job
> DistroCodename: trusty
> DistroVariant: ubuntu
> GraphicsCard:
> NVIDIA Corporation GF108M [GeForce GT 425M] [10de:0df0] (rev a1) (prog-if 00 [VGA controller])
> Subsystem: Sony Corporation Device [104d:907a]
> InstallationDate: Installed on 2013-10-20 (123 days ago)
> InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release i386 (20131016.1)
> MachineType: Sony Corporation VPCF13Z1R
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-11-generic root=UUID=1d9289fd-0252-4f52-9d1e-fe6baf51083a ro quiet splash vt.handoff=7
> SourcePackage: unity
> UpgradeStatus: Upgraded to trusty on 2013-11-19 (93 days ago)
> dmi.bios.date: 10/20/2010
> dmi.bios.vendor: American Megatrends Inc.
> dmi.bios.version: R0190Y9
> dmi.board.asset.tag: N/A
> dmi.board.name: VAIO
> dmi.board.vendor: Sony Corporation
> dmi.board.version: N/A
> dmi.chassis.asset.tag: N/A
> dmi.chassis.type: 10
> dmi.chassis.vendor: Sony Corporation
> dmi.chassis.version: N/A
> dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrR0190Y9:bd10/20/2010:svnSonyCorporation:pnVPCF13Z1R:pvrC607OEHZ:rvnSonyCorporation:rnVAIO:rvrN/A:cvnSonyCorporation:ct10:cvrN/A:
> dmi.product.name: VPCF13Z1R
> dmi.product.version: C607OEHZ
> dmi.sys.ve...

Read more...

I confirm that Alt+Prt scr works correctly on my Pavilion dv7..

First of all, thank you all by the support.
I have a Pavilion dv6 laptop.
Here are the results of x11-utils:

--> When I press the PrintScreen button:

Outer window is 0x4200001, inner window is 0x4200002

KeymapNotify event, serial 24, synthetic NO, window 0x0,
    keys: 4294967223 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
           0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

KeyPress event, serial 25, synthetic NO, window 0x4200001,
    root 0xb6, subw 0x0, time 4825148, (-287,261), root:(484,313),
    state 0x10, keycode 218 (keysym 0xff61, Print), same_screen YES,
    XKeysymToKeycode returns keycode: 107
    XLookupString gives 0 bytes:
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: False

KeyRelease event, serial 28, synthetic NO, window 0x4200001,
    root 0xb6, subw 0x0, time 4825199, (-287,261), root:(484,313),
    state 0x10, keycode 218 (keysym 0xff61, Print), same_screen YES,
    XKeysymToKeycode returns keycode: 107
    XLookupString gives 0 bytes:
    XFilterEvent returns: False

--> When I press fn+Del key combination:

Outer window is 0x4200001, inner window is 0x4200002

KeymapNotify event, serial 24, synthetic NO, window 0x0,
    keys: 4294967223 0 0 0 16 0 0 0 0 0 0 0 0 0 0 0
           0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

KeyRelease event, serial 25, synthetic NO, window 0x4200001,
    root 0xb6, subw 0x0, time 4848953, (-660,410), root:(111,462),
    state 0x10, keycode 36 (keysym 0xff0d, Return), same_screen YES,
" XLookupString gives 1 bytes: (0d) "
    XFilterEvent returns: False

KeymapNotify event, serial 26, synthetic NO, window 0x0,
    keys: 4294967222 0 0 0 0 0 0 0 0 0 0 0 0 8 0 0
           0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

KeyRelease event, serial 28, synthetic NO, window 0x4200001,
    root 0xb6, subw 0x0, time 4851521, (-660,410), root:(111,462),
    state 0x10, keycode 107 (keysym 0xff61, Print), same_screen YES,
    XLookupString gives 0 bytes:
    XFilterEvent returns: False

Norbert (nrbrtx) wrote :

Dear all,
I still suspect that the problem is between laptop keyboard and its driver.

I have a new idea.
Could you please connect USB (or Bluetooth, or Wireless) keyboard to your HP Pavilion's and test <PrintScreen> from it.
As I know from my table (https://docs.google.com/spreadsheet/ccc?key=0Ao5e713Ig9g_dHpGYVlMZ2JuYXdXdEtmUi1QbGxsYXc&usp=sharing#gid=0), all shortcuts works normally on all sessions of Ubuntu 14.04 (Unity, GNOME FlashBack Compiz, GNOME FlashBack Metacity) on my 3 laptops (2 Asus - T101MT, UX32A, 1 Sony - VPCF13Z1R).

So please test <PrintScreen>, <Alt+PrintScreen>, <Ctrl+PrintScreen>, <Shift+PrintScreen>, <Ctrl+Alt+PrintScreen>, <Ctrl+Shift+PrintScreen> on Unity session with external keyboard.

Download full text (9.6 KiB)

Dear Norbert,
Sorry for not responding earlier. I had no usb keyboard at home so I waited till today to do it at the work.
I confirm that the PrintScreen USB Keyboard button works well.
Here are the results for the USB Keyboard testing:

<PrintScreen>

Outer window is 0x4400001, inner window is 0x4400002

KeymapNotify event, serial 24, synthetic NO, window 0x0,
    keys: 4294967223 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
           0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

KeymapNotify event, serial 24, synthetic NO, window 0x0,
    keys: 4294967223 0 0 0 0 0 0 0 0 0 0 0 0 8 0 0
           0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

KeyRelease event, serial 25, synthetic NO, window 0x4400001,
    root 0xb6, subw 0x0, time 2870503, (-614,399), root:(157,451),
    state 0x10, keycode 107 (keysym 0xff61, Print), same_screen YES,
    XLookupString gives 0 bytes:
    XFilterEvent returns: False

<Alt+PrintScreen>

Outer window is 0x4400001, inner window is 0x4400002

KeymapNotify event, serial 24, synthetic NO, window 0x0,
    keys: 4294967223 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
           0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

KeymapNotify event, serial 24, synthetic NO, window 0x0,
    keys: 4294967223 0 0 0 0 0 0 0 1 0 0 0 0 0 0 0
           0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

KeyPress event, serial 25, synthetic NO, window 0x4400001,
    root 0xb6, subw 0x0, time 3022739, (-347,336), root:(424,388),
    state 0x10, keycode 64 (keysym 0xffe9, Alt_L), same_screen YES,
    XLookupString gives 0 bytes:
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: False

KeyRelease event, serial 28, synthetic NO, window 0x4400001,
    root 0xb6, subw 0x0, time 3023003, (-347,336), root:(424,388),
    state 0x18, keycode 64 (keysym 0xffe9, Alt_L), same_screen YES,
    XLookupString gives 0 bytes:
    XFilterEvent returns: False

KeymapNotify event, serial 28, synthetic NO, window 0x0,
    keys: 4294967222 0 0 0 0 0 0 0 1 0 0 0 0 0 0 0
           0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

KeyPress event, serial 28, synthetic NO, window 0x4400001,
    root 0xb6, subw 0x0, time 3023003, (-347,336), root:(424,388),
    state 0x10, keycode 64 (keysym 0xffe9, Alt_L), same_screen YES,
    XLookupString gives 0 bytes:
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: False

KeymapNotify event, serial 28, synthetic NO, window 0x0,
    keys: 4294967222 0 0 0 0 0 0 0 1 0 0 0 0 8 0 0
           0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

KeyRelease event, serial 28, synthetic NO, window 0x4400001,
    root 0xb6, subw 0x0, time 3023003, (-347,336), root:(424,388),
    state 0x18, keycode 107 (keysym 0xff15, Sys_Req), same_screen YES,
    XLookupString gives 0 bytes:
    XFilterEvent returns: False

KeyRelease event, serial 28, synthetic NO, window 0x4400001,
    root 0xb6, subw 0x0, time 3023003, (-347,336), root:(424,388),
...

Read more...

Norbert (nrbrtx) wrote :

@Arthur Hrast Essenfelder
so all screenshot-related functionality works normally with USB-keyboard, but does not work with laptop keyboard, am I right?
So PrintScreen hotkeys work normally in Ubuntu 14.04.

It seems that your problem with HP Pavillion-s is not related to this bug 1282649 and to bug 1295994
and you need to report another bug on linux-image-generic and xserver-xorg-input-all.

Exactly.
Using the USB keyboard everything works fine, however using the laptop keyboard there is this problem.
I will report another bug as suggested.
Thank you.

Please post the link of the new bug that you are going to report

Download full text (4.1 KiB)

I do not have an external keyboard to try this out, but the fact that
prt sc works perfectly under 12.04 Precise and Windows 7 makes me
think its something wrong with Trusty.

On Mon, Apr 28, 2014 at 9:48 PM, Marcuz93 <email address hidden> wrote:
> Please post the link of the new bug that you are going to report
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1282649
>
> Title:
> Unable to make screenshot with <PrintScreen> key in Unity session in
> Trusty
>
> Status in "unity-settings-daemon" package in Ubuntu:
> Fix Released
>
> Bug description:
> In Trusty with all installed updates it is not possible to make
> ScreenShot with <Print Screen> keyboard button.
>
> The sound /usr/share/sounds/ubuntu/stereo/dialog-error.ogg is played and desired screenshot is not saved in ~/Pictures.
> Tested in guest and normal sessions.
>
> Please fix this bug. Do not forget about <Alt+PrintScreen>,
> <Ctrl+PrintScreen> and <Ctrl+Shift+PrintScreen>.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 14.04
> Package: unity 7.1.2+14.04.20140218.1-0ubuntu2
> ProcVersionSignature: Ubuntu 3.13.0-11.31-generic 3.13.3
> Uname: Linux 3.13.0-11-generic i686
> .tmp.unity.support.test.0:
>
> ApportVersion: 2.13.2-0ubuntu5
> Architecture: i386
> CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
> CompositorRunning: compiz
> CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
> CompositorUnredirectFSW: true
> CurrentDesktop: Unity
> Date: Thu Feb 20 19:40:24 2014
> DistUpgraded: 2013-11-19 13:23:13,179 DEBUG enabling apt cron job
> DistroCodename: trusty
> DistroVariant: ubuntu
> GraphicsCard:
> NVIDIA Corporation GF108M [GeForce GT 425M] [10de:0df0] (rev a1) (prog-if 00 [VGA controller])
> Subsystem: Sony Corporation Device [104d:907a]
> InstallationDate: Installed on 2013-10-20 (123 days ago)
> InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release i386 (20131016.1)
> MachineType: Sony Corporation VPCF13Z1R
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-11-generic root=UUID=1d9289fd-0252-4f52-9d1e-fe6baf51083a ro quiet splash vt.handoff=7
> SourcePackage: unity
> UpgradeStatus: Upgraded to trusty on 2013-11-19 (93 days ago)
> dmi.bios.date: 10/20/2010
> dmi.bios.vendor: American Megatrends Inc.
> dmi.bios.version: R0190Y9
> dmi.board.asset.tag: N/A
> dmi.board.name: VAIO
> dmi.board.vendor: Sony Corporation
> dmi.board.version: N/A
> dmi.chassis.asset.tag: N/A
> dmi.chassis.type: 10
> dmi.chassis.vendor: Sony Corporation
> dmi.chassis.version: N/A
> dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrR0190Y9:bd10/20/2010:svnSonyCorporation:pnVPCF13Z1R:pvrC607OEHZ:rvnSonyCorporation:rnVAIO:rvrN/A:cvnSonyCorporation:ct10:cvrN/A:
> dmi.product.name: VPCF13Z1R
> dmi.product.version: C607OEHZ
> dmi.sys.vendor: Sony Corporation
> version.compiz: compiz 1:0.9.11+14.04.20140218-0ubuntu1
> version.libdrm2: libdrm2 2.4.52-1
> version.libgl1-mesa-dri: libgl1-mesa-dri 10.1.0~rc1-1ubuntu3
> version.libgl1-mesa-dri-experimental: libgl1-mesa-d...

Read more...

Even after a fresh Trusty install and applying updates afterwards, the printscreen and all associated key combinations (alt+prtsc), the screenshot does not work. I do not have this issue with my up-to-date Saucy system.

As a temporary fix, change the keyboard shortcut for screenshots to "ctrl+M"

For those interested, I opened a new bug as suggested by Norbert.
Bug #1313754

Tessa (unit3) wrote :

I'm seeing this issue on Trusty but not on a laptop, and with a USB keyboard:

KeyRelease event, serial 28, synthetic NO, window 0x4000001,
    root 0x296, subw 0x0, time 440656382, (72,58), root:(492,110),
    state 0x10, keycode 107 (keysym 0xff61, Print), same_screen YES,
    XLookupString gives 0 bytes:
    XFilterEvent returns: False

That's the key event that doesn't trigger a screenshot on my computer. The keyboard shortcuts dialogue registers it as the "Print" key when I try and change the screenshot shortcut to it, so it looks like unity sees the key correctly, it just doesn't trigger a printscreen event.

Download full text (4.6 KiB)

As advised by someone above, the temporary solution to remap the
screenshot key to Ctrl+M works.

On Thu, May 8, 2014 at 1:21 AM, Graeme <email address hidden> wrote:
> I'm seeing this issue on Trusty but not on a laptop, and with a USB
> keyboard:
>
> KeyRelease event, serial 28, synthetic NO, window 0x4000001,
> root 0x296, subw 0x0, time 440656382, (72,58), root:(492,110),
> state 0x10, keycode 107 (keysym 0xff61, Print), same_screen YES,
> XLookupString gives 0 bytes:
> XFilterEvent returns: False
>
> That's the key event that doesn't trigger a screenshot on my computer.
> The keyboard shortcuts dialogue registers it as the "Print" key when I
> try and change the screenshot shortcut to it, so it looks like unity
> sees the key correctly, it just doesn't trigger a printscreen event.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1282649
>
> Title:
> Unable to make screenshot with <PrintScreen> key in Unity session in
> Trusty
>
> Status in "unity-settings-daemon" package in Ubuntu:
> Fix Released
>
> Bug description:
> In Trusty with all installed updates it is not possible to make
> ScreenShot with <Print Screen> keyboard button.
>
> The sound /usr/share/sounds/ubuntu/stereo/dialog-error.ogg is played and desired screenshot is not saved in ~/Pictures.
> Tested in guest and normal sessions.
>
> Please fix this bug. Do not forget about <Alt+PrintScreen>,
> <Ctrl+PrintScreen> and <Ctrl+Shift+PrintScreen>.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 14.04
> Package: unity 7.1.2+14.04.20140218.1-0ubuntu2
> ProcVersionSignature: Ubuntu 3.13.0-11.31-generic 3.13.3
> Uname: Linux 3.13.0-11-generic i686
> .tmp.unity.support.test.0:
>
> ApportVersion: 2.13.2-0ubuntu5
> Architecture: i386
> CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
> CompositorRunning: compiz
> CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
> CompositorUnredirectFSW: true
> CurrentDesktop: Unity
> Date: Thu Feb 20 19:40:24 2014
> DistUpgraded: 2013-11-19 13:23:13,179 DEBUG enabling apt cron job
> DistroCodename: trusty
> DistroVariant: ubuntu
> GraphicsCard:
> NVIDIA Corporation GF108M [GeForce GT 425M] [10de:0df0] (rev a1) (prog-if 00 [VGA controller])
> Subsystem: Sony Corporation Device [104d:907a]
> InstallationDate: Installed on 2013-10-20 (123 days ago)
> InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release i386 (20131016.1)
> MachineType: Sony Corporation VPCF13Z1R
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-11-generic root=UUID=1d9289fd-0252-4f52-9d1e-fe6baf51083a ro quiet splash vt.handoff=7
> SourcePackage: unity
> UpgradeStatus: Upgraded to trusty on 2013-11-19 (93 days ago)
> dmi.bios.date: 10/20/2010
> dmi.bios.vendor: American Megatrends Inc.
> dmi.bios.version: R0190Y9
> dmi.board.asset.tag: N/A
> dmi.board.name: VAIO
> dmi.board.vendor: Sony Corporation
> dmi.board.version: N/A
> dmi.chassis.asset.tag: N/A
> dmi.chassis.type: 10
> dmi.chassis.vendor: Sony Corporation
> dmi.chassis.version: N/A
> dmi.mod...

Read more...

Waz (paviluf) wrote :

Hello,

I have an Apple Aluminium keyboard without a print screen key.
Usually I set F16 to take a screenshot but it doesn't work in Ubuntu 14.04.

I hope you can fix it. In the meantime I set Ctrl + M to take a screenshot.

cactus (catalinbordenciu) wrote :

I didn't have this issue until yesterday after some updates.This problem was fixed for some people and "activated" for others including me.Now if i press PrintSc key nothing happens.I have a Lenovo laptop.Luckily i can change the key but it used to be standard on PrintScreen key.

Høst (helvete) wrote :

Same problem on HP Pavilion G4 2306la
Print screen works on wireless keyboard, in 13.10 also it worked very well.
Every function related to the key "Print Scren" (alt/ctrl/shift....etc+print screen doesn't) work.
Here is my output of xev -event keyboard when pressioning Print Screen

KeyPress event, serial 25, synthetic NO, window 0x4c00001,
    root 0xb1, subw 0x4c00002, time 6378036, (59,37), root:(59,627),
    state 0x10, keycode 218 (keysym 0xff61, Print), same_screen YES,
    XKeysymToKeycode returns keycode: 107
    XLookupString gives 0 bytes:
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: False

KeyRelease event, serial 28, synthetic NO, window 0x4c00001,
    root 0xb1, subw 0x4c00002, time 6378214, (59,37), root:(59,627),
    state 0x10, keycode 218 (keysym 0xff61, Print), same_screen YES,
    XKeysymToKeycode returns keycode: 107
    XLookupString gives 0 bytes:
    XFilterEvent returns: False

Dan Jared (danjaredg) wrote :

I have version unity-settings-daemon 14.04.0+14.04.20140414-0ubuntu1, and PrintScreen key doesn't work.

KeyPress event, serial 28, synthetic NO, window 0x4e00001,
    root 0xa9, subw 0x0, time 8225042, (-366,-111), root:(822,479),
    state 0x0, keycode 218 (keysym 0xff61, Print), same_screen YES,
    XKeysymToKeycode returns keycode: 107
    XLookupString gives 0 bytes:
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: False

KeyRelease event, serial 28, synthetic NO, window 0x4e00001,
    root 0xa9, subw 0x0, time 8225121, (-366,-111), root:(822,479),
    state 0x0, keycode 218 (keysym 0xff61, Print), same_screen YES,
    XKeysymToKeycode returns keycode: 107
    XLookupString gives 0 bytes:
    XFilterEvent returns: False

Ilya (xahon) wrote :

Is this already fixed? Is there way without remapping PrScr key? No updates of `unity-settings-daemon`

unity-settings-daemon is already the newest version (15.04.1+16.04.20160701-0ubuntu1).

As of Ubuntu 14.04.5 LTS on HP Pavilion G6, this issue is not fixed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers