Selecting new dept should cancel current query

Bug #1537139 reported by Kyle Nitzsche on 2016-01-22
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Alejandro J. Cura
The Savilerow project
Undecided
Unassigned
unity-scopes-shell (Ubuntu)
High
Marcus Tomlinson

Bug Description

Selecting a new department should cancel any query currently running.

For example, open News scope. Select the Sports departments. While it is running, select the Finance department.

Unexpected result: Sports results display, but Finance department appears selected.

Related branches

Changed in unity-scopes-shell (Ubuntu):
status: New → Confirmed
Changed in canonical-devices-system-image:
importance: Undecided → High
Changed in unity-scopes-shell (Ubuntu):
importance: Undecided → High
Changed in canonical-devices-system-image:
status: New → Triaged
assignee: nobody → Alejandro J. Cura (alecu)
Changed in unity-scopes-shell (Ubuntu):
assignee: nobody → Marcus Tomlinson (marcustomlinson)
Changed in canonical-devices-system-image:
milestone: none → ww08-2016
Changed in unity-scopes-shell (Ubuntu):
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-scopes-shell - 0.5.7+16.04.20160317-0ubuntu1

---------------
unity-scopes-shell (0.5.7+16.04.20160317-0ubuntu1) xenial; urgency=medium

  [ Pawel Stolowski ]
  * Preliminary support for filters.

  [ CI Train Bot ]
  * debian/libscope-harness.symbols.in: update to released version.

  [ Marcus Tomlinson ]
  * The "FIXME" in Scope::executeCannedQuery() is no longer necessary
    since scope->invalidateResults() itself now ensures that there is
    only ever one search is in progress. (LP: #1537139)

 -- Michael Zanetti <email address hidden> Thu, 17 Mar 2016 22:35:47 +0000

Changed in unity-scopes-shell (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
Changed in savilerow:
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers