/usr/bin/unity8-dash:11:data:qGetPtrHelper:d_func:get:QQmlBoundSignalExpression::function

Bug #1410191 reported by errors.ubuntu.com bug bridge on 2015-01-13
44
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Alejandro J. Cura
unity-scopes-shell (Ubuntu)
High
Paweł Stołowski

Bug Description

Steps:
* go to any scope requiring an online account
* trigger the account creation
* wait for the web view to load
* tap the home button in the launcher

Expected:
* the account UI goes away and you're presented with the leftmost scope

The Ubuntu Error Tracker has been receiving reports about a problem regarding unity8. This problem was most recently seen with version 8.02.4+bzr1517~ubuntu15.04.1, the problem page at https://errors.ubuntu.com/problem/c4ec750d94b30e1a9388be31c466e547a26952bd contains more details.

Related branches

Michał Sawicz (saviq) wrote :

From a quick glance I can't see anything in the stacktrace that we have control over. It's just deleting objects (on shutdown, I expect) and then referencing a deleted object.

Michał Sawicz (saviq) on 2015-02-09
no longer affects: qtdeclarative-opensource-src (Ubuntu)
affects: unity8 (Ubuntu) → unity-scopes-shell (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-scopes-shell (Ubuntu):
status: New → Confirmed
Michał Sawicz (saviq) on 2015-02-09
description: updated
Michał Sawicz (saviq) wrote :

It is very likely that the attached branch will fix this.

Changed in unity-scopes-shell (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Pawel Stolowski (stolowski)
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-scopes-shell - 0.5.4+15.04.20150213-0ubuntu1

---------------
unity-scopes-shell (0.5.4+15.04.20150213-0ubuntu1) vivid; urgency=medium

  [ Pawel Stolowski ]
  * Keep temporary scopes list in the Scopes object instances and make
    Scopes the partent of temp scopes instances. Temp scopes can be
    closed (and freed) using closeScope() method of the original scope,
    or by calling closeScope() method of Scopes instance. (LP: #1410337,
    #1410191)
 -- CI Train Bot <email address hidden> Fri, 13 Feb 2015 16:47:39 +0000

Changed in unity-scopes-shell (Ubuntu):
status: In Progress → Fix Released
Brian Murray (brian-murray) wrote :

Querying the Error Tracker database using the bucket linked to in the description it appears that this may in fact not be fixed. This is a list of unity-scopes-shell package versions (found in Dependencies.txt) and the quantity of times an error report contains that version.

0.5.4+14.10.20141015-0ubuntu1: 5
0.5.4+14.10.20141029.1~rtm-0ubuntu1: 2
0.5.4+15.04.20141119-0ubuntu1: 19
0.5.4+15.04.20141205-0ubuntu1: 1
0.5.4+15.04.20141216.1-0ubuntu1: 20
0.5.4+15.04.20141216.1~rtm-0ubuntu1: 30
0.5.4+15.04.20141216~rtm-0ubuntu1: 13
0.5.4+15.04.20150120-0ubuntu1: 1
0.5.4+15.04.20150126-0ubuntu1: 3
0.5.4+15.04.20150126~rtm.is.0.5.4+15.04.20150120~rtm-0ubuntu1: 67
0.5.4+15.04.20150205-0ubuntu1: 6
0.5.4+15.04.20150206.1~rtm-0ubuntu1: 49
0.5.4+15.04.20150213-0ubuntu1: 10
0.5.4+15.04.20150226-0ubuntu1: 14
0.5.4+15.04.20150226~rtm-0ubuntu1: 50
0.5.4+15.04.20150311.3-0ubuntu1: 18
0.5.4+15.04.20150407-0ubuntu1: 59
0.5.4+15.04.20150410.2-0ubuntu1: 3

Changed in unity-scopes-shell (Ubuntu):
status: Fix Released → Triaged
kevin gunn (kgunn72) wrote :

So I've been seeing this error quite a bit during my silo testing, especially from a fresh image. I am wondering if many users experience this once during the first experience. Adding to Canonical System Image for an OTA target, i figure might be too much to ask for by 6, but targeting for 7.

Changed in canonical-devices-system-image:
assignee: nobody → Alejandro J. Cura (alecu)
importance: Undecided → High
milestone: none → ww40-2015
Changed in canonical-devices-system-image:
status: New → Confirmed
Paweł Stołowski (stolowski) wrote :

Ok, I can reproduce it with youtube scope as long as it's a temporary scope (not favorited). I've a theory about the root cause and am trying to verify that...

Changed in unity-scopes-shell (Ubuntu):
status: Triaged → In Progress
Pat McGowan (pat-mcgowan) wrote :

any updates?

Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Alejandro J. Cura (alecu) wrote :

The merge proposal is too complex to land as a bugfix, so it's been moved for OTA-8

Changed in canonical-devices-system-image:
milestone: ww40-2015 → ww46-2015
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-scopes-shell - 0.5.5+15.10.20151019-0ubuntu3

---------------
unity-scopes-shell (0.5.5+15.10.20151019-0ubuntu3) xenial; urgency=medium

  * Hard-code Python 3.5 instead of Python 3.4.

 -- Matthias Klose <email address hidden> Fri, 23 Oct 2015 21:45:34 +0200

Changed in unity-scopes-shell (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers