Settings "Display results from SCOPE" is not translated

Bug #1474944 reported by Kyle Nitzsche on 2015-07-15
48
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Alejandro J. Cura
The Savilerow project
Medium
Unassigned
Ubuntu Translations
High
Unassigned
unity-scopes-api (Ubuntu)
High
Alejandro J. Cura
unity-scopes-shell (Ubuntu)
High
Paweł Stołowski

Bug Description

Since keyword support was added, agg scopes automatically get user settings to enable/disable child scopes.

PROBLEM: Theses always display in English for me.

I flashed with a --wipe:
ubuntu-device-flash --wipe --channel=ubuntu-touch/rc-proposed/bq-aquaris.en

On first boot welcome wizard I chose Spanish/Spain.

phablet@ubuntu-phablet:~$ system-image-cli -i
current build number: 67
device name: krillin
channel: ubuntu-touch/rc-proposed/bq-aquaris.en
last update: 2015-07-15 16:17:29
version version: 67
version ubuntu: 20150715
version device: 20150529-8e13c5f
version custom: 20150709-814-29-21-vivid

See screenshot of Video agg.

Related branches

Kyle Nitzsche (knitzsche) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-scopes-api (Ubuntu):
status: New → Confirmed
description: updated
description: updated
Changed in canonical-devices-system-image:
assignee: nobody → Pat McGowan (pat-mcgowan)
importance: Undecided → High
milestone: none → ww34-2015
status: New → Confirmed
Changed in unity-scopes-api (Ubuntu):
assignee: nobody → Alejandro J. Cura (alecu)
importance: Undecided → High
Pat McGowan (pat-mcgowan) wrote :

see https://translations.launchpad.net/unity-scopes-shell/ trunk/+pots/unity-plugin-scopes/es/1/+translate

Need to prompt the translators, may need to up some priority settings on our templates

Changed in savilerow:
status: New → Invalid
Michi Henning (michihenning) wrote :

This isn't a problem in scopes-api. I suspect the shell is responsible, seeing that it constructs the settings page.

Changed in unity-scopes-api (Ubuntu):
status: Confirmed → Invalid
Kyle Nitzsche (knitzsche) wrote :

mark as "triaged" in savilerow to indicate it affects savilerow but cannot be fixed by savilerow.

Changed in savilerow:
status: Invalid → Triaged
Changed in unity-scopes-shell (Ubuntu):
assignee: nobody → Alejandro J. Cura (alecu)
importance: Undecided → High
status: New → Confirmed
Changed in unity-scopes-shell (Ubuntu):
assignee: Alejandro J. Cura (alecu) → Pawel Stolowski (stolowski)
Paweł Stołowski (stolowski) wrote :

The string is marked translatable and available in the pot file as "Display results from %1", we're just missing translations.

Changed in canonical-devices-system-image:
assignee: Pat McGowan (pat-mcgowan) → David Planella (dpm)

Just to confirm Pawel's comment, the fix to localise this string was released in 0.5.4+15.10.20150601-0ubuntu1.

David Planella (dpm) wrote :

A call was sent to translators on the 16th of June [1], and the upstream project is translated into 23 languages already:

https://translations.launchpad.net/unity-scopes-shell/trunk

It seems like the target languages for bq are covered there too.

Depending on whether the translations are shipped in a click package or as a .deb package, the developer will need to do some work to integrate and ship the translations.

Looking at https://translations.launchpad.net/ubuntu/wily/+source/unity-scopes-shell it seems it's shipped as a .deb package, in which case, I'd recommend using the same setup as other scopes shipped by default. In summary, it's about ensuring that the .deb package generates a .pot file on build, which boils down to:

1. Add X-Ubuntu-Use-Langpack: yes to debian/control's source record
2. Use dh_translations to generate a POT file during the build process.

[1] https://lists.ubuntu.com/archives/ubuntu-translators/2015-July/006949.html

Changed in ubuntu-translations:
status: New → Fix Committed
importance: Undecided → High
tags: added: tracking
Changed in savilerow:
importance: Undecided → Medium
Bill Filler (bfiller) on 2015-08-19
Changed in canonical-devices-system-image:
assignee: David Planella (dpm) → Alejandro J. Cura (alecu)
milestone: ww34-2015 → ww40-2015
Pat McGowan (pat-mcgowan) wrote :

still open?

Changed in canonical-devices-system-image:
milestone: ww40-2015 → ww46-2015
Changed in unity-scopes-shell (Ubuntu):
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Changed in unity-scopes-shell (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Released
Kyle Nitzsche (knitzsche) wrote :

invalid because the fix was in another project: unity-scopes-shell

Changed in savilerow:
status: Triaged → Confirmed
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers