unity-scope-video-remote crashed with GError in on_activate_uri(): Failed to execute child process "/usr/bin/gvfs-open" (No such file or directory)

Bug #972304 reported by crtm on 2012-04-03
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity Videos Lens
Undecided
Unassigned
unity-scope-video-remote (Ubuntu)
Medium
Unassigned
Precise
Low
Unassigned

Bug Description

[Test Case]
1. On a Precise system, run 'sudo apt-get remove gvfs-bin' to remove the gvfs-bin package (installed by default in Ubuntu).
2. Confirm that the unity-scope-video-remote package is still installed.
3. Run '/usr/lib/unity-scope-video-remote/unity-scope-video-remote'.
4. Click on a result from the Online section of the Video lens.
5. Confirm that the program crashes.
6. Upgrade to unity-scope-video-remote from precise-proposed.
7. Confirm that the gvfs-bin package is pulled in as a dependency.
8. Run '/usr/lib/unity-scope-video-remote/unity-scope-video-remote' again.
9. Confirm that the program does not crash.

[Regression Potential]
Minimal, as the missing dependency is already part of the default Ubuntu install.

Original description:

when start, then crash

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: unity-scope-video-remote 0.3.4-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-21.34-generic 3.2.13
Uname: Linux 3.2.0-21-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0-0ubuntu3
Architecture: amd64
CrashCounter: 1
Date: Tue Apr 3 07:21:49 2012
ExecutablePath: /usr/lib/unity-scope-video-remote/unity-scope-video-remote
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/lib/unity-scope-video-remote/unity-scope-video-remote
PythonArgs: ['/usr/lib/unity-scope-video-remote/unity-scope-video-remote']
SourcePackage: unity-scope-video-remote
Title: unity-scope-video-remote crashed with GError in on_activate_uri(): Failed to execute child process "/usr/bin/gvfs-open" (No such file or directory)
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin audio cdrom dialout dip fax floppy fuse lpadmin netdev plugdev sambashare scanner tape vboxusers video

crtm (carlosrtm) wrote :
tags: removed: need-duplicate-check
Changed in unity-scope-video-remote (Ubuntu):
importance: Undecided → Medium
Sebastien Bacher (seb128) wrote :

the package should either depends on gvfs-bin or the code should handle gvfs-open not being installed

visibility: private → public
David Callé (davidc3) on 2012-06-27
Changed in unity-lens-videos:
status: New → Invalid
Changed in unity-scope-video-remote (Ubuntu):
status: New → Fix Committed
description: updated
description: updated
Changed in unity-lens-videos:
status: Invalid → Fix Committed
Changed in unity-scope-video-remote (Ubuntu Precise):
importance: Undecided → Low
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-scope-video-remote - 0.3.6-0ubuntu1

---------------
unity-scope-video-remote (0.3.6-0ubuntu1) quantal; urgency=low

  [ Łukasz 'sil2100' Zemczak ]
  * New upstream release.
    - Exit on DBus hickup at startup, Unity will restart the scope (LP: #950862)
  * debian/control:
    - Depends on gvfs-bin (LP: #972304)

  [ Didier Roche ]
  * Adding Vcs-Bzr
  * point the new location to the canonical directory
    (lp:ubuntu/unity-lens-video) after the conversion in a merge-upstream
    source
 -- Didier Roche <email address hidden> Fri, 29 Jun 2012 10:37:01 +0200

Changed in unity-scope-video-remote (Ubuntu):
status: Fix Committed → Fix Released

Hello crtm, or anyone else affected,

Accepted unity-scope-video-remote into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity-scope-video-remote/0.3.5-0ubuntu2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

description: updated
Changed in unity-scope-video-remote (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
David Callé (davidc3) on 2012-07-02
description: updated
description: updated
Sami Jaktholm (sjakthol) wrote :

Package in -proposed fixed this bug.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-scope-video-remote - 0.3.5-0ubuntu2.1

---------------
unity-scope-video-remote (0.3.5-0ubuntu2.1) precise-proposed; urgency=low

  * Exit on DBus hickup at startup, Unity will restart the scope (LP: #950862)
  * Depends on gvfs-bin (LP: #972304)
 -- David Calle <email address hidden> Wed, 27 Jun 2012 20:33:46 +0200

Changed in unity-scope-video-remote (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in unity-lens-videos:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers