Source file’s copyright information is incomplete

Bug #1260105 reported by Frederik Elwert on 2013-12-11
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
unity-scope-texdoc (Ubuntu)
Undecided
Mark Tully

Bug Description

I am the author of the original version of the texdoc scope. The original code can be found here: https://code.launchpad.net/~frederik-elwert/askubuntu-lens/add_texdoc_scope

In my original version, the copyright header was:

# Copyright (C) 2012 Frederik Elwert <email address hidden>
# 2012 Pawel Stolowski <email address hidden>
# 2012 Mark Tully <email address hidden>

Now in the current version, /usr/share/unity-scopes/texdoc/unity_texdoc_daemon.py only contains this copyright header:

# Copyright(C) 2013 Mark Tully <email address hidden>

While the new implementation has changed in many ways, some pieces of my code are still in the current version. I am quite surprised to see the corresponding copyright information removed.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: unity-scope-texdoc 0.1+13.10.20130723-0ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-12.19~lp1195483v2-generic 3.11.3
Uname: Linux 3.11.0-12-generic x86_64
ApportVersion: 2.12.5-0ubuntu2.1
Architecture: amd64
Date: Wed Dec 11 23:32:04 2013
EcryptfsInUse: Yes
InstallationDate: Installed on 2013-07-20 (144 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: unity-scope-texdoc
UpgradeStatus: Upgraded to saucy on 2013-10-12 (60 days ago)

Related branches

description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-scope-texdoc (Ubuntu):
status: New → Confirmed
Mark Tully (markjtully) on 2013-12-16
Changed in unity-scope-texdoc (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Mark Tully (markjtully)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-scope-texdoc - 0.1+14.04.20140328-0ubuntu1

---------------
unity-scope-texdoc (0.1+14.04.20140328-0ubuntu1) trusty; urgency=low

  [ David Callé ]
  * Don't crash Unity bindings when building results. (LP: #1274669)

  [ Mark Tully ]
  * Fix copyright attributions. (LP: #1260105)
 -- Ubuntu daily release <email address hidden> Fri, 28 Mar 2014 09:13:54 +0000

Changed in unity-scope-texdoc (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers