unity should Depends on unity-scope-home

Bug #1233029 reported by Greg A on 2013-09-30
86
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Unassigned
unity (Ubuntu)
High
Unassigned
Saucy
High
Unassigned
Trusty
High
Unassigned
unity-scope-home (Ubuntu)
Undecided
Unassigned
Saucy
Undecided
Unassigned
Trusty
Undecided
Unassigned

Bug Description

On my upgrade from 13.04 to 13.10 then my Dash showed only applications. This regression meant all other scopes (though appearing to be selected) did not produce any results.

It turns out that installing the unity-scope-home package fixed the regression. In order to prevent more confused users, we should somehow ensure this package is installed when upgrading.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: unity-scope-home 6.8.2+13.10.20130927-0ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-8.15-generic 3.11.1
Uname: Linux 3.11.0-8-generic x86_64
ApportVersion: 2.12.4-0ubuntu1
Architecture: amd64
CheckboxSubmission: 346c69198d9a34d2dea85736f0dd6571
CheckboxSystem: b633b4f40868d491c2ae5b50030ce6f3
Date: Sun Sep 29 18:01:53 2013
InstallationDate: Installed on 2012-07-14 (442 days ago)
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
MarkForUpload: True
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: unity-scope-home
UpgradeStatus: Upgraded to saucy on 2013-09-24 (4 days ago)

Related branches

Greg A (etulfetulf) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-meta (Ubuntu):
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity-scope-home (Ubuntu):
status: New → Confirmed
Stephen M. Webb (bregma) wrote :

Marked as Invalid for Unity and unity-scope-home beacsue all the required package dependencies are there and should work swimmingly on a normal upgrade.

Changed in unity-scope-home (Ubuntu):
status: Confirmed → Invalid
Changed in unity (Ubuntu):
status: Confirmed → Invalid
Jan Groenewald (jan-aims) wrote :

Mine unity-scope-home was missing too after an upgrade.

Brian Murray (brian-murray) wrote :

Could somebody please add the log files from their upgrade, found in '/var/log/dist-upgrade/' to this bug report. Thanks in advance.

Changed in ubuntu-meta (Ubuntu):
status: Confirmed → Incomplete
  • lspci.txt Edit (2.6 KiB, text/plain; charset=US-ASCII; name="lspci.txt")
  • apt.log Edit (40.0 KiB, application/octet-stream; name="apt.log")
  • apt-term.log Edit (391.2 KiB, application/octet-stream; name="apt-term.log")
  • history.log Edit (133.0 KiB, application/octet-stream; name="history.log")
  • main.log Edit (63.6 KiB, application/octet-stream; name="main.log")
  • xorg_fixup.log Edit (77 bytes, application/octet-stream; name="xorg_fixup.log")

screenlog.0 is 21M and google does not want to attach
apt-clone_system_state.tar.gz right now.
Here are the rest.

I think something did go wrong with do-release-upgrade, and there were
earlier attempts:
0 jan@osprey:~$ls /var/log/dist-upgrade/20131016-10* -d
/var/log/dist-upgrade/20131016-1014 /var/log/dist-upgrade/20131016-1023
/var/log/dist-upgrade/20131016-1018
0 jan@osprey:~$

On 17 October 2013 19:32, Brian Murray <email address hidden> wrote:

> Could somebody please add the log files from their upgrade, found in
> '/var/log/dist-upgrade/' to this bug report. Thanks in advance.
>
> ** Changed in: ubuntu-meta (Ubuntu)
> Status: Confirmed => Incomplete
>
> --
> You received this bug notification because you are a member of AIMS,
> which is subscribed to the bug report.
> https://bugs.launchpad.net/bugs/1233029
>
> Title:
> unity-scope-home not a dependency of ubuntu-desktop
>
> Status in “ubuntu-meta” package in Ubuntu:
> Incomplete
> Status in “unity” package in Ubuntu:
> Invalid
> Status in “unity-scope-home” package in Ubuntu:
> Invalid
>
> Bug description:
> On my upgrade from 13.04 to 13.10 then my Dash showed only
> applications. This regression meant all other scopes (though appearing
> to be selected) did not produce any results.
>
> It turns out that installing the unity-scope-home package fixed the
> regression. In order to prevent more confused users, we should somehow
> ensure this package is installed when upgrading.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 13.10
> Package: unity-scope-home 6.8.2+13.10.20130927-0ubuntu1
> ProcVersionSignature: Ubuntu 3.11.0-8.15-generic 3.11.1
> Uname: Linux 3.11.0-8-generic x86_64
> ApportVersion: 2.12.4-0ubuntu1
> Architecture: amd64
> CheckboxSubmission: 346c69198d9a34d2dea85736f0dd6571
> CheckboxSystem: b633b4f40868d491c2ae5b50030ce6f3
> Date: Sun Sep 29 18:01:53 2013
> InstallationDate: Installed on 2012-07-14 (442 days ago)
> InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64
> (20120425)
> MarkForUpload: True
> ProcEnviron:
> LANGUAGE=en_GB:en
> PATH=(custom, no user)
> XDG_RUNTIME_DIR=<set>
> LANG=en_GB.UTF-8
> SHELL=/bin/bash
> SourcePackage: unity-scope-home
> UpgradeStatus: Upgraded to saucy on 2013-09-24 (4 days ago)
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/ubuntu-meta/+bug/1233029/+subscriptions
>
> --
> Mailing list: https://launchpad.net/~aims
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~aims
> More help : https://help.launchpad.net/ListHelp
>

--
  .~.
  /V\ Jan Groenewald
 /( )\ www.aims.ac.za
 ^^-^^

Also happened to me after a default upgrade to 13.10. Might be related to #1220572.

Sebastien Bacher (seb128) wrote :

Unity should depends on it, rather than recommends (mhr3 and didrocks said they agree with that)

no longer affects: ubuntu-meta (Ubuntu)
Changed in unity (Ubuntu):
importance: Undecided → High
status: Invalid → Triaged
summary: - unity-scope-home not a dependency of ubuntu-desktop
+ unity should Depends on unity-scope-home

same here, how this packade can be left out in a first place?

laulau (olaulau) wrote :

same here, unity-scope-home missing after upgrade 13.04 -> 13.10
so dash doesn't return anything, which is blocking for non-advanced users.

Changed in unity (Ubuntu Saucy):
status: New → Triaged
importance: Undecided → High
Changed in unity-scope-home (Ubuntu Saucy):
status: New → Invalid
Changed in unity (Ubuntu Trusty):
status: Triaged → Fix Committed
Changed in unity (Ubuntu Saucy):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.1.2+14.04.20140217-0ubuntu1

---------------
unity (7.1.2+14.04.20140217-0ubuntu1) trusty; urgency=low

  [ Luke Yelavich ]
  * QuickListMenuItem: Add GetPlainTextLabel method to better present
    quicklist menu items to screen reader users. When Orca users
    navigate quicklists, they hear something like <b>item name</b>, due
    to the markup for the item being used as the accessible label. Use
    the ACCESSIBLE_DESC property of dbusmenu menu items to provide a
    plain text form of the label. (LP: #1266656)

  [ Sebastien Bacher ]
  * Restore archive change dropped by error, let g-s-d run in Unity
    sessions

  [ Niklas Steger ]
  * Add missing unity-scope-home dependency. (LP: #1233029)

  [ Chris Townsend ]
  * Fix some more AP tests: Redo the Hud query method to account for the
    fact that the Hud button we want may not be the first entry. Fix a
    show desktop test so we get the correct show desktop state after the
    test exits. Fix a Spread test to get the mouse to move to the
    Launcher icon that we want. .
 -- Ubuntu daily release <email address hidden> Mon, 17 Feb 2014 14:02:37 +0000

Changed in unity (Ubuntu Trusty):
status: Fix Committed → Fix Released
Changed in unity:
importance: Undecided → High
status: New → Fix Released
Changed in unity (Ubuntu Saucy):
status: Fix Committed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers