Apps scope not shown in the dash (but is installed)

Bug #1603186 reported by fcole90 on 2016-07-14
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Undecided
Unassigned
unity-scope-click (Ubuntu)
Undecided
Unassigned
unity-scopes-shell (Ubuntu)
High
Paweł Stołowski
unity8 (Ubuntu)
Undecided
Unassigned

Bug Description

When opening the dash I just see Music, XApps and Videos scope. But there is no Apps scope.

The only way to reach the Apps scope is opening the menu from the bottom edge and selecting it from there.

So the scope is there and installed, the problem is that's not among the enabled (starred) scopes (and there's no way to enable it).

This bug is not a duplicate of #1579551:
 - I am able to launch apps, I'm just missing the Apps scope
 - unity-scope-click is already installed, but the problem is still there

Related branches

Stephen M. Webb (bregma) wrote :

Thanks for trying to improve Unity 8 on the desktop.

I haven't seen this particular behaviour on any system I have tested. Could you please attach a screenshot of this problem so we can try to analyze the cause?

Changed in unity8-desktop-session (Ubuntu):
status: New → Incomplete
fcole90 (fcole90) wrote :

How can I take a screenshot in mir?

fcole90 (fcole90) wrote :
Daniel van Vugt (vanvugt) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 1579551, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

fcole90 (fcole90) wrote :

This bug is not a duplicate of #1579551:
 - I am able to launch apps, I'm just missing the Apps scope
 - unity-scope-click is already installed, but the problem is still there

fcole90 (fcole90) wrote :

As explained in the description, I can reach the Apps scope if I open the bottom edge and I select it, the problem is that's not among the enabled scopes (and there's no way to enable it).

description: updated
Daniel van Vugt (vanvugt) wrote :

Check that you have the following deb package installed: unity-scope-click

If it's missing then this is bug 1579551

Daniel van Vugt (vanvugt) wrote :

Oh, you did that already, sorry.

affects: unity8-desktop-session (Ubuntu) → unity-scope-click (Ubuntu)
Changed in unity-scope-click (Ubuntu):
status: Incomplete → New
summary: - Apps scope not shown in the dash
+ Apps scope not shown in the dash (but is installed)
fcole90 (fcole90) wrote :

No problem ;)
Current version of unity-scope-click is (0.1.1+16.10.20160705-0ubuntu1).

kevin gunn (kgunn72) wrote :

ok, duping another bug, but it had this info in it
https://paste.ubuntu.com/19904324/
that's olli's /var/log/apt/term.log, i was helping him get setup and he had this exact situation.

@Fabio can you check if the apps scope appears in the scope manager list? (bottom swipe up while in the dash)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-scope-click (Ubuntu):
status: New → Confirmed
Changed in unity8 (Ubuntu):
status: New → Confirmed
fcole90 (fcole90) wrote :

Yes, it does. You can see it in the comment #4

fcole90 (fcole90) wrote :

I can even open it from the scope manager, it's just not shown among the enabled scopes

fcole90 (fcole90) wrote :

Reinstalling unity-scope-click didn't change the situation

Paweł Stołowski (stolowski) wrote :

From the symptoms it seems that the list of favorited scopes got messed up somehow. Did you uninstall unity-scope-click scope before at any point?

This list can be (re)set with e.g.
$ gsettings set com.canonical.Unity.Dash favorite-scopes "['scope://unity-scope-nearby', 'scope://clickscope']"`

or
$ gsettings reset com.canonical.Unity.Dash favorite-scopes

I think the problem we have is that on the phone we assumed click-scope would never be uninstalled (it's impossible to uninstall it via the UI) and therefore it's impossible to star/unstar it in the UI (it's always "starred"). If however the scope disappears from the system, it's also removed from favorites and there is no way to favorite it back even after manually installing the scope again.

Adding unity-scopes-shell as I think it needs to deal with the above scenario.

Changed in unity-scope-click (Ubuntu):
status: Confirmed → Invalid
Changed in unity-scopes-shell (Ubuntu):
status: New → Confirmed
importance: Undecided → High
fcole90 (fcole90) wrote :

This indeed solved the problem. I'm not sure if I ever removed it, but I can't exclude it

Changed in unity-scopes-shell (Ubuntu):
status: Confirmed → Triaged
kevin gunn (kgunn72) on 2016-07-21
tags: added: unity8-desktop
Changed in unity-scopes-shell (Ubuntu):
assignee: nobody → Paweł Stołowski (stolowski)
status: Triaged → In Progress
Stephen M. Webb (bregma) on 2016-07-25
Changed in canonical-devices-system-image:
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-scopes-shell - 0.5.8+16.10.20161004-0ubuntu1

---------------
unity-scopes-shell (0.5.8+16.10.20161004-0ubuntu1) yakkety; urgency=medium

  [ Albert Astals Cid ]
  * Optimize ResultsModel::data a bit
  * Save creating/destroying a QSharedPointer

  [ Marcus Tomlinson ]
  * Don't make changes to the settings model from a separate thread.
    (LP: #1627795)

  [ Pawel Stolowski ]
  * Optimize scope favoriting. Make sure click scope is favorited back
    if reinstalled. (LP: #1583067, #1603186)

 -- Marcus Tomlinson <email address hidden> Tue, 04 Oct 2016 09:00:09 +0000

Changed in unity-scopes-shell (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers