[Ubuntu Phone Store] No message when no applications found

Bug #1421718 reported by costales on 2015-02-13
52
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Ubuntu UX
Medium
Alex Milazzo
unity-scope-click (Ubuntu)
Low
Unassigned
unity8 (Ubuntu)
Undecided
Unassigned

Bug Description

Hi!

Steps:
1. Open Store.
2. Search RRS (Not RSS).
3. Bug: Nothing found, but you can't see a message for this.
4. Search RSS.
5. OK: You see 5 applications found message.

Thanks in advance!

------------------------------
Desired resolution:

This is part of a bigger redesign project (Scopes toolkit) and it can't be fixed as a single bug. The description and specs will be updated as soon as they are available.

dobey (dobey) wrote :

This is a bit difficult, because categories are only shown if they have results in them. So a category of "0 results in Ubuntu Store" can't be shown without results. A bit of a chicken/egg problem, so I've added Unity to the bug. This may be in unity-scopes-shell instead of unity8 itself though.

costales (costales) wrote :

Hi Rodney :)
I wasn't talking about "categories", I'm talking about a search in the Store without results for that search.
Best regards!

Albert Astals Cid (aacid) wrote :

You can always inject a fake result when there's no results and send it up, no?

dobey (dobey) wrote :

@costales Each section of results is called a category. When you get results and see "5 results in Music" that is the category header. It is only displayed when there are results.

@Albert I suppose we could, but then we'd have a fake result which is being displayed and which would result in a preview being requested when tapped. I don't think it would look good, and I can't think of way to display that there are no results, without having a result, right now.

Albert Astals Cid (aacid) wrote :

@Rodney The user can't tap on the result if you return a template that sets the "non-interactive" flag

Not sure if the architecture works for you sendng different templates depending if you have proper results or not, but it's worth a try i'd say

Albert Astals Cid (aacid) wrote :

That or we could ask the scopes to provide a "no results found string" for the shell to use, otherwise it'd be a bit weird for us trying to guess what string to show there i think.

dobey (dobey) wrote :

@Albert Could the shell not display "No results" if the SearchReply pointer has been destroyed and no results were pushed? I'm not sure there would need to be a special string for that.

The only issue I see with that, is that there's no way to differentiate between no actual results, and the network not being available, or being slow, when the scope needs network. But I think that is a separate issue that needs a separate solution, too.

Albert Astals Cid (aacid) wrote :

I don't think it's a separate issue at all, and the only one that knows everything to decide is the scope, us at the shell we have just dumb data showing code, the one with all the knowledge to decide if to show a message and what to show is the scope.

Alejandro J. Cura (alecu) wrote :

Before deciding *who* needs to show it, we need to know *what* to show.
I'm adding Ubuntu UX to the discussion to get some design feedback.

Alejandro J. Cura (alecu) wrote :

Btw, there are designs and client-side code to show "recommendations" that come from the server, and there are even a few queries that return some recommendations.

And the server ought to be smart enough to return RSS apps in the Recommendations category when the user searches for RRS, (or Telegram when the user seaches for Whatsapp) but let's keep this bug for when the server does not return any useful result at all.

tags: added: usability
summary: - Ubuntu Phone Store: No message when no applications found
+ [Ubuntu Phone Store] No message when no applications found
Changed in ubuntu-ux:
assignee: nobody → James Mulholland (jamesjosephmulholland)
Changed in ubuntu-ux:
assignee: James Mulholland (jamesjosephmulholland) → nobody
assignee: nobody → Magdalena Mirowicz (magdalena-mirowicz)
status: New → Triaged
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-scope-click (Ubuntu):
status: New → Confirmed
Changed in unity8 (Ubuntu):
status: New → Confirmed
Changed in ubuntu-ux:
assignee: Magdalena Mirowicz (magdalena-mirowicz) → Paty Davila (dizzypaty)
Albert Astals Cid (aacid) wrote :

unity8 waiting for design -> Incomplete

Changed in unity8 (Ubuntu):
status: Confirmed → Incomplete
Changed in ubuntu-ux:
assignee: Paty Davila (dizzypaty) → Jouni Helminen (jounihelminen)
John Lea (johnlea) on 2015-07-30
Changed in ubuntu-ux:
assignee: Jouni Helminen (jounihelminen) → Alex Milazzo (digitalalex)
importance: Undecided → Medium
description: updated
Changed in ubuntu-ux:
status: Triaged → Fix Released
John Lea (johnlea) on 2015-08-04
Changed in ubuntu-ux:
status: Fix Released → In Progress
description: updated
Alex Milazzo (digitalalex) wrote :

Will be closing this bug since the desired solution won't match the bug issue. This bug relates to the entire update of the scope toolkit that will be publishing shortly.

Changed in ubuntu-ux:
status: In Progress → Won't Fix
Changed in unity8 (Ubuntu):
status: Incomplete → Won't Fix
no longer affects: canonical-devices-system-image
dobey (dobey) on 2016-01-20
Changed in unity-scope-click (Ubuntu):
importance: Undecided → Low
tags: added: bq-feedback
Norbert (nrbrtx) wrote :

BQ M10, OTA-13.
Ubuntu Store show empty window as search result.
Why? I do not know. Slow/broken internet connection? Timeout? Search term is not found in App/Scope database?

Please show verbose message for user for at least these variants:
* search term not found;
* timeout occured, please try again;
* unknown error occured.

Norbert (nrbrtx) wrote :

Same on M10 with OTA-15.

tags: added: bq m10 touch
Norbert (nrbrtx) wrote :

ame on M10 with rc-proposed r268.

Norbert (nrbrtx) wrote :

Same on M10 with rc-proposed r268.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers