Departments in Apps don't match Store

Bug #1352451 reported by Paweł Stołowski
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
unity-scope-click (Ubuntu)
Fix Released
Undecided
Paweł Stołowski

Bug Description

The departments menu in Apps scope has some extra top-level departments, such as "3D", that don't exist in the Store.

There are three causes for this issue, all connected:
1) we have entries in the departments db with locale "", and they are used as a fallback for name lookups
2) we never update it while refreshing departments in the Store scope, as we use non-empty locale ("en_US" by default, or whatever reported by the shell), and only update entries for that locale.
3) the SQL query used for depts_v uses a join against deptnames table, but since the statement is not restricted for a specific locale, it just uses all names, including the ones that are never updated because of (2).

Tags: rtm14

Related branches

Changed in unity-scope-click (Ubuntu):
assignee: nobody → Pawel Stolowski (stolowski)
status: New → Confirmed
description: updated
description: updated
description: updated
description: updated
Changed in unity-scope-click (Ubuntu):
status: Confirmed → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-scope-click - 0.1+14.10.20140807.1-0ubuntu1

---------------
unity-scope-click (0.1+14.10.20140807.1-0ubuntu1) utopic; urgency=medium

  [ Alejandro J. Cura (alecu) ]
  * New upstream release.
    - After uninstall, show the dash instead of a canned query. (LP: #1352879)
    - A separate category for available scopes. (LP: #1350565)
    - Changes in department database to better match store departments.
      (LP: #1352451)
    - Updated translations.

  [ Ubuntu daily release ]
  * New rebuild forced
 -- Ubuntu daily release <email address hidden> Thu, 07 Aug 2014 02:48:46 +0000

Changed in unity-scope-click (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers