Inline translations from .desktop files are not loaded

Bug #1325626 reported by David Planella on 2014-06-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Calculator App
Undecided
Unassigned
Ubuntu Calendar App
High
David Planella
Ubuntu Clock App
Medium
David Planella
Ubuntu File Manager App
Medium
David Planella
Ubuntu Music App
High
Andrew Hayzen
Ubuntu Shorts App
Medium
Unassigned
Ubuntu Terminal App
Medium
David Planella
Ubuntu Weather App
High
David Planella
camera-app
Fix Released
High
Florian Boucault
gallery-app
Fix Released
High
Ugo Riboni
notes-app
Medium
Ugo Riboni
camera-app (Ubuntu)
High
Unassigned
gallery-app (Ubuntu)
Undecided
Unassigned
unity-scope-click (Ubuntu)
Low
Unassigned

Bug Description

Using image #60, and the Calculator app as an example, the inline translations of its desktop files are not loaded.

Steps to reproduce:

1. Set the system locale (System Settings > Language & Text) to Spanish or Simplified Chinese
2. Reboot the phone
Go to My Apps on the click scope

Actual:
- "Calculator" appears untranslated beneath the Calculator icon

Expected:
- "Calculator" appears translated beneath the Calculator icon (if inline translations are available in its .desktop file)

Related branches

David Planella (dpm) on 2014-06-02
tags: added: touch-cn
dobey (dobey) on 2014-06-05
Changed in unity-scope-click (Ubuntu):
status: New → Confirmed
importance: Undecided → Critical
dobey (dobey) wrote :

The scope code is behaving correctly. The problem is that the apps all still have the X-Gettext-Domain= field in their .desktop files. Removing this field results in the translations being loaded correctly. The apps will need to fixed and re-uploaded to the store, with that fix.

Changed in unity-scope-click (Ubuntu):
importance: Critical → Low
status: Confirmed → Invalid
Changed in ubuntu-calculator-app:
status: New → Confirmed
dobey (dobey) on 2014-06-05
description: updated
Victor Thompson (vthompson) wrote :

If the apps need to be uploaded to the store to test this fix, does that also mean that I can't fix this and deploy the click on my device and verify that it works? Or should each app just assume this will work?

Victor, you don't need to re-upload to the store to verify that fix, you
can test it with a locally-installed package. I've just tested it locally
with Calculator by modifying its .desktop file on the device.

On Fri, Jun 6, 2014 at 6:45 AM, Victor Thompson <email address hidden>
wrote:

> If the apps need to be uploaded to the store to test this fix, does that
> also mean that I can't fix this and deploy the click on my device and
> verify that it works? Or should each app just assume this will work?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> Matching subscriptions: File Manager App Bugmail, Ubuntu RSS Reader Bugmail
> https://bugs.launchpad.net/bugs/1325626
>
> Title:
> Inline translations from .desktop files are not loaded
>
> Status in Camera App:
> New
> Status in Dropping Letters:
> New
> Status in Gallery App:
> New
> Status in Music application for Ubuntu devices:
> New
> Status in Notes App:
> New
> Status in Sudoku game for Ubuntu Touch:
> New
> Status in Calculator application for Ubuntu devices:
> Confirmed
> Status in Calendar application for Ubuntu devices:
> New
> Status in Clock application for Ubuntu devices:
> New
> Status in File Manager application for Ubuntu devices:
> New
> Status in RSS Feed Reader application for Ubuntu devices:
> New
> Status in Terminal application for Ubuntu devices:
> New
> Status in Weather application for Ubuntu devices:
> New
> Status in “unity-scope-click” package in Ubuntu:
> Invalid
>
> Bug description:
> Using image #60, and the Calculator app as an example, the inline
> translations of its desktop files are not loaded.
>
> Steps to reproduce:
>
> 1. Set the system locale (System Settings > Language & Text) to Spanish
> or Simplified Chinese
> 2. Reboot the phone
> Go to My Apps on the click scope
>
> Actual:
> - "Calculator" appears untranslated beneath the Calculator icon
>
> Expected:
> - "Calculator" appears translated beneath the Calculator icon (if inline
> translations are available in its .desktop file)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/camera-app/+bug/1325626/+subscriptions
>

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:ubuntu-calculator-app at revision 278, scheduled for release in ubuntu-calculator-app, milestone 1.6

Changed in ubuntu-calculator-app:
status: Confirmed → Fix Committed
Changed in ubuntu-clock-app:
importance: Undecided → Medium
assignee: nobody → David Planella (dpm)
Andrew Hayzen (ahayzen) on 2014-06-06
Changed in music-app:
assignee: nobody → Andrew Hayzen (andrew-hayzen)
importance: Undecided → High
status: New → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:ubuntu-clock-app at revision 430, scheduled for release in ubuntu-clock-app, milestone 2.2

Changed in ubuntu-clock-app:
status: New → Fix Committed

Fix committed into lp:music-app at revision 483, scheduled for release in music-app, milestone 1.0

Changed in music-app:
status: In Progress → Fix Committed
David Planella (dpm) on 2014-06-06
no longer affects: dropping-letters
David Planella (dpm) on 2014-06-06
Changed in ubuntu-weather-app:
assignee: nobody → David Planella (dpm)
status: New → In Progress
Changed in ubuntu-calculator-app:
status: Fix Committed → Fix Released
Changed in ubuntu-clock-app:
status: Fix Committed → Fix Released
Changed in music-app:
status: Fix Committed → Fix Released
Changed in ubuntu-calendar-app:
assignee: nobody → David Planella (dpm)
importance: Undecided → High
status: New → In Progress

Fix committed into lp:ubuntu-calendar-app at revision 305, scheduled for release in ubuntu-calendar-app, milestone alpha-1

Changed in ubuntu-calendar-app:
status: In Progress → Fix Committed
Changed in camera-app:
importance: Undecided → High
Changed in camera-app:
status: New → Confirmed
Changed in ubuntu-calendar-app:
status: Fix Committed → Fix Released

Fix committed into lp:ubuntu-weather-app at revision 335, scheduled for release in ubuntu-weather-app, milestone alpha-1

Changed in ubuntu-weather-app:
status: In Progress → Fix Committed
tags: added: rtm14
Changed in camera-app:
milestone: none → rtm-freeze
Changed in camera-app:
assignee: nobody → Florian Boucault (fboucault)
Changed in camera-app:
milestone: rtm-freeze → none
Bill Filler (bfiller) on 2014-08-29
tags: added: touch-2014-09-11
Changed in camera-app:
status: Confirmed → In Progress
Bill Filler (bfiller) on 2014-09-03
Changed in gallery-app:
assignee: nobody → Ugo Riboni (uriboni)
status: New → Confirmed
importance: Undecided → High
Changed in notes-app:
assignee: nobody → Ugo Riboni (uriboni)
importance: Undecided → High
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package camera-app - 3.0.0+14.10.20140903-0ubuntu1

---------------
camera-app (3.0.0+14.10.20140903-0ubuntu1) utopic; urgency=low

  [ Michał Sawicz ]
  * Add :any to python dependency and install the camera app module in
    app-private libdir.

  [ Ugo Riboni ]
  * Add translations inside the .desktop file (LP: #1318008)

  [ Florian Boucault ]
  * Disable mode switching while recording videos.
  * Disable camera switching while recording videos. (LP: #1358302)
  * Photo roll: more fine grained media folder monitoring as to properly
    forward deletions to the view. Workarounded a couple of Qt bugs
    related to snapMode SnapOneItem. (LP: #1355407)
  * Do not allow switching to the camera roll while recording a video.
  * Rename application from 'camera' to 'com.ubuntu.camera' to make
    state saving work again. Seamlessly transition ~/Pictures/camera and
    ~/Videos/camera to new locations. (LP: #1363112)
  * Remove the X-Ubuntu-Gettext-Domain from the .desktop file, which
    causes the click scope not to load the inline translations. (LP:
    #1325626)
  * Align snapshot with viewfinder as to assure visual continuity in the
    transition from one to the other. (LP: #1362822)
  * Added cancel button in content export mode. (LP: #1362823)
 -- Ubuntu daily release <email address hidden> Wed, 03 Sep 2014 18:52:44 +0000

Changed in camera-app (Ubuntu):
status: New → Fix Released
Bill Filler (bfiller) on 2014-09-05
Changed in camera-app (Ubuntu):
importance: Undecided → High
Changed in camera-app:
status: In Progress → Fix Released
Bill Filler (bfiller) on 2014-09-12
tags: added: touch-2014-09-25
removed: touch-2014-09-11
Ugo Riboni (uriboni) on 2014-09-15
Changed in gallery-app:
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gallery-app - 0.0.67+14.10.20140917-0ubuntu1

---------------
gallery-app (0.0.67+14.10.20140917-0ubuntu1) utopic; urgency=low

  [ Ugo Riboni ]
  * Translate the .desktop file inline (LP: #1325626)

  [ Albert Astals ]
  * Update .pot

  [ Benjamin Zeller ]
  * Make sure gallery-app cmake project works out of the box in the SDK:
    Enable click mode by default. Disable click mode in debian rules
    file. Add variable UBUNTU_MANIFEST_PATH variable so QtC knows where
    to look. for the manifest file Rename gallery-apparmor.json =>
    gallery.apparmor (editor support). Automatically substitute the
    click architecture in the manifest file .

  [ Víctor R. Ruiz ]
  * Mark photo deletion strings for translation (LP: #1365032)

  [ David Planella ]
  * Mark photo deletion strings for translation (LP: #1365032)

  [ CI bot ]
  * Resync trunk
 -- Ubuntu daily release <email address hidden> Wed, 17 Sep 2014 17:38:32 +0000

Changed in gallery-app (Ubuntu):
status: New → Fix Released
David Planella (dpm) on 2014-09-23
Changed in ubuntu-weather-app:
importance: Undecided → High
status: Fix Committed → Fix Released
David Planella (dpm) on 2014-09-23
Changed in ubuntu-filemanager-app:
assignee: nobody → David Planella (dpm)
importance: Undecided → Medium
status: New → Fix Released
Changed in ubuntu-terminal-app:
assignee: nobody → David Planella (dpm)
importance: Undecided → Medium
status: New → Fix Released
Changed in ubuntu-rssreader-app:
assignee: nobody → David Planella (dpm)
importance: Undecided → Medium
status: New → In Progress
David Planella (dpm) wrote :

Actually, removing RSS reader, as the issue is not that the .desktop file has the X-Ubuntu-GettextDomain, but rather than its desktop file was not set up for translations, which is being tracked as bug 1318008

Changed in ubuntu-rssreader-app:
assignee: David Planella (dpm) → nobody
status: In Progress → Invalid
Ugo Riboni (uriboni) on 2014-09-29
Changed in gallery-app:
status: In Progress → Fix Released
David Planella (dpm) on 2014-09-29
no longer affects: sudoku-app
Bill Filler (bfiller) on 2014-09-29
tags: added: touch-2014-10-09
removed: touch-2014-09-25
Ugo Riboni (uriboni) on 2014-10-08
Changed in notes-app:
status: Confirmed → In Progress
Bill Filler (bfiller) on 2014-11-14
Changed in notes-app:
importance: High → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers