The files lens includes folders that don't exist

Bug #780841 reported by DavidBriscoe on 2011-05-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Low
Michal Hruby
unity-lens-files
Low
Michal Hruby
unity (Ubuntu)
Undecided
Unassigned
unity-lens-files (Ubuntu)
Undecided
Unassigned
unity-place-files (Ubuntu)
Undecided
Michal Hruby

Bug Description

Binary package hint: unity

The first thing I do after I install ubuntu is "cd ~; rmdir *" to remove the folders that I don't use. (I already have analogs in another partition that I mount as ~/data.)

However, these folders (~/Downloads, ~/Documents, ~/Pictures, ~/Videos) show up in the Dash's search results even though the folders don't exist. I see these ghost folders in "Top Results" when searching by invoking the dash, using "Find Files", or using "Files & Folders".

I tried clearing my zeitgeist history:
rm ~/.local/share/zeitgeist/activity.sqlite
zeitgeist-daemon --replace

But these folders still show up.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: zeitgeist 0.7.1-1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: wl
Architecture: amd64
Date: Tue May 10 18:16:45 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_CA:en
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
SourcePackage: zeitgeist
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

DavidBriscoe (idbrii) wrote :
DavidBriscoe (idbrii) wrote :

Attaching unity info.

Seif Lotfy (seif) wrote :

This is not a zeitgeist framework bug. It seems like a dash bug.

Changed in zeitgeist:
status: New → Invalid
Harry van Haaren (harryhaaren) wrote :

Can't reproduce this here using "Down" search for downloads... didn't work. Can you give a simple test case please?

DavidBriscoe (idbrii) wrote :

@Harry: The folders don't always show up for me because my unity search results for the same query are often inconsistent (see bug 810823). Are you seeing a Files & Folders section at all (what if you create a file called ~/downloads.txt)?

Here's more formal steps.

Load up a natty LiveCD
Search "down" and get the Downloads folder
Delete the ~/Downloads folder from nautilus
Search "doc" (workaround bug 810823)
Search "down" and the Downloads folder is still there!

You shouldn't have to do anything other than delete a folder from nautilus to make it stop showing in your results. That's how it works for any other file.

I tried applying updates to the LiveCD, but I don't have enough memory. However, I've updated unity (dpkg -l output changes from 3.8.10-0ubuntu2 to 3.8.16-0ubuntu1-natty1) and run setsid unity to restart unity. The above steps still show the Downloads folder.

Omer Akram (om26er) wrote :

Just tested, It seems the favorite folders are the one's that we see in Nautilus 'bookmarks' menu(obvious) if any folder is removed from that menu it is cleanly removed from the Dash as well. But if you delete any of the bookmarked folders by hand, they are cleanly removed from the 'Bookmarks' menu instantly but they remain in the dash.

affects: zeitgeist → unity-lens-files
Changed in unity-lens-files:
status: Invalid → Confirmed
affects: unity (Ubuntu) → unity-place-files (Ubuntu)
Changed in unity-place-files (Ubuntu):
status: New → Confirmed
Changed in unity:
status: New → Confirmed
DavidBriscoe (idbrii) wrote :

@Omer: You're right. If I create ~/Downloads, add it to the bookmarks, remove it from bookmarks, and delete the folder then I don't see it in my Dash results anymore.

> But if you delete any of the bookmarked folders by hand, they are
> cleanly removed from the 'Bookmarks' menu instantly

It looks like they might linger somewhere. I recreated the default folders and navigated to another folder (effectively refreshing nautilus) and all of the bookmarks were automatically recreated! If I remove the bookmarks and folders and recreate the folders again, they don't reappear.

I'm not sure if that's a feature of the bookmarks or part of the same bug.

Michal Hruby (mhr3) on 2011-09-21
Changed in unity:
assignee: nobody → Michal Hruby (mhr3)
Changed in unity-lens-files:
assignee: nobody → Michal Hruby (mhr3)
Changed in unity-place-files (Ubuntu):
assignee: nobody → Michal Hruby (mhr3)
Changed in unity-lens-files:
status: Confirmed → In Progress
Changed in unity:
status: Confirmed → In Progress
Michal Hruby (mhr3) on 2011-09-21
Changed in unity-lens-files:
status: In Progress → Fix Committed
Changed in unity:
status: In Progress → Fix Committed
importance: Undecided → Low
Changed in unity-lens-files:
importance: Undecided → Low
Changed in unity:
milestone: none → 4.18.0
Changed in unity-lens-files:
milestone: none → 0.6.10
Changed in unity-lens-files:
milestone: 0.6.10 → 0.6.8
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity-lens-files:
status: Fix Committed → Fix Released
Michal Hruby (mhr3) on 2011-09-29
Changed in unity-lens-files (Ubuntu):
status: New → Fix Released
Changed in unity-place-files (Ubuntu):
status: Confirmed → Fix Released
Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers