\\192.168.1.x opens http:\\192.168.1.x in firefox as opposed to smb://192.168.1.x in nautilus

Bug #773841 reported by pythonholum on 2011-04-30
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Low
Angelo Compagnucci
unity-2d
Wishlist
Unassigned
unity-lens-files
Medium
Angelo Compagnucci
unity (Ubuntu)
Undecided
Unassigned
unity-lens-files (Ubuntu)
Undecided
Unassigned
unity-place-files (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: unity-place-files

\\192.168.1.x Should bring up a smb link to 192.168.1.x
smb://192.168.1.x should bring up the same currently the system brings the first up in firefox as http://192.168.1.x and the latter as http://smb://192.168.1.x

It would also be nice to have the ability to have scp:// ftp://

This might need to go as a feature request more then a bug, Sorry in advance if I placed this under the wrong category,
PS Keep up the great work I love the new interface and how well ubuntu works

I am running ubuntu 11.04 ( on 2 separate machine's same issue )

unity-place-files:
  Installed: 0.5.46-0ubuntu5
  Candidate: 0.5.46-0ubuntu5
  Version table:
 *** 0.5.46-0ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages
        100 /var/lib/dpkg/status

Related branches

Changed in unity-place-files (Ubuntu):
importance: Undecided → Low
assignee: nobody → Didier Roche (didrocks)
Changed in unity-2d:
status: New → Confirmed
importance: Undecided → Low
importance: Low → Wishlist
Didier Roche (didrocks) on 2011-07-22
Changed in unity-place-files:
status: New → Confirmed
Changed in unity-place-files (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2011-07-29
Changed in unity:
status: New → Confirmed
Didier Roche (didrocks) wrote :

Quite similar to bug #770126: if anyone wants to work on it, it can be quite straightfoward. If anyone wants to work on that, do not hesitate to ping me on irc on #ayatana on freenode :)

Changed in unity-place-files (Ubuntu):
assignee: Didier Roche (didrocks) → nobody
tags: added: bitesize
Didier Roche (didrocks) on 2011-09-30
Changed in unity-lens-files (Ubuntu):
status: New → Confirmed
kroq-gar78 (kroq-gar78) on 2011-11-05
summary: \\192.168.1.x opens http:\\192.168.1.x in firefox as appose to
- smb://192.168.1.x in natulis
+ smb://192.168.1.x in nautilus
summary: - \\192.168.1.x opens http:\\192.168.1.x in firefox as appose to
+ \\192.168.1.x opens http:\\192.168.1.x in firefox as opposed to
smb://192.168.1.x in nautilus
Angelo Compagnucci (angeloc) wrote :

I assigned the bug to me because I want to take this bitesize job. I'm already working on it.

Changed in unity-lens-files:
assignee: nobody → Angelo Compagnucci (angelo-compagnucci)
kroq-gar78 (kroq-gar78) wrote :

On Ubuntu 11.10, this bug doesn't exist. All links are by default sent to Epiphany. Should I update the description?

Daniel Smith (connect404) wrote :

Opened ubuntu 11.10, open nautils, control-L, and then tested:

\\ no longer directs to firefox, it appends the path to your current focused window location
ftp:// works. eg ftp://ftp.ubuntu.com
scp is not correct, using ssh:// gives the desired result

This can probably be closed

This bug is not related to nautilus, but unity.

If you try to open ssh:// or \\ or smb:// with unity, this opens firefox
with a wrong address, it should instead open nautilus and ask to mount
remote location if not mounted. This doesn't work.

I'll working on fixing.

2012/1/5 Daniel Smith <email address hidden>

> Opened ubuntu 11.10, open nautils, control-L, and then tested:
>
> \\ no longer directs to firefox, it appends the path to your current
> focused window location
> ftp:// works. eg ftp://ftp.ubuntu.com
> scp is not correct, using ssh:// gives the desired result
>
> This can probably be closed
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/773841
>
> Title:
> \\192.168.1.x opens http:\\192.168.1.x in firefox as opposed to
> smb://192.168.1.x in nautilus
>
> Status in Unity:
> Confirmed
> Status in Unity 2D:
> Confirmed
> Status in Unity Files Lens:
> Confirmed
> Status in “unity-lens-files” package in Ubuntu:
> Confirmed
> Status in “unity-place-files” package in Ubuntu:
> Confirmed
>
> Bug description:
> Binary package hint: unity-place-files
>
> \\192.168.1.x Should bring up a smb link to 192.168.1.x
> smb://192.168.1.x should bring up the same currently the system brings
> the first up in firefox as http://192.168.1.x and the latter as http:/
> /smb://192.168.1.x
>
> It would also be nice to have the ability to have scp:// ftp://
>
> This might need to go as a feature request more then a bug, Sorry in
> advance if I placed this under the wrong category,
> PS Keep up the great work I love the new interface and how well ubuntu
> works
>
>
> I am running ubuntu 11.04 ( on 2 separate machine's same issue )
>
> unity-place-files:
> Installed: 0.5.46-0ubuntu5
> Candidate: 0.5.46-0ubuntu5
> Version table:
> *** 0.5.46-0ubuntu5 0
> 500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages
> 100 /var/lib/dpkg/status
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/unity/+bug/773841/+subscriptions
>

--
Profile: http://it.linkedin.com/in/compagnucciangelo

Michal Hruby (mhr3) on 2012-03-05
Changed in unity-lens-files:
status: Confirmed → In Progress
importance: Undecided → Medium
milestone: none → 5.8.0
Changed in unity:
status: Confirmed → In Progress
importance: Undecided → Low
milestone: none → 5.8.0
Changed in unity-lens-files:
status: In Progress → Fix Committed
Changed in unity:
assignee: nobody → Angelo Compagnucci (angeloc)
Changed in unity:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-03-23
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity-lens-files:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-files - 5.8.0-0ubuntu1

---------------
unity-lens-files (5.8.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - clicking on folders in the file lens does not open nautilus
      (LP: #921665)
    - Dash - No message displayed when no results are returned in the
      Dash (LP: #711199)
    - Privacy Delete history is not deleting download history (LP: #947856)
    - Locate scope doesn't respect privacy settings (LP: #955229)
    - \\192.168.1.x opens http:\\192.168.1.x in firefox as opposed to
      smb://192.168.1.x in nautilus (LP: #773841)
    - Web url regexp matches non url (LP: #948086)
  * debian/control:
    - build-dep on newer zeitgeist
 -- Didier Roche <email address hidden> Fri, 23 Mar 2012 15:05:24 +0100

Changed in unity-lens-files (Ubuntu):
status: Confirmed → Fix Released
Changed in unity-2d:
status: Confirmed → Fix Released
Changed in unity-place-files (Ubuntu):
status: Confirmed → Fix Released
Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers