"Search Files & Folders" does not ever find folders, only files

Bug #731854 reported by Andrew Toogood on 2011-03-09
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Unity
Fix Released
Medium
Mikkel Kamstrup Erlandsen
Unity Foundations
Medium
Mikkel Kamstrup Erlandsen
unity-lens-files
Medium
Mikkel Kamstrup Erlandsen
unity (Ubuntu)
Undecided
Unassigned
unity-place-files (Ubuntu)
Medium
Mikkel Kamstrup Erlandsen

Bug Description

Binary package hint: unity

If you search from main dash or files dash it does not return folder results only files.
This should return folders or it is of no use for navigating.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.6.2-0ubuntu1 [modified: usr/bin/unity usr/lib/compiz/libunityshell.so usr/lib/unity/unity-panel-service usr/share/doc/unity/changelog.Debian.gz]
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 270.29 Wed Feb 23 16:18:35 PST 2011
 GCC version: gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-3ubuntu3)
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
Date: Wed Mar 9 22:51:35 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus: nvidia-current, 270.29, 2.6.38-5-generic, x86_64: installed
GraphicsCard:
 nVidia Corporation G84 [GeForce 8600M GT] [10de:0407] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: Toshiba America Info Systems Device [1179:0001]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110228.1)
InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110228.1)
InstallationMedia__: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110228.1)
MachineType: TOSHIBA Qosmio G40
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcEnviron:
 LANGUAGE=en_NZ:en
 LANG=en_NZ.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-5-generic root=UUID=186547b2-6678-4f57-8404-b1fa11669343 ro quiet splash vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
ProcVersionSignature__: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Renderer: Unknown
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 02/29/2008
dmi.bios.vendor: TOSHIBA
dmi.bios.version: Version 2.20
dmi.board.name: Portable PC
dmi.board.vendor: TOSHIBA
dmi.board.version: Version A0
dmi.chassis.asset.tag: 00000000
dmi.chassis.type: 10
dmi.chassis.version: A
dmi.modalias: dmi:bvnTOSHIBA:bvrVersion2.20:bd02/29/2008:svnTOSHIBA:pnQosmioG40:pvrPQG40A-00Y014:rvnTOSHIBA:rnPortablePC:rvrVersionA0:cvnTSI:ct10:cvrA:
dmi.product.name: Qosmio G40
dmi.product.version: PQG40A-00Y014
dmi.sys.vendor: TOSHIBA
version.compiz: compiz 1:0.9.4-0ubuntu4
version.libdrm2: libdrm2 2.4.23-1ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1-0ubuntu1
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu11
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu5

Martin Pitt (pitti) wrote :

Hm, for me it does not even find files. For example, if I open the Files&Folders place, I have a recent file "Aufnahmebestaetigung.pdf". However, when I open the dash and type "Aufn" (or fewer or more letters), I get matches in the applications (Audio recorder and screenshot which are correct matches in German translation), but I never ever get any result in the "files & folders" category, it just says "no matches found" (which indicates that it's supposed to search for files).

File search in the file place is broken the other way round: If I type a search term there, it never narrows down the initially displayed results to the search, nor add older/less used matches; the initially displayed results never change at all.

@Martin: Are you sure you have the zeitgeist-fts-extension installed? And if you do, I guess the index is somehow corrupted... You can try to kill zeitgeist-daemon and look at ~/.local/share/zeitgeist/fts.index. Mine looks like:

$ ls -lh ~/.local/share/zeitgeist/fts.index/
total 2,2M
-rw-r--r-- 1 kamstrup kamstrup 0 2011-03-11 08:38 flintlock
-rw-r--r-- 1 kamstrup kamstrup 28 2011-03-08 14:32 iamchert
-rw-r--r-- 1 kamstrup kamstrup 29 2011-03-11 10:58 position.baseA
-rw-r--r-- 1 kamstrup kamstrup 29 2011-03-11 10:58 position.baseB
-rw-r--r-- 1 kamstrup kamstrup 704K 2011-03-11 10:58 position.DB
-rw-r--r-- 1 kamstrup kamstrup 25 2011-03-11 10:58 postlist.baseA
-rw-r--r-- 1 kamstrup kamstrup 24 2011-03-11 10:58 postlist.baseB
-rw-r--r-- 1 kamstrup kamstrup 520K 2011-03-11 10:58 postlist.DB
-rw-r--r-- 1 kamstrup kamstrup 18 2011-03-11 10:58 record.baseA
-rw-r--r-- 1 kamstrup kamstrup 18 2011-03-11 10:58 record.baseB
-rw-r--r-- 1 kamstrup kamstrup 40K 2011-03-11 10:58 record.DB
-rw-r--r-- 1 kamstrup kamstrup 32 2011-03-11 10:58 termlist.baseA
-rw-r--r-- 1 kamstrup kamstrup 32 2011-03-11 10:58 termlist.baseB
-rw-r--r-- 1 kamstrup kamstrup 944K 2011-03-11 10:58 termlist.DB

While ZG is not running you try try and just delete ~/.local/share/zeitgeist/fts.index - it will be rebuild when ZG starts up next time. Maybe this fixes you issues?

You can also try and poke at the Zeitgeist logs in ~/.cache/zeitgeist to see if anything is suspicious...

@Andrew: If you enter the files place (hit <super>-f) you should see your bookmarked folders at the bottom of the initial screen, please confirm?

Also, you can select "Folders" from the dropdown in the search entry whuch should list all your folders by usage history. Please confirm that as well.

I'll mark as Incomplete until I hear back from you guys.

Changed in unity (Ubuntu):
assignee: nobody → Mikkel Kamstrup Erlandsen (kamstrup)
importance: Undecided → Medium
status: New → Incomplete
Changed in unity:
assignee: nobody → Mikkel Kamstrup Erlandsen (kamstrup)
importance: Undecided → Medium
status: New → Incomplete
Changed in unity-place-files:
assignee: nobody → Mikkel Kamstrup Erlandsen (kamstrup)
importance: Undecided → Medium
status: New → Incomplete
Martin Pitt (pitti) wrote :

I do have zeitgeist-fts-extension installed. Purging the index and restarting definitively helped, thanks!

I now confirm the original bug: it does find files, but no folders.

@Martin, @Andrew: Sorry if I am a bit slow... :-)

So you're saying you don't have a group on the front page of the files place called "Folders" that lists you Gnome folder bookmarks? If that's the case can you post your ~/.gtk-bookmarks file here? And please take a peak inside it before you do - to make sure it doesn't contain sensible content :-)

Also, clicking the Folders entry in the dropdown from the search box should list the folders you been active in - confirm, or no confirm?

Download full text (5.9 KiB)

Hey Buddy thanks for getting back to me,

I should have read your email before doing an update as it seems things
(Including File places) have even bigger issues.

When I Super+f I get a blank black box, see attachment and if i click to
make it full screen I get a crash, and then the bug logger crashes when
it tries to load firefox!

This is what I remember about the issue from memory:

Yes all the favorite folders showed up by default.
The search states files or folders so it does not suggest I have to
select folders on the right before I will get folder results so I never
tried that. I also get the same result when searching from the dash and
there is no way to select folders there.

Is that what you needed to know?

Cheers,

Andrew T

On Fri, 2011-03-11 at 10:25 +0000, Mikkel Kamstrup Erlandsen wrote:
> @Andrew: If you enter the files place (hit <super>-f) you should see
> your bookmarked folders at the bottom of the initial screen, please
> confirm?
>
> Also, you can select "Folders" from the dropdown in the search entry
> whuch should list all your folders by usage history. Please confirm that
> as well.
>
> I'll mark as Incomplete until I hear back from you guys.
>
> ** Changed in: unity (Ubuntu)
> Importance: Undecided => Medium
>
> ** Changed in: unity (Ubuntu)
> Status: New => Incomplete
>
> ** Changed in: unity (Ubuntu)
> Assignee: (unassigned) => Mikkel Kamstrup Erlandsen (kamstrup)
>
> ** Also affects: unity
> Importance: Undecided
> Status: New
>
> ** Changed in: unity
> Importance: Undecided => Medium
>
> ** Changed in: unity
> Status: New => Incomplete
>
> ** Changed in: unity
> Assignee: (unassigned) => Mikkel Kamstrup Erlandsen (kamstrup)
>
> ** Also affects: unity-place-files
> Importance: Undecided
> Status: New
>
> ** Changed in: unity-place-files
> Importance: Undecided => Medium
>
> ** Changed in: unity-place-files
> Status: New => Incomplete
>
> ** Changed in: unity-place-files
> Assignee: (unassigned) => Mikkel Kamstrup Erlandsen (kamstrup)
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/731854
>
> Title:
> "Search Files & Folders" does not ever find folders, only files
>
> Status in Unity:
> Incomplete
> Status in Unity Files Place:
> Incomplete
> Status in “unity” package in Ubuntu:
> Incomplete
>
> Bug description:
> Binary package hint: unity
>
> If you search from main dash or files dash it does not return folder results only files.
> This should return folders or it is of no use for navigating.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.04
> Package: unity 3.6.2-0ubuntu1 [modified: usr/bin/unity usr/lib/compiz/libunityshell.so usr/lib/unity/unity-panel-service usr/share/doc/unity/changelog.Debian.gz]
> ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
> Uname: Linux 2.6.38-5-generic x86_64
> NonfreeKernelModules: nvidia
> .proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
> .proc.driver.nvidia.registry: Binary: ""
> .proc.driver.nvidia.version:
> NVRM version: NV...

Read more...

Martin Pitt (pitti) wrote :

Mikkel Kamstrup Erlandsen [2011-03-11 15:14 -0000]:
> So you're saying you don't have a group on the front page of the files
> place called "Folders" that lists you Gnome folder bookmarks?

Nothign to do with GNOME bookmarks. I'm actually talking about file
system directories here -- The f&f place does show them, but once you
start typing a search, neither the dash nor the f&f place show any
folders in the results.

> Also, clicking the Folders entry in the dropdown from the search box
> should list the folders you been active in - confirm, or no confirm?

Confirm, that works for me.

Ok Martin and Andrew - I think I get your point now, thanks for pinning it out :-)

I've been wondering for a while if it made sense to search the names of the bookmarked folder names for matches in the files place - or maybe also searching all folder names under ~/ for matches. The crucial point here is how we integrate that with the relevancy ranking we're already doing, but that will be my headache :-)

I'll talk this over with someone from design and post back.

Changed in unity-place-files:
milestone: none → 0.5.44
affects: unity → unity-foundations
Changed in unity-foundations:
milestone: none → unity-3.6.6
tags: added: needs-design
Martin Pitt (pitti) wrote :

Mikkel,

for the record, I was merely confirming the bug description. I don't actually miss folders in the search result, since in most cases I'm really just interested in files. So this might well be a "wont fix".

Martin Pitt (pitti) wrote :

Oh, but if it's meant to only show files, then the category heading should say so, and not "Files & Folders".

Didier Roche (didrocks) on 2011-03-16
Changed in unity:
status: New → Incomplete
Changed in unity-place-files:
milestone: 0.5.44 → none
Changed in unity-foundations:
milestone: unity-3.6.6 → none
Bram Bonné (brambonne) wrote :

It would make sense to include folders in the results here. My reasoning behind this is that a user will expect to be searching the 'files and folders' that are visible when accessing the files&folders screen, just like he is able to search the applications that are visible when accessing the applications screen. Just my 2 cents.

Marking as Fix Released since we had +1 in another bug

Changed in ayatana-design:
status: New → Fix Released

What I plan to do for this weeks release is to make the bookmarked folders and folders in your home dir show up in the search results

Changed in unity-foundations:
milestone: none → unity-3.6.8
status: Incomplete → Triaged
Changed in unity:
assignee: nobody → Mikkel Kamstrup Erlandsen (kamstrup)
importance: Undecided → Medium
milestone: none → 3.6.8
status: Incomplete → Triaged
Changed in unity-place-files:
milestone: none → 0.5.46
status: Incomplete → Triaged
Changed in unity (Ubuntu):
status: Incomplete → Triaged
affects: unity (Ubuntu) → unity-place-files (Ubuntu)

The merged branch makes the bookmarked folders searchable, but not generally folders in your homedir. The jury is still out on that one, on whether it's a good or bad idea.

Changed in unity-foundations:
status: Triaged → Fix Committed
Changed in unity:
status: Triaged → Fix Committed
Changed in unity-place-files:
status: Triaged → Fix Committed
Changed in unity-place-files (Ubuntu):
status: Triaged → Fix Committed
Martin Pitt (pitti) wrote :

Mikkel, that sounds like a great compromise to me. Personally I wouldn't even want it to display each and every subdirectory in the dozens of bzr and git checkouts, Evolution cache dirs, etc. :)

Changed in unity-place-files:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity-foundations:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-place-files - 0.5.46-0ubuntu1

---------------
unity-place-files (0.5.46-0ubuntu1) natty; urgency=low

  * New upstream release.
    - adding url launcher support from the search (LP: #739038)
    - SearchFinished signal for Places API (LP: #739311)
    - recent documents do not appear in the dash (LP: #737088)
    - "Search Files & Folders" does not ever find folders, only files
      (LP: #731854)
  * debian/control:
    - bump build-dep req.
 -- Didier Roche <email address hidden> Wed, 23 Mar 2011 17:10:27 +0100

Changed in unity-place-files (Ubuntu):
status: Fix Committed → Fix Released

How is this fixed? It is not here. If I go to files and places and start typing, it does not find folders that clearly exist... and even with the files it only finds them very arbitrarily....

Download full text (4.7 KiB)

it finds files you have used not all files, as explained to me that is
all that is scope at the moment. If finds the standard folders as well
as those added/changed. Not a perfect solution but as designed, I have
to say it does find about 80% of what I am looking for without going to
filemanager so still very useful.

Too late in the cycle to hope to get a design change so we can put our 2
cents worth in for 11.10.

On Sun, 2011-04-10 at 11:21 +0000, Sebastian Haselbeck wrote:
> How is this fixed? It is not here. If I go to files and places and start
> typing, it does not find folders that clearly exist... and even with
> the files it only finds them very arbitrarily....
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/731854
>
> Title:
> "Search Files & Folders" does not ever find folders, only files
>
> Status in Ayatana Design:
> Fix Released
> Status in Unity:
> Fix Released
> Status in Unity Foundations:
> Fix Released
> Status in Unity Files Place:
> Fix Released
> Status in “unity-place-files” package in Ubuntu:
> Fix Released
>
> Bug description:
> Binary package hint: unity
>
> If you search from main dash or files dash it does not return folder results only files.
> This should return folders or it is of no use for navigating.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.04
> Package: unity 3.6.2-0ubuntu1 [modified: usr/bin/unity usr/lib/compiz/libunityshell.so usr/lib/unity/unity-panel-service usr/share/doc/unity/changelog.Debian.gz]
> ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
> Uname: Linux 2.6.38-5-generic x86_64
> NonfreeKernelModules: nvidia
> .proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
> .proc.driver.nvidia.registry: Binary: ""
> .proc.driver.nvidia.version:
> NVRM version: NVIDIA UNIX x86_64 Kernel Module 270.29 Wed Feb 23 16:18:35 PST 2011
> GCC version: gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-3ubuntu3)
> Architecture: amd64
> CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
> CompositorRunning: compiz
> Date: Wed Mar 9 22:51:35 2011
> DistUpgraded: Fresh install
> DistroCodename: natty
> DistroVariant: ubuntu
> DkmsStatus: nvidia-current, 270.29, 2.6.38-5-generic, x86_64: installed
> GraphicsCard:
> nVidia Corporation G84 [GeForce 8600M GT] [10de:0407] (rev a1) (prog-if 00 [VGA controller])
> Subsystem: Toshiba America Info Systems Device [1179:0001]
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110228.1)
> InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110228.1)
> InstallationMedia__: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110228.1)
> MachineType: TOSHIBA Qosmio G40
> PccardctlIdent:
> Socket 0:
> no product info available
> PccardctlStatus:
> Socket 0:
> no card
> ProcEnviron:
> LANGUAGE=en_NZ:en
> LANG=en_NZ.UTF-8
> S...

Read more...

u-foka (ufooka) wrote :

Hy!

That "Search files & folders" thing suggests to the user that is will search for files other than the last used ones.. It should be combined with some indexing service to quickly show up accurate results from the entire disk!

Doug McMahon (mc3man) wrote :

Have added new bug related to this - not that previously opened folders aren't search-able (folder search), but that they no longer will show on an "All Files" search which is the general expectation (folders are files too.

Bug #784896
And maybe do new users a favor with a better hint line
Bug #782362

ahalin (ahalinahalin) wrote :

Agree, it doesn't search worth a damn (and even if it did, you can't copy-paste into the Files and Folders button (super+f) text area. Unfortunately Windows 7 does a much better job on this, dare I say they got it right..........

Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.