Ubuntu

Dash search unavoidably returns offensive results

Reported by Matthew Paul Thomas on 2011-03-21
78
This bug affects 29 people
Affects Status Importance Assigned to Milestone
Unity
Medium
Mikkel Kamstrup Erlandsen
Unity Foundations
Medium
Mikkel Kamstrup Erlandsen
unity-lens-applications
Medium
Unassigned
unity-place-applications (Ubuntu)
Undecided
Unassigned

Bug Description

unity 3.6.6-0ubuntu1, Ubuntu Natty
unity 3.6.8-0ubuntu3, Ubuntu Natty
unity-2d 5.8.0-0ubuntu1, Ubuntu Pangolin

Example 1:
0. Be a 14-year-old girl, or a schoolteacher preparing to show a film to your class, or a businessperson preparing to give a presentation.
1. Click the Applications button.
2. Type "movie" to launch Movie Player.
What happens: Seven applications appear, one of which is called "PornView".

Example 2:
0. Be a Dell representative or customer.
1. Click the Applications button.
2. Type "Dell" to find the Dell Recovery tool.
What happens: Five applications appear, including "Dopewars", a drug-dealing game.

(More examples in <https://bugs.launchpad.net/ubuntu/+source/unity/+bug/883800/comments/15>.)

This problem cannot reasonably be solved merely by renaming or blacklisting one or two particular applications. These are just two examples, and if the Dash shows any applications that aren't installed, there is no bright line between those that should appear for everyone and those that should appear for no-one.

We can't realistically expect the entire Ubuntu software library to be offense-free: as more independent applications are published, some (especially games) will be targeted at mature audiences and/or be non-worksafe, and that's fine. (We can introduce a maturity rating system inside Ubuntu Software Center for those.) But people should be able to expect that the launcher in Ubuntu's shell, of all things, *will* be offense-free.

Possible solutions:

* Simplest would be to restrict application search results only to those applications that are actually installed. As Mark Shuttleworth said in <https://lists.launchpad.net/unity-design/msg08030.html>: "To launch what you know you have installed, use the Dash. To explore what may be installed, or may be available, use the Software Centre. Now, neither piece may yet be ideal, but we should improve the design of those pieces for their specific purposes, not try to make everything do everything."

* Introduce a maturity ratings system <https://blueprints.launchpad.net/ubuntu/+spec/foundations-software-maturity-ratings>, apply it to every package in the Ubuntu archive that needs it, then set a reasonable default for Dash searches (analogous to Google's "SafeSearch Moderate"). This might involve adding a setting for how much filtering the Dash should do.

* Ad-hoc and unconfigurable blacklisting (as proposed in duplicate bug 883800). This might result in ongoing disagreements about whether particular applications should be blacklisted.

description: updated
Changed in unity:
assignee: nobody → Mikkel Kamstrup Erlandsen (kamstrup)
importance: Undecided → Medium
milestone: none → 3.6.8
status: New → Triaged
Changed in unity-place-applications:
assignee: nobody → Mikkel Kamstrup Erlandsen (kamstrup)
importance: Undecided → Medium
milestone: none → 0.2.42
status: New → Triaged
Changed in unity-foundations:
assignee: nobody → Mikkel Kamstrup Erlandsen (kamstrup)
importance: Undecided → Medium
milestone: none → unity-3.6.8
status: New → Triaged
Changed in unity-foundations:
status: Triaged → Fix Committed
Changed in unity:
status: Triaged → Fix Committed
Changed in unity-place-applications:
status: Triaged → Fix Committed
Duncan McGreggor (oubiwann) wrote :

Hey mpt,

I just took a look at the fix that Mikkel implemented, and I like it: simple and direct. The dash search will now only show installed applications.

Though this does address the use case you offered as an example, I really like your idea of ratings. It shows a sensitivity to different audiences that has been demanded in other areas of the entertainment industry (including software). For the aspects of this bug that the fix didn't (and rightly can't) address, I'd be +1 for a discussion at UDS about ratings, and how we could go about that...

Matthew Paul Thomas (mpt) wrote :

Blueprint registered and proposed for UDS.

Mikkel, can you confirm:

 - the home screen aggregation shows only installed apps
 - the apps place shows both installed and available apps?

Thanks
Mark

On 22 March 2011 20:48, Mark Shuttleworth <email address hidden> wrote:
> Mikkel, can you confirm:
>
>  - the home screen aggregation shows only installed apps
>  - the apps place shows both installed and available apps?

That's a positive. Hitting the mirrors on Wednesday evening (tomorrow that is).

Changed in unity-foundations:
status: Fix Committed → Fix Released
Changed in unity-place-applications:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-place-applications - 0.2.42-0ubuntu1

---------------
unity-place-applications (0.2.42-0ubuntu1) natty; urgency=low

  * New upstream release.
    - Dash search unavoidably returns offensive results (LP: #739469)
    - SearchFinished signal for Places API (LP: #739311)
    - Dash: installed/not installed packages are conflated under "Applications":
      incredibly confusing (LP: #733669)
    - Apps Place: SIGABRT when monkey-typing global searches (LP: #737396)
  * debian/control:
    - bump dep req.
 -- Didier Roche <email address hidden> Wed, 23 Mar 2011 17:06:19 +0100

Changed in unity-place-applications (Ubuntu):
status: New → Fix Released
Matthew Paul Thomas (mpt) wrote :

Reproduced in unity 3.6.8-0ubuntu3, unity-place-applications 0.2.42-0ubuntu2. Reopening.

Changed in unity-place-applications (Ubuntu):
status: Fix Released → New
description: updated

@mpt: Are you sure you see the available apps in the Dash search as well? I can't see them here. It behaves exactly as described in Mark's comment #3 for me.

Neil Perry (nperry) wrote :

Unable to reproduce in Dash, however application places still has same behaviour

Changed in unity-place-applications (Ubuntu):
status: New → Confirmed

@Neil: The apps place should still show the Apps Available for Download section. That's what's specced in comment #3. So what you describe sounds like this one is solved.

Didier Roche (didrocks) wrote :

@Mikkel, should that be tracked in another bug then?
typing movie will show "pornview" as the third result

Changed in unity-place-applications:
status: Fix Released → Triaged
Changed in unity:
status: Fix Released → Triaged
Didier Roche (didrocks) wrote :

(in the apps place, as described on comment #3)

Mark Shuttleworth (sabdfl) wrote :

It's a fact of life - pornview is in Ubuntu. If we don't like that, we
should drop it. Instead, we'll figure out a safe-search framework for
Oneiric and use it widely (dash and other apps).

Thanks for the current fix, which at least keeps uninstalled apps off
the dash Home Screen aggregated search, and correctly identifies
PornView as "available for install" on my system (not installed, I'll
have you know ;-)).

Mark

Considering this bug as Fix Released. Further discussion on the "safe search" feature can continue on bug #745534

Changed in unity:
milestone: 3.6.8 → none
status: Triaged → Fix Released
Changed in unity-place-applications:
status: Triaged → Fix Released
Changed in unity-place-applications (Ubuntu):
status: Confirmed → Fix Released
Matthew Paul Thomas (mpt) wrote :

It's still not fixed, with all updates installed as of a couple of hours ago.

Changed in unity:
status: Fix Released → New
Matthew Paul Thomas (mpt) wrote :

Sebastien Bacher just drew my attention to Mark's comment about pornview being in Ubuntu and about introducing a safe-search framework. I addressed both of those points in the original report. In every previous version of Ubuntu back to 6.06 (if not earlier), pornview was available and there was no safe-search framework. And there's no serious sign of either of those things changing soon. But in every previous version of Ubuntu, this bug did not exist. This bug is specific to the design of Unity.

Alex Launi (alexlauni) on 2011-03-30
Changed in unity:
status: New → Confirmed
Alex Launi (alexlauni) on 2011-04-05
Changed in unity:
status: Confirmed → Fix Released
Jeremy Bicha (jbicha) wrote :

Alex, why did you remark this Fix Released? It's only half fixed. Searching for "movie" in the Applications lens still shows PornView.

@Jeremy: I think that part is going to have to wait for a safe search system to be implemented.

Paul Hoell (hoellp) wrote :

In the meantime, how about a way to disable the recommendations in the app-place as well?

That wouldn't bother unconcerned users and help people who have a problem with the current state, after the introduction of the safe search system, this option could be expanded to finely control the search function.

levu (levu) wrote :

omg, the world is not as some people wish it to be - face it. PornView is in ubuntu, and so what? It's correctly described as "program available for download" (download shows that it isn't currently on your computer). What if i'd say i believe in the religion of emacs so that all vi clones are evil? Ubuntu stands for bringing people together. But this also means teaching tolerance to people.

Sorry for my english,
Florian

btw: the internet is for pr0n ;)

IKT (ikt) wrote :

PornView is an image and movie viewer/manager with thumbnail previews. Additional features includes thumbnail caching, directory tree views, adjustable zoom, and fullscreen view. Slideshows allow for unattended presentation of images for hands-free viewing. Pornview is written using GTK+. .

Why not just rename the program from pornview to freeview or something...

IKT (ikt) wrote :

"For example, a Saudi Ubuntu user might be similarly annoyed that searching for "guide" returns "Xiphos Bible Guide" as a result, when that's not installed either."

By "Saudi Ubuntu user" you mean Muslim right? Just because someone lives in the Middle East ( and can be killed for not believing in Islam :/ ) does not automatically make them Muslim, this is an 101 on atheism, you find atheists everywhere.

Should I be similarly annoyed if I as an atheist search for "guide" and it returns anything that includes any references to any religion/cults?

How do you even begin to implement search filters like that?

yman (s-y-schwarz) wrote :

@levu:
The problem being raised here is that people who don't want to see certain things and aren't searching for them still find them popping up on their desktop. Until PornView and any other apps one might find offensive stop popping up on the desktops of unsuspecting users there is a problem.

A comment ridiculing other people's values and refusing to consider accommodating their needs can hardly call for tolerance. Part of tolerance is to allow freedom of expression, and part of it is to allow people not to listen if they don't want to. Forcing people to see what they don't want to see is an act of intolerance.

levu (levu) wrote :

Simply implement a user scope blacklist (e.g. some regexpes in ~/.config/unity/blacklist). Every person can put everything he wants to this blacklist. The thing I wanted to point out is that, if you want to make everyone happy, you have to deliver empty repositories...
An advantage of a config file instead of some dconf values is that you can share your blacklists easily with others. E.g. you can share a "muslim blacklist", a "atheist blacklist" and so on. Every content blocking makes more persons unhappy than happy. I for myself want the dash to show all applications and i would be unhappy with each filter.

Jeremy Bicha (jbicha) wrote :

levu, I think you're creating a straw man. I refuse to believe emacs users are offended by the presence of vi in Software Center and I think if you were honest, you'd say that's ridiculous too.

I know Christians and Muslims who use Ubuntu. I've never met anyone offended by the presence of Bible or Quran software in Ubuntu. Some might prefer not to see religious software but that's different than the porn button by trying to start a movie.

I am not a religious fanatic but as the bug description says, there are numerous examples where not hiding illicit software can cause significant problems for Ubuntu and Ubuntu users. We should have a mature blacklist in Software Center for 11.10 (and not attempt to outright censor free software that happens to be controversial), and the blacklist should be enabled by default.

I think dopewars should be on this blacklist too. While just a text-based game, the whole point is buying and drugs illegally in New York City. While I think US drug laws need dramatic reform, I don't think this is appropriate for the general Ubuntu audience. I only think there are a few apps that would be on this list.

Matthew Paul Thomas (mpt) wrote :

Reproduced in unity-2d 5.8.0-0ubuntu1, Ubuntu Pangolin. Reopening.

description: updated
Changed in unity-lens-applications:
status: Fix Released → Confirmed
description: updated
Jane Atkinson (irihapeti) wrote :

Reproduced in unity-2d 5.12.0-0ubuntu1.1 and Unity 5.12-0ubuntu3, Ubuntu Quantal Quetzal.

tags: added: precise
Changed in unity-lens-applications:
assignee: Mikkel Kamstrup Erlandsen (kamstrup) → nobody
tenfishsticks (tenfishsticks) wrote :

This discussion has focused mostly on religious/non-religious arguments on this bug, so I'd like to remind the users that any rating system or blacklist should be centered on child protection and family use. My overall concern in this bug is allowing my family to use Ubuntu. When I know that PornView and DopeWars are possible search results, I'm less inclined to install it at home. Not to mention the use of Ubuntu in professional settings (which is actually where I encountered the PornView result), without a moderating enhancement Ubuntu will lose users who

a) see it as a potential for encouragement to a curious child or family member or
b) companies that see it as unprofessional and risky to their employees' productivity/effectiveness.

This bug isn't about the Bible or the Qu'ran. Take an hour, find a good shrink and a couch, and get over it already. This is about making Ubuntu user-friendly, whether you're a grown adult or a 5-year-old.

K (wk-r) wrote :

I just encountered this issue on a fresh install of Ubuntu 12.04. I am having serious trouble believing that this has actually been a matter of discussion for over a year - it needs to go. If no plan can be developed for a comprehensive filtering scheme to be deployed NOW, then this "lens" feature - and to be clear, I mean the misguided feature that lists installable software in the menu - needs to be removed until such a filter can be built.

Why is this a holy war? If it offends religious people, fine, do it to appease them. I'm an atheist married father of two with more than twenty gigabytes of double penetration on a tertiary hard drive and I STILL don't want my operating system offering ways to watch it autonomously.

The reasons I have for wanting this removed from the menu are simple:

 1. I will no longer recommend Ubuntu to friends and family, particularly older individuals because now the OS reflects poorly on me as a user
 2. It makes the operating system feel far less professional if it's peddling smut to me. I love smut, but I can find it on my own.
 3. I can't use Ubuntu to demo something for a client, because if I need anything from the menu there's a chance that this stuff will appear unbidden.

But seriously, this is dumb, stop it now. It doesn't matter if this is a free speech to you - if you care that much about the ethical principle of the thing, you should look for a distro that doesn't include proprietary drivers because that is a much more immediate and pressing threat to your rights than being able to display porn icons in the main menu.

Having these apps in the MENU is a completely different question to having them in the SOFTWARE CENTER. I want this stuff available, just not advertised BY THE OPERATING SYSTEM.

In closing, this hurts me professionally and it negates any ability or desire I might have to spread the OS to my social circle and family.

tags: added: scopes-s
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments