unity video lens always re-thumbnails

Bug #977158 reported by Michael Blennerhassett on 2012-04-09
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity Videos Lens
Undecided
Unassigned
unity-lens-video (Ubuntu)
High
David Callé
Precise
High
Unassigned

Bug Description

[Impact]
The video lens keeps trying to thumbnail videos and uses resources when it should just ignore the one which it already tried and can't be thumbnailed

[Test Case]
1. Make sure to have a video file in the lens that is failing in creating the thumbnail
2. Open the video lens
   -> Verify that the thumbnail is not available
3. Close and re-open the video lens
   -> Verify that the lens doesn't try to re-load the thumbnail

[Regression Potential]
Transient errors in thumbnail generation, if any, will now appear permanent.

Original description:

- The totem video thumbnailer times out after 30secs (or so)
- Sometimes this isn't enough time to create a thumbnail
- unity video lens will re-thumbnail these video files every time the lens is opened (and fail every time)

Nautilus has the idea of a "failed thumbnail", so that it won't keep trying to thumbnail files that failed previosly. The video lens should do something similar.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity-lens-video 0.3.5-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-22.35-generic 3.2.14
Uname: Linux 3.2.0-22-generic x86_64
ApportVersion: 2.0-0ubuntu4
Architecture: amd64
Date: Mon Apr 9 21:57:28 2012
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
PackageArchitecture: all
SourcePackage: unity-lens-video
UpgradeStatus: Upgraded to precise on 2012-03-16 (24 days ago)

David Callé (davidc3) on 2012-04-09
Changed in unity-lens-video (Ubuntu):
status: New → Confirmed
assignee: nobody → David Callé (davidc3)

Note: this is triggered by searching in the dash too.

So whenever I open the home dash and search for something I get ~30secs of 100% CPU usage. (laptop users aren't going to be happy)

David Callé (davidc3) on 2012-04-12
Changed in unity-lens-video (Ubuntu):
importance: Undecided → High

Well, I guess not many people have videos that fail to thumbnail in 30secs. Anyway, I've been using the attached patch for a while with no problems. Only fixes the problem if nautilus has been to the directory beforehand, though. It just checks if nautilus reported the thumbnailing as failed, and if so, displays the generic 'video' icon.

The attachment "check_for_failed.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
David Callé (davidc3) wrote :

Hello Michael, thanks a lot for this patch.
It should land next week in trunk and in Precise.

Changed in unity-lens-video (Ubuntu):
status: Confirmed → In Progress
David Callé (davidc3) on 2012-06-27
Changed in unity-lens-video (Ubuntu):
status: In Progress → Fix Committed
Changed in unity-lens-videos:
status: New → Fix Committed
description: updated
Changed in unity-lens-video (Ubuntu Precise):
importance: Undecided → High
status: New → In Progress
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-video - 0.3.6-0ubuntu1

---------------
unity-lens-video (0.3.6-0ubuntu1) quantal; urgency=low

  [ Łukasz 'sil2100' Zemczak ]
  * New upstream release.
    - Don't try to thumbnail if Nautilus has marked the thumbnailing as failed
      (LP: #977158)
    - Exit on DBus hickup at startup, Unity will restart the lens (LP: #975023)

  [ Didier Roche ]
  * Adding Vcs-Bzr
  * point the new location to the canonical directory
    (lp:ubuntu/unity-lens-video) after the conversion in a merge-upstream
    source
 -- Didier Roche <email address hidden> Thu, 28 Jun 2012 17:50:40 +0200

Changed in unity-lens-video (Ubuntu):
status: Fix Committed → Fix Released

Hello Michael, or anyone else affected,

Accepted unity-lens-video into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity-lens-video/0.3.5-0ubuntu1.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

description: updated
Changed in unity-lens-video (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed

So I might be a bad person to do the verification, since I suggested the fix in the first place...

But yes, the updated version fixes the constant re-thumbnailing for me, assuming that I let nautilus thumbnail them first.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-video - 0.3.5-0ubuntu1.3

---------------
unity-lens-video (0.3.5-0ubuntu1.3) precise-proposed; urgency=low

  * Cherry-pick upstream:
    - Fix one more DBus issue (LP: #975023)

unity-lens-video (0.3.5-0ubuntu1.2) precise-proposed; urgency=low

  * Don't try to thumbnail if Nautilus has marked the thumbnailing as failed (LP: #977158)
  * Exit on DBus hickup at startup, Unity will restart the lens (LP: #975023)
 -- Lukasz 'sil2100' Zemczak <email address hidden> Tue, 03 Jul 2012 11:09:19 +0200

Changed in unity-lens-video (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in unity-lens-videos:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers