unity-lens-video crashed with DBusException in __new__(): org.freedesktop.DBus.Error.NoServer: Failed to connect to socket /tmp/dbus-sFPba6i7zb: Connection refused

Bug #975023 reported by Mariusz Kozłowski on 2012-04-06
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Unity Videos Lens
Undecided
Unassigned
unity-lens-video (Ubuntu)
Medium
Unassigned
Precise
High
Unassigned

Bug Description

[Impact]
It's one of the most report issues on errors.ubuntu.com

[Test Case]
No clear and easy test case sadly... Bug was 'just' happening. Only way of testing: just using and confirming that the given crash is not reported on errors.ubuntu.com in the new package version.

[Regression Potential]
Minimal; an untrapped exception is now being trapped and translated to exit(1), which is unlikely to break any expectations.

Original description:

Randomly happened.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: unity-lens-video 0.3.5-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-22.35-generic 3.2.14
Uname: Linux 3.2.0-22-generic x86_64
ApportVersion: 2.0-0ubuntu4
Architecture: amd64
Date: Fri Apr 6 12:29:43 2012
ExecutablePath: /usr/lib/unity-lens-video/unity-lens-video
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120328)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/lib/unity-lens-video/unity-lens-video
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
PythonArgs: ['/usr/lib/unity-lens-video/unity-lens-video']
SourcePackage: unity-lens-video
Title: unity-lens-video crashed with DBusException in __new__(): org.freedesktop.DBus.Error.NoServer: Failed to connect to socket /tmp/dbus-sFPba6i7zb: Connection refused
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Mariusz Kozłowski (sp3fxc) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-lens-video (Ubuntu):
status: New → Confirmed
Changed in unity-lens-video (Ubuntu):
importance: Undecided → Medium
Sebastien Bacher (seb128) wrote :

The bug is the second most reported on errors.ubuntu.com at the moment we should fix the issue and SRU it

visibility: private → public
Changed in unity-lens-video (Ubuntu Precise):
importance: Undecided → High
status: New → Triaged
milestone: none → ubuntu-12.04.1
David Callé (davidc3) on 2012-06-27
Changed in unity-lens-video (Ubuntu):
status: Confirmed → Fix Committed
Changed in unity-lens-video (Ubuntu Precise):
status: Triaged → Fix Committed
Changed in unity-lens-videos:
status: New → Fix Committed
description: updated
description: updated
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-video - 0.3.6-0ubuntu1

---------------
unity-lens-video (0.3.6-0ubuntu1) quantal; urgency=low

  [ Łukasz 'sil2100' Zemczak ]
  * New upstream release.
    - Don't try to thumbnail if Nautilus has marked the thumbnailing as failed
      (LP: #977158)
    - Exit on DBus hickup at startup, Unity will restart the lens (LP: #975023)

  [ Didier Roche ]
  * Adding Vcs-Bzr
  * point the new location to the canonical directory
    (lp:ubuntu/unity-lens-video) after the conversion in a merge-upstream
    source
 -- Didier Roche <email address hidden> Thu, 28 Jun 2012 17:50:40 +0200

Changed in unity-lens-video (Ubuntu):
status: Fix Committed → Fix Released

Hello Mariusz, or anyone else affected,

Accepted unity-lens-video into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity-lens-video/0.3.5-0ubuntu1.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

description: updated
tags: added: verification-needed
Sebastien Bacher (seb128) wrote :

reuploaded a fix-the-bug-harder version to proposed for Łukasz and David which fixes a case which was not covered by the previous upload, the .changes include both entries and superseed the previous upload if somebody wants to accept the new version

Sebastien Bacher (seb128) wrote :

no regression detected, setting to verification-done

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-video - 0.3.5-0ubuntu1.3

---------------
unity-lens-video (0.3.5-0ubuntu1.3) precise-proposed; urgency=low

  * Cherry-pick upstream:
    - Fix one more DBus issue (LP: #975023)

unity-lens-video (0.3.5-0ubuntu1.2) precise-proposed; urgency=low

  * Don't try to thumbnail if Nautilus has marked the thumbnailing as failed (LP: #977158)
  * Exit on DBus hickup at startup, Unity will restart the lens (LP: #975023)
 -- Lukasz 'sil2100' Zemczak <email address hidden> Tue, 03 Jul 2012 11:09:19 +0200

Changed in unity-lens-video (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in unity-lens-videos:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers