Empty queries being sent to videosearch

Bug #1079699 reported by Tom Haddon on 2012-11-16
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Unity Videos Lens
Undecided
Michal Hruby
unity-lens-video (Ubuntu)
Undecided
Paweł Stołowski
Nominated for Quantal by Timo Jyrinki

Bug Description

I've been investigating the logfiles for videosearch which seem to be an order of magnitude or two larger than any other lens, and it turns out we have lots of empty queries being sent to it. This is causing way more requests than necessary to the service. An example (with IP addresses scrubbed) is:

[14/Nov/2012:06:27:33 +0000] "GET /v0/sources HTTP/1.1" 200 667 "-" "Unity Video Lens Remote Scope v0.4"
[14/Nov/2012:06:27:33 +0000] "GET /v0/search HTTP/1.1" 200 12544 "-" "Unity Video Lens Remote Scope v0.4"

I've filed this bug with "ubuntu-bug" but I'm not sure if it actually affects the version I'm running (I'm on quantal).

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: unity-lens-video 0.3.14-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-18.29-generic 3.5.7
Uname: Linux 3.5.0-18-generic i686
ApportVersion: 2.6.1-0ubuntu6
Architecture: i386
CheckboxSubmission: e9bd5d0c11367f73e7718b1ea675f7ba
CheckboxSystem: bb422ca46d02494cdbc459927a98bc2f
Date: Fri Nov 16 14:29:16 2012
InstallationDate: Installed on 2011-10-04 (409 days ago)
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110921.2)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: unity-lens-video
UpgradeStatus: Upgraded to quantal on 2012-09-05 (72 days ago)

Related branches

Tom Haddon (mthaddon) wrote :
David Callé (davidc3) wrote :

These two queries are sent regularly two check for new video sources and recommendations. I don't remember the exact frequency, I think it's every hour. This could certainly be lowered.

Changed in unity-lens-video (Ubuntu):
assignee: nobody → Pawel Stolowski (stolowski)
Tom Haddon (mthaddon) wrote :

From talking to Chipaca, this is by design, it's the hourly ping to gather recommendations that can be viewed before searching. We're caching the results in squid, so it's not really a problem.

Changed in unity-lens-video (Ubuntu):
status: New → Invalid
Haw Loeung (hloeung) on 2012-11-19
tags: added: canonical-webops-u1
Michal Hruby (mhr3) on 2012-12-04
Changed in unity-lens-video (Ubuntu):
status: Invalid → Confirmed
Changed in unity-lens-video:
assignee: nobody → Michal Hruby (mhr3)
Michal Hruby (mhr3) wrote :

Turns out there is a bug in the scope and when the remote video scope gets an empty result list for recommendations it assumes there was an error and does a RETRY, which is more expensive than a REFRESH.

Michal Hruby (mhr3) on 2012-12-06
Changed in unity-lens-video:
status: New → In Progress
Drey (drey) wrote :

This queries even happen when "Include Online Search Results" set to "Off" in Privacy panel of System Settings!

Michal Hruby (mhr3) on 2014-04-15
Changed in unity-lens-video:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers