Ubuntu

[FFe] [UIFe] No easy way to disable online-fetched results in lenses

Reported by Iain Lane on 2012-09-22
318
This bug affects 64 people
Affects Status Importance Assigned to Milestone
AskUbuntu Lens
Undecided
Didier Roche
Google Documents Lens
Undecided
Alberto Mardegan
Gwibber
Undecided
Didier Roche
Music Lens
High
Didier Roche
Photos Lens
High
Didier Roche
Ubuntu Translations
Undecided
Unassigned
Unity
High
Didier Roche
Unity Remote Videos scope
High
Didier Roche
Wikipedia Lens
Undecided
Didier Roche
libunity
High
Didier Roche
unity-lens-shopping
High
Didier Roche
activity-log-manager (Ubuntu)
High
Didier Roche
Quantal
High
Didier Roche
gwibber (Ubuntu)
High
Didier Roche
Quantal
High
Didier Roche
libunity (Ubuntu)
High
Didier Roche
Quantal
High
Didier Roche
unity-lens-help (Ubuntu)
Undecided
Unassigned
unity-lens-music (Ubuntu)
High
Didier Roche
Quantal
High
Didier Roche
unity-lens-photos (Ubuntu)
Undecided
Unassigned
unity-lens-radios (Ubuntu)
High
Didier Roche
Quantal
High
Didier Roche
unity-lens-shopping (Ubuntu)
High
Didier Roche
Quantal
High
Didier Roche
unity-scope-gdocs (Ubuntu)
Undecided
Unassigned
unity-scope-video-remote (Ubuntu)
High
Didier Roche
Quantal
High
Didier Roche

Bug Description

We will add an option in the Privacy panel of System Settings.

This on/off switch enables to remove all internet connexion in any lens you have installed supporting the option (which are all lenses in the ubuntu repository).

All lenses components and libunity are impacted by the change, as well as gnome-control-center. A couple of new strings will be added to the latest for the option.

see on comment #27 the screenshot of the privacy settings dash panel. This one is in gnome-control-center (but the source is activity-log-manager for it).
The additional strings are:

#: ../src/activity-log-manager.vala:57
msgid "Search Results"
msgstr ""

#: ../src/searchresults-widget.vala:60
#, c-format
msgid "When searching in the Dash:"
msgstr ""

#: ../src/searchresults-widget.vala:67
#, c-format
msgid "Include online search results."
msgstr ""

------------

The fact that this lens is installed by default means that users are shown commercial content as search results by default in the home screen, and that search queries are sent to an external (to the user) server. It's reasonable that one might want to turn this behaviour off. While it is possible to uninstall the package, this isn't a particularly intuitive route for most.

Other lenses have a 'Filter results' item, which would solve this if on the home screen. Otherwise, an option somewhere in the control centre (privacy?) would be good.

Related branches

lp:~mardy/unity-scope-gdrive/lp1054746
Merged into lp:unity-scope-gdrive at revision 19
Didier Roche: Approve on 2012-09-27
David King (community): Approve on 2012-09-27
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-lens-shopping (Ubuntu):
status: New → Confirmed
Thomas Kluyver (takluyver) wrote :

For that matter, I don't think this should be in the home lens by default. Every time I search for an application or a file, it seems that my search will be transmitted to the web. That should be opt-in, not opt-out.

Please, put these results in a separate lens, not in the home lens. They would still be easily accessible when users want them, but there would be no privacy issue. It also avoids the negative publicity now growing on tech news sites like Slashdot and Hacker News.

Iain Lane (laney) wrote :

Thomas, could you file a separate bug about that please? I'd really like to keep this one about the one issue (and on topic).

Thomas Kluyver (takluyver) wrote :

I'm happy to do that if you prefer, but I see it as two alternative solutions to the same bug. As you described, the problem is that commercial items show up during local searches, and transmitting local searches to a remote server breaks an expectation of privacy. You propose making the opt-out more visible, while I propose making the feature opt-in.

If you still feel my comment should be a separate bug, let me know, and I'll open one.

Iain Lane (laney) wrote :

Yes. I'm asking for a way to disable the lens. You want it to present its results elsewhere. To me, these are related but separate.

Jeremy Bicha (jbicha) wrote :

Thomas, yes please open a separate bug.

Thomas Kluyver (takluyver) wrote :

OK, I've opened bug #1054776.

Iain Lane (laney) on 2012-09-24
Changed in unity-lens-shopping:
status: New → Confirmed
Didier Roche (didrocks) on 2012-09-25
Changed in unity-lens-shopping (Ubuntu):
assignee: nobody → Didier Roche (didrocks)
importance: Undecided → High
Changed in unity-lens-shopping:
importance: Undecided → High
Didier Roche (didrocks) on 2012-09-25
Changed in libunity:
status: New → Triaged
Changed in unity:
status: New → Triaged
assignee: nobody → Didier Roche (didrocks)
Changed in libunity:
assignee: nobody → Didier Roche (didrocks)
Changed in unity:
importance: Undecided → High
Changed in libunity:
importance: Undecided → High
Changed in libunity (Ubuntu Quantal):
importance: Undecided → High
status: New → Triaged
Changed in unity-lens-shopping:
status: Confirmed → Triaged
assignee: nobody → Didier Roche (didrocks)
Changed in libunity (Ubuntu Quantal):
assignee: nobody → Didier Roche (didrocks)
Changed in unity:
milestone: none → 6.8
Changed in unity-lens-applications:
assignee: nobody → Didier Roche (didrocks)
importance: Undecided → High
status: New → Triaged
Didier Roche (didrocks) on 2012-09-25
Changed in unity-lens-applications (Ubuntu Quantal):
assignee: nobody → Didier Roche (didrocks)
importance: Undecided → High
status: New → Triaged
Changed in unity-lens-video (Ubuntu Quantal):
assignee: nobody → Didier Roche (didrocks)
importance: Undecided → High
status: New → Triaged
Changed in unity-lens-music (Ubuntu Quantal):
assignee: nobody → Didier Roche (didrocks)
importance: Undecided → High
status: New → Triaged
Changed in unity-lens-videos:
assignee: nobody → Didier Roche (didrocks)
importance: Undecided → High
status: New → Triaged
Changed in unity-lens-music:
assignee: nobody → Didier Roche (didrocks)
importance: Undecided → High
status: New → Triaged
Changed in gnome-control-center (Ubuntu Quantal):
assignee: nobody → Didier Roche (didrocks)
importance: Undecided → High
status: New → Triaged
Didier Roche (didrocks) on 2012-09-26
affects: unity-lens-video (Ubuntu Quantal) → unity-scope-video-remote (Ubuntu Quantal)
affects: unity-lens-videos → unity-scope-video-remote
Didier Roche (didrocks) on 2012-09-26
summary: - No easy way to disable (results from) this lens
+ [FFe] [UIFe] No easy way to disable (results from) this lens
description: updated
Didier Roche (didrocks) on 2012-09-26
description: updated

From a feature freeze point of view I have no problem with this, as long as it
is tested by some people to do what is expected (stage in a PPA once merged
upstream for testing).

The docs team will need to sign off that any screenshots or text they have
describing this feature will be updated.

As for translations, if it's possible to re-use strings we already have
translated that would be ideal. The translators will be able to comment more.
Please could you mail both lists (docs and translators), as is the process for
UIFe requests? And then update the description with a link to the mails in the
web archives.

And putting it in "Privacy" seems to me far more intuitive than "Appearance". I
don't think I'd consider looking in the latter for this kind of setting.

I'm going to reset all of the Ubuntu tasks to New so that the last of docs or
translators can update to Triaged if/when they approve this.

Changed in gnome-control-center (Ubuntu Quantal):
status: Triaged → New
Changed in libunity (Ubuntu Quantal):
status: Triaged → New
Changed in unity-lens-applications (Ubuntu Quantal):
status: Triaged → New
Changed in unity-lens-music (Ubuntu Quantal):
status: Triaged → New
Changed in unity-lens-shopping (Ubuntu Quantal):
status: Confirmed → New
Changed in unity-scope-video-remote (Ubuntu Quantal):
status: Triaged → New
Didier Roche (didrocks) wrote :

Removed the app lens, it's been descoped by the design team and they still want those results to be shown here.

no longer affects: unity-lens-applications
no longer affects: unity-lens-applications (Ubuntu)
David Planella (dpm) wrote :

+1 from the translations team, as I think such an important feature shouldn't block on translations. Please do send an e-mail to the ubuntu-doc and ubuntu-translators mailing lists as per the UIFe procedure, though.

In any case, if as Iain suggests, the messages shown to the user could be generic enough so that existing translations could be used, that'd be a plus for translators.

Alberto Mardegan (mardy) on 2012-09-26
Changed in unity-lens-gdocs:
assignee: nobody → Alberto Mardegan (mardy)
importance: Undecided → High
status: New → In Progress
Jeremy Bicha (jbicha) wrote :

-1 from the Docs Team.

Adding a switch to System Settings means that our docs are out of date. These are the docs that I spent most of my weekend working on, since the Design Team really needed to get those dozens of UI Freeze Exceptions done beyond the last possible minute on Thursday, and even Monday (for the new launcher icons). Every one agreed that docs would freeze yesterday at 9 pm UTC. That still gave all day Saturday, Sunday, Monday, and Tuesday for Canonical to scramble to find a fix for this problem.

This is why we shouldn't approve very late major Feature Freeze Exceptions/User Interface Freeze Exceptions. These features *will* need tweaking.

At some point, we actually do hit a hard User Interface Freeze/Feature Freeze. Considering that those "deadlines" passed a month ago, I believe we've already reached that point.

Also, I don't think we can approve this until it is explicit about what exactly the UI will look like. If that's not agreed upon in advance, then there is a decent chance that people will want to change it again.

From the docs side, you could just add an extra gsettings string. We don't document dconf-editor and while we do have some "gsettings set" instructions on other pages, you could say that arguably using Software Center to remove the lens is better since it's graphical and easier. Or you could remove the shopping feature. It's very easy to remove documentation.

For reference, this is the docs page:
http://bazaar.launchpad.net/~ubuntu-core-doc/ubuntu-docs/quantal/view/head:/ubuntu-help/C/unity-shopping.page

Didier Roche (didrocks) wrote :
description: updated
Didier Roche (didrocks) on 2012-09-26
description: updated

That title was bugging me since the bug was reported :)

summary: - [FFe] [UIFe] No easy way to disable (results from) this lens
+ [FFe] [UIFe] No easy way to disable online results in lenses
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Didier Roche (didrocks) on 2012-09-26
affects: gnome-control-center (Ubuntu Quantal) → activity-log-manager (Ubuntu Quantal)
Changed in activity-log-manager (Ubuntu Quantal):
status: New → Confirmed
Changed in activity-log-manager (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) wrote :
description: updated
description: updated
Didier Roche (didrocks) wrote :
description: updated
Changed in unity-lens-music:
status: Triaged → Fix Committed
Didier Roche (didrocks) wrote :
description: updated

Commercial/non-commercial seems at least somewhat orthogonal to the title of
the bug.

Scott, we've been discussing this in #ubuntu-desktop. It's not as easy to disable all online results, and someone who wants to use the social networking integration (Gwibber lens, photo lens, even Google docs scope for files lens) but not the "ads" doesn't have a way to do that easily in the GUI.

summary: - [FFe] [UIFe] No easy way to disable online results in lenses
+ [FFe] [UIFe] No easy way to disable sponsored results in lenses
Iain Lane (laney) on 2012-09-26
summary: - [FFe] [UIFe] No easy way to disable sponsored results in lenses
+ [FFe] [UIFe] No easy way to disable results from Canonical partners in
+ lenses

Hi Jeremy! So, I understand that I shouldn't modify the Google Docs scope to respect this setting?

Alexandre Franke (afranke) wrote :

As the admin of the French localization team, you have my +1 too.

Didier Roche (didrocks) wrote :

@mardy: that's what I told you on IRC an hour ago :)

Didier Roche (didrocks) on 2012-09-26
description: updated
Redmar (redmar) wrote :

As a translator, three extra strings are not a big deal, so +1 on that account. I also think this option will address important privacy concerns.

However, I do feel there have been too many UIFE this cycle, as #11 indicates. It is a huge motivation killer to lose a couple of hours of work due to some external change you have little control over. Just imagine losing a couple of hours worth of work on some nice feature. Especially when you are a volunteer donating your free time to a project.

Jeremy Bicha (jbicha) wrote :

Ok, changing the UI this late most affects documentation (me) and the translators.

Since we now have 2 +1's from translators not counting dpm's +1, I'll change my -1 vote from the Docs Team to a +1. Please, please let's handle the feature & UI freezes better next cycle.

I'll update the documentation tonight and make sure the ubuntu-docs pot gets uploaded.

Gabor Kelemen (kelemeng) wrote :

As another translator, I agree with Redmar, so +1.

Didier Roche (didrocks) on 2012-09-27
description: updated
Alberto Mardegan (mardy) on 2012-09-27
no longer affects: unity-lens-gdocs
Didier Roche (didrocks) on 2012-09-27
description: updated
Changed in unity-lens-radios (Ubuntu Quantal):
assignee: nobody → Didier Roche (didrocks)
importance: Undecided → High
status: New → Triaged
Didier Roche (didrocks) on 2012-09-27
Changed in activity-log-manager (Ubuntu Quantal):
status: New → Fix Committed
Changed in unity-lens-shopping:
status: Triaged → Fix Committed
Changed in libunity:
status: Triaged → Fix Committed
Didier Roche (didrocks) on 2012-09-27
Changed in unity-scope-video-remote:
status: Triaged → Fix Committed
Didier Roche (didrocks) on 2012-09-27
Changed in unity-lens-radios (Ubuntu Quantal):
status: Triaged → Fix Committed
no longer affects: unity-lens-radios
Changed in gwibber:
assignee: nobody → Didier Roche (didrocks)
status: New → In Progress
Changed in gwibber (Ubuntu Quantal):
assignee: nobody → Didier Roche (didrocks)
importance: Undecided → High
Didier Roche (didrocks) on 2012-09-27
Changed in unity-lens-wikipedia:
assignee: nobody → Didier Roche (didrocks)
status: New → In Progress
no longer affects: unity-lens-applications (Ubuntu Quantal)
Didier Roche (didrocks) on 2012-09-27
Changed in unity-lens-wikipedia:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-09-27
Changed in askubuntu-lens:
assignee: nobody → Didier Roche (didrocks)
status: New → In Progress
Didier Roche (didrocks) on 2012-09-27
summary: - [FFe] [UIFe] No easy way to disable results from Canonical partners in
- lenses
+ [FFe] [UIFe] No easy way to disable online-fetched results in lenses
Didier Roche (didrocks) on 2012-09-27
Changed in unity-lens-gdocs:
assignee: nobody → Alberto Mardegan (mardy)
status: New → Fix Committed
Changed in unity-lens-photos:
assignee: nobody → Didier Roche (didrocks)
status: New → Fix Committed
Alberto Mardegan (mardy) on 2012-09-27
Changed in unity-lens-gdocs:
status: Fix Committed → Fix Released
Jeremy Bicha (jbicha) on 2012-09-27
description: updated
Didier Roche (didrocks) wrote :
description: updated
Scott Kitterman (kitterman) wrote :

FFe approved for the "Hopefully real final design" as long as it can be uploaded very soon. Can these all be uploaded by Monday? If we're going to churn the design again, then please ask again.

Changed in unity-scope-video-remote (Ubuntu Quantal):
milestone: none → ubuntu-12.10
status: New → Triaged
Changed in unity-scope-gdocs (Ubuntu):
milestone: none → ubuntu-12.10
status: New → Triaged
Didier Roche (didrocks) on 2012-09-27
Changed in unity-lens-shopping (Ubuntu Quantal):
status: New → Triaged
Changed in unity-lens-photos (Ubuntu):
status: New → Triaged
Didier Roche (didrocks) on 2012-09-27
Changed in unity-lens-music (Ubuntu Quantal):
status: New → Triaged
Changed in unity-lens-help (Ubuntu):
status: New → Triaged
Changed in libunity (Ubuntu Quantal):
status: New → Triaged
Changed in gwibber (Ubuntu Quantal):
status: New → Triaged
Mark Tully (markjtully) on 2012-09-27
Changed in askubuntu-lens:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package activity-log-manager - 0.9.4-0ubuntu4

---------------
activity-log-manager (0.9.4-0ubuntu4) quantal; urgency=low

  * debian/patches/05_add_missing_configvapi.patch:
    - add missing file which should be disted upstream for autoreconf
  * Run autoreconf when building
  * debian/patches/06_add_unity_dash_privacy.patch:
    - add unity dash privacy tab to the privacy g-c-c panel (LP: #1054746)
 -- Didier Roche <email address hidden> Wed, 26 Sep 2012 14:03:52 +0200

Changed in activity-log-manager (Ubuntu Quantal):
status: Fix Committed → Fix Released

I've updated to activity-log-manager 0.9.4-0ubuntu4, but I can't see the new tab.

from the patch:

+ bool unity_installed = false;
+ foreach (var schema in schemas)
+ {
+ if (schema == "com.canonical.Unity.Lenses") {
+ unity_installed = true;
+ break;
+ }
+ }

I don't appear to have the "com.canonical.Unity.Lenses" schema installed, even though I'm running unity.

David Callé (davidc3) on 2012-09-28
Changed in unity-lens-photos:
importance: Undecided → High
milestone: none → 0.8
Didier Roche (didrocks) wrote :

@Michael: I only explicitely told it on IRC and G+, but the panel will appear only when next Unity release (with the lenses supporting the option) will be out. That's why there is this schema test.

David Callé (davidc3) on 2012-09-28
Changed in unity-scope-video-remote:
milestone: none → 0.3.9
mikelococo (mikelococo) wrote :

Does this proposed fix prevent *display* of results, or *sending* of queries to the productsearch servers? The latter is clearly what's desired by the community.

Additionally, the proposed design in comment #27 is misleading. This setting doesn't guarantee that all online results will be omitted from the dash. The proposal in comment #18 is "correct" in describing the scope of this setting.

Changed in unity-lens-shopping:
milestone: none → 6.8.0
Didier Roche (didrocks) on 2012-10-02
Changed in unity-lens-photos:
status: Fix Committed → Fix Released
Changed in unity-scope-video-remote:
status: Fix Committed → Fix Released
papukaija (papukaija) on 2012-10-02
tags: added: privacy
tags: added: ffe uife
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 3.6.0-0ubuntu1

---------------
gwibber (3.6.0-0ubuntu1) quantal-proposed; urgency=low

  * New upstream release
    - Add disabling online search support, requires libunity 6.7 or
      later, thanks to Didier Roche (LP: #1054746)
    - Don't let the lens start gwibber-service unless data is
      needed (LP: #1046360)
  * debian/control
    - bump build depends for libunity-dev to >= 6.8
 -- Ken VanDine <email address hidden> Thu, 04 Oct 2012 12:16:49 -0400

Changed in gwibber (Ubuntu Quantal):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-scope-video-remote - 0.3.9-0ubuntu1

---------------
unity-scope-video-remote (0.3.9-0ubuntu1) quantal-proposed; urgency=low

  * New upstream release.
    - Incorrect capitalization in "More suggestions" results (LP: #1056091)
    - Online videos flickering when switched to their view (LP: #1058097)
    - [FFe] [UIFe] No easy way to disable online-fetched results in lenses
      (LP: #1054746)
  * debian/control:
    - needs latest gir1.2-unity-5.0 for new API
  * debian/watch: point to the right launchpad project
 -- Didier Roche <email address hidden> Tue, 02 Oct 2012 17:19:16 +0200

Changed in unity-scope-video-remote (Ubuntu Quantal):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libunity - 6.8.0-0ubuntu1

---------------
libunity (6.8.0-0ubuntu1) quantal-proposed; urgency=low

  [ Didier Roche ]
  * Install the new schema file
  * add intltool as a build-dep

  [ Dmitry Shachnev ]
  * Make libunity9 depend on unity-common >= 6.0.0-0ubuntu3 (LP: #1055019).

  [ Timo Jyrinki ]
  * New upstream release.
    - Converts white space to underscores when trying to export the mpris
      bus (LP: #1031933)
    - Added size hint to AnnotatedIcon (LP: #1052513)
    - Add remote search disabling option support to libunity for lenses to
      consume it (LP: #1054746)
    - Make sender wrap the title property and set the subtitle in the
      constructor. (LP: #1058198)
    - Allow null preview argument in preview_ready signal by declaring it
      with "?" (LP: #1060281)
  * debian/libunity9.symbols:
    - update symbols to include the new APIs
 -- Timo Jyrinki <email address hidden> Wed, 03 Oct 2012 09:22:42 +0300

Changed in libunity (Ubuntu Quantal):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-photos - 0.8-0ubuntu1

---------------
unity-lens-photos (0.8-0ubuntu1) quantal-proposed; urgency=low

  * New upstream release.
    - Fix previews for raw files by using shotwell generated jpg file
      (LP: #1057949, #1057432)
    - [FFe] [UIFe] No easy way to disable online-fetched results in lenses
      (LP: #1054746)
  * Cherry-pick:
    - The shortcut Super + P is conflicting with the Video out hotkey
      (LP: #1049090)
  * debian/control:
    - needs latest gir1.2-unity-5.0 for new API
  * debian/source/format:
    - remove format 3, not playing nice with merge-upstream workflow
 -- Didier Roche <email address hidden> Thu, 04 Oct 2012 17:27:38 +0200

Changed in unity-lens-photos (Ubuntu):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-help - 1.7.1

---------------
unity-lens-help (1.7.1) quantal-proposed; urgency=low

  * Taken in upstream trunk:
    - disable online results (LP: #1054746)
  * debian/control:
    - dep on latest gir1.2-unity-5.0
 -- Didier Roche <email address hidden> Thu, 04 Oct 2012 17:42:37 +0200

Changed in unity-lens-help (Ubuntu):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-radios - 0.2-0ubuntu1

---------------
unity-lens-radios (0.2-0ubuntu1) quantal-proposed; urgency=low

  * add disabling online search support (LP: #1054746)
  * debian/control:
    - build-dep on new unity gir
 -- Didier Roche <email address hidden> Thu, 04 Oct 2012 17:32:05 +0200

Changed in unity-lens-radios (Ubuntu Quantal):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-shopping - 6.8.0-0ubuntu1

---------------
unity-lens-shopping (6.8.0-0ubuntu1) quantal-proposed; urgency=low

  [ Łukasz 'sil2100' Zemczak ]
  * New upstream release.
    - Use music lens details page for music store results (LP: #1055684)
    - No easy way to disable online-fetched results in lenses (LP: #1054746)
    - Display category emblems on results (LP: #1056901)
    - Descriptions are missing all html tags (LP: #1058197)

  [ Didier Roche ]
  * debian/control:
    - bump libunity build-dep
 -- Didier Roche <email address hidden> Thu, 04 Oct 2012 16:46:32 +0200

Changed in unity-lens-shopping (Ubuntu Quantal):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-scope-gdocs - 0.5-0ubuntu1

---------------
unity-scope-gdocs (0.5-0ubuntu1) quantal-proposed; urgency=low

  * New upstream release.
    - Do not make any online queries if remote searches have been
      disabled. (LP: #1054746)
    - Prevent multiple authorizations of the same account (LP: #1053647)
  * debian/control
    - depend on gir1.2-unity-5.0 >= 6.8 for Unity.PreferencesManager
 -- Ken VanDine <email address hidden> Thu, 04 Oct 2012 10:35:00 -0400

Changed in unity-scope-gdocs (Ubuntu):
status: Triaged → Fix Released
Didier Roche (didrocks) on 2012-10-05
Changed in unity-lens-music (Ubuntu Quantal):
status: Triaged → Fix Released
Changed in unity:
status: Triaged → Fix Released
Changed in gwibber:
status: In Progress → Fix Released
Changed in libunity:
status: Fix Committed → Fix Released
Changed in unity-lens-shopping:
status: Fix Committed → Fix Released
Changed in unity-lens-music:
status: Fix Committed → Fix Released
Mark Tully (markjtully) on 2012-10-05
Changed in askubuntu-lens:
status: Fix Committed → Fix Released
Jonathan Higgins (lpah012) wrote :

#32 is right: "Include online search results" sounds like the search is performed and the results are just not displayed. Please change it to something like "Search online"

Adolfo Jayme (fitoschido) wrote :

@lpah012: The UI text cannot change anymore at this point, it has hardly been translated now, and we're very close to the release date.

The switch prevents Unity lenses to perform online searches, isn't that clear enough?

Scott Kitterman (kitterman) wrote :

It looks like there's no further release team action for this bug, so unsubscribing the team.

David King (amigadave) on 2012-10-25
Changed in unity-lens-gdocs:
milestone: none → 0.5
Changed in ubuntu-translations:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers