unity-lens-photos crashed with ImportError in /usr/lib/unity-lens-photos/flickr_scope.py: No module named oauthlib.oauth1

Bug #1053257 reported by Ivan Sagalaev on 2012-09-20
88
This bug affects 20 people
Affects Status Importance Assigned to Milestone
unity-lens-photos (Ubuntu)
Medium
Unassigned

Bug Description

I suspect this happened after I "apt-get autoremoved" the python3-oauth which apt reported as no longer needed…

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: unity-lens-photos 0.6-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-15.22-generic 3.5.4
Uname: Linux 3.5.0-15-generic x86_64
ApportVersion: 2.5.2-0ubuntu4
Architecture: amd64
Date: Thu Sep 20 00:44:51 2012
ExecutablePath: /usr/lib/unity-lens-photos/unity-lens-photos
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
InterpreterPath: /usr/bin/python3.2mu
PackageArchitecture: all
ProcCmdline: /usr/bin/python3 /usr/lib/unity-lens-photos/unity-lens-photos
PythonArgs: ['/usr/lib/unity-lens-photos/unity-lens-photos']
SourcePackage: unity-lens-photos
Title: unity-lens-photos crashed with ImportError in /usr/lib/unity-lens-photos/flickr_scope.py: No module named oauthlib.oauth1
UpgradeStatus: Upgraded to quantal on 2012-09-06 (13 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Ivan Sagalaev (isagalaev) wrote :
tags: removed: need-duplicate-check
Changed in unity-lens-photos (Ubuntu):
importance: Undecided → Medium
Timo Aaltonen (tjaalton) on 2012-09-20
visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-lens-photos (Ubuntu):
status: New → Confirmed
Para Siva (psivaa) on 2012-09-20
tags: added: rls-q-incoming
David Callé (davidc3) wrote :

The package is missing a depends on python3-oauthlib.

Changed in unity-lens-photos (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-photos - 0.6-0ubuntu2

---------------
unity-lens-photos (0.6-0ubuntu2) quantal; urgency=low

  * debian/control:
    - add miss dep from previous upload:
      gir1.2-gdata-0.0, python3-oauthlib (LP: #1053257)
    - add gir1.2-unity-5.0 versionning
 -- Didier Roche <email address hidden> Thu, 20 Sep 2012 14:51:25 +0200

Changed in unity-lens-photos (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers