photo lens is empty

Bug #1048038 reported by Pavol Klačanský on 2012-09-08
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
unity-lens-photos (Ubuntu)
Undecided
Unassigned

Bug Description

Hi, I have Ubuntu Q and if I open photo lens, spinner spins for few seconds and then nothing, lens is empty all the time.

David Callé (davidc3) wrote :

Hello,
Do you have any photos imported in Shotwell, or have you added a Flickr, Facebook or Google account via the Online Accounts panel in System Settings?

I have many photos in shotwell, few in facebook and picasa

David Callé (davidc3) wrote :

If you don't mind doing a test, please open a terminal and run:

killall unity-lens-photos
/usr/lib/unity-lens-photos/unity-lens-photos

And do a search in the lens.
Then, paste the terminal output here (feel free to obfuscate any personal info in the log).

hmm, if I start it over command line, lens works, but it didn't worked
before,

David Callé (davidc3) wrote :

Is this still happening over a reboot?

Changed in unity-lens-photos (Ubuntu):
status: New → Incomplete

no, thanks, it was quite weird though

David Callé (davidc3) wrote :

Ok, I'm marking the bug as invalid, but I'll keep an eye on it. Feel free to change the status back if it happens again.

Changed in unity-lens-photos (Ubuntu):
status: Incomplete → Invalid
Israel Dahl (israeldahl) wrote :

Hi, I am Beta testing Quantal and I have experienced this error. I am using the same /home partition to test this Beta out. I haven't ever opened shotwell since testing. I did run the two lines
killall unity-lens-photos
/usr/lib/unity-lens-photos/unity-lens-photos
and absolutely nothing happens, and then the terminal sits as though some program is open. I can still terminate the photo lens in a tab by running 'killall unity-lens-photos' (which outputs "Terminated")

I definetly have plenty of Pictures in my ~/Pictures folder.... so I would expect the lens to automatically know that my pictures are there without shotwell. I will post this link in the qa.tracker

Changed in unity-lens-photos (Ubuntu):
status: Invalid → New
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1048038

tags: added: package-qa-testing
David Callé (davidc3) wrote :

Hi Israel, the lens only works for photos imported in Shotwell (and Flickr, Facebook, Picasa online accounts). Does the lens works as expected if you import something in Shotwell?

If yes, then you are not experiencing a bug, but feel free to open a report about the lack of support for ~/Pictures, as this should be fixed for 13.04.

Israel Dahl (israeldahl) wrote :

Yes. It works fine, though I do consider that a bug as a new user wouldn't know to do such a thing. How would I open a report for 13.04? Thanks for your quick response by the way!

David Callé (davidc3) wrote :

I get your point, but the lens has been worked on to be very photo centric (as opposed to "any image" centric), Shotwell being the dedicated application for photo management, it made sense to give it priority. It also makes it much easier to differentiate between image types : things in ~/Pictures can be wallpapers, screenshots and so on, they are Files lens material, things in Shotwell are usually only photos and they can be on an external drive, a SD card, etc. Next cycle, we *should* be able to have support for ~/Pictures, with prioritization for actual photos.

Just open a new bug on unity-lens-photos about the fact that it doesn't support stuff in ~/Pictures. It won't be specific for 13.04, but I will set a high priority for it.

John Kuang (xiphosurus) wrote :

My photo lens is empty too despite having lots of photos in shotwell, facebook, picasa, last 2 linked in online accounts. Turns out the unity-lens-photos isn't running (can't kill it), and when I try to run it, I get this error message:

/usr/lib/python3/dist-packages/gi/_gobject/__init__.py:279: Warning: attempting to add an interface (UnityMergeStrategy) to class (__main__+Merger) after class_init
  type_register(cls, namespace.get('__gtype_name__'))
Traceback (most recent call last):
  File "/usr/lib/unity-lens-photos/unity-lens-photos", line 103, in <module>
    class Merger (GObject.Object, Unity.MergeStrategy):
  File "/usr/lib/python3/dist-packages/gi/types.py", line 230, in __init__
    cls._setup_vfuncs()
  File "/usr/lib/python3/dist-packages/gi/types.py", line 118, in _setup_vfuncs
    for vfunc_name, py_vfunc in cls.__dict__.items():
  File "/usr/lib/python3.2/warnings.py", line 18, in showwarning
    file.write(formatwarning(message, category, filename, lineno, line))
  File "/usr/lib/python3.2/warnings.py", line 25, in formatwarning
    line = linecache.getline(filename, lineno) if line is None else line
  File "/usr/lib/python3.2/linecache.py", line 15, in getline
    lines = getlines(filename, module_globals)
  File "/usr/lib/python3.2/linecache.py", line 41, in getlines
    return updatecache(filename, module_globals)
  File "/usr/lib/python3.2/linecache.py", line 81, in updatecache
    stat = os.stat(fullname)
RuntimeError: Couldn't find GType of implementor of interface UnityMergeStrategy. Forgot to set __gtype_name__?

John Kuang (xiphosurus) wrote :

Since I am experiencing different symptoms, I think I have a real bug on hand, and have filed a new one at https://bugs.launchpad.net/ubuntu/+source/unity-lens-photos/+bug/1135029

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers