Unity-lens-photo takes all cpu

Bug #1047739 reported by Jorge Ortega on 2012-09-08
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Photos Lens
High
David Callé
unity-lens-photos (Ubuntu)
Undecided
Unassigned

Bug Description

On ubuntu 12.10.
My photo colection is on a ntfs partition and are imported into shotwell. Everytime I make a search the lens takes all power of one processor core for several minutes. Eventurally it finds what it was looking for -as I said after maybe a couple of minutes. I have about 5000 pictures. The experience makes the lens unusable.

David Callé (davidc3) on 2012-09-08
Changed in unity-lens-photos (Ubuntu):
assignee: nobody → David Callé (davidc3)
status: New → Confirmed
David Callé (davidc3) wrote :

This happens because the search doesn't rely only on Shotwell db, but also verifies some data directly in the files.
I think your use case makes it clear that it shouldn 't.

David Callé (davidc3) on 2012-09-08
Changed in unity-lens-photos (Ubuntu):
status: Confirmed → In Progress
Changed in unity-lens-photos:
assignee: nobody → David Callé (davidc3)
status: New → In Progress
Changed in unity-lens-photos (Ubuntu):
assignee: David Callé (davidc3) → nobody
status: In Progress → Confirmed
Changed in unity-lens-photos:
importance: Undecided → High
David Callé (davidc3) wrote :

Hello Jorge,
could you please try this photos lens package to see if it improves your situation?
https://launchpad.net/~unity-lens-photos/+archive/staging/+build/3776203

This version will never try to check your ntfs partition while searching, as I assumed this was the main performance bottleneck.

Thanks!

Jorge Ortega (jorge-ortega111) wrote :

Looking forward to doing it tonight when I get back home.

A couple of things:

I reverted back to Precise on my computer as 12.10 was giving me too much trouble. I do have it installed on a memory stick and the issue is the same so it should be OK to try it there.

The version I have installed is 64 bits and your package seems to be 32. Any issue there?

David Callé (davidc3) wrote :

The package is architecture agnostic, it won't be an issue.

David Callé (davidc3) on 2012-09-10
Changed in unity-lens-photos:
milestone: none → 0.5
Jorge Ortega (jorge-ortega111) wrote :

OK, I would've loved to give you some clear feed back but I have none.

From a clean usb stick installation, with both, local collection (ntfs) and picasa account enabled.

So i reimported my collection into Shotwell and started making searches. From the main dash, and from the photo lens for both, local disk AND Picasa (I mean, some times I used one, some times the other), the cpu went to 100 for a couple of minutes. After say 20 minutes to half and hour the intence cpu usage stopped altogether. But searches still take one to two minutes maybe. Until it finds the correct photos it shows other different pictures, maybe 2 or 3 times before it arrives to the good ones.

This is all with that build you provided me with. Please, let me know If I can do anything else to clarify this. Tomorrow I'll do some more trials.

Maybe the fact that it takes so long should be filled as a different bug?

Jorge Ortega (jorge-ortega111) wrote :

I have spent some more time with it and it is definetly the local colection. Picasa search works fine (but a bit unreliably...). Local search on the ntfs sucks all the cpu power and take loooong.

David Callé (davidc3) wrote :

I've found another bottleneck: tag search.
I'll push a new test build in a few hours to this PPA https://code.launchpad.net/~unity-lens-photos/+archive/staging

David Callé (davidc3) wrote :

It's available for testing, Launchpad has finally decided to build it.

Jorge Ortega (jorge-ortega111) wrote :

OK, being testing it for a while now and I have to say that it works great. Good job David.
I've seen you've implemented multi tag search and this is working well too.
There are a couple of smaller things for which I am now going to open new bug reports.
Thanks for your work

David Callé (davidc3) on 2012-09-11
Changed in unity-lens-photos:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-photos - 0.6-0ubuntu1

---------------
unity-lens-photos (0.6-0ubuntu1) quantal; urgency=low

  * New upstream release.
    - The online account g-c-c interface doesn't support i18n (LP: #1052375)
    - Desktop file does not validate with desktop-file-validate (LP: #1051949)
    - Unity-lens-photo takes all cpu (LP: #1047739)
    - no pictures previews from dash (LP: #1049268)
    - unity-lens-photos crashed with TypeError in constructor(): Argument 0
      does not allow None as a value (LP: #1047754)
    - Older results from Shotwell are not correctly sorted when they contain
      photos without an exposure time (LP: #1049561)
    - Description of application should be ‘Photos search plugin’ (LP: #1050361)
    - Unity-lens-photo can only search one tag at a time (LP: #1047740)
 -- Ken VanDine <email address hidden> Wed, 19 Sep 2012 16:17:30 -0400

Changed in unity-lens-photos (Ubuntu):
status: Confirmed → Fix Released
David Callé (davidc3) on 2012-09-20
Changed in unity-lens-photos:
status: Fix Committed → Fix Released
enedene (enedene) wrote :

I have this problem on ubuntu 13.04

Scott White (s-whit385) wrote :

I have this problem on 13.04 as well. The Photo Lens doesn't register anything and just keeps searching, and it causes my CPU to run higher than normal from about 45Celcius to over 75Celcius. As such I'll most likely just uninstall the lens since I never use it that much.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers