unity-music-daemon crashed with SIGSEGV in find_term_real() from dee_tree_index_lookup() from dee_index_lookup() from unity_music_lens_rhythmbox_collection_search()

Bug #963991 reported by Chris Giltnane on 2012-03-24
670
This bug affects 97 people
Affects Status Importance Assigned to Milestone
Music Lens
Undecided
Unassigned
Unity
Fix Released
High
Michal Hruby
dee
High
Michal Hruby
dee (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned
unity-lens-music (Ubuntu)
Medium
Unassigned

Bug Description

Seemed to be random as could not identify any way to reproduce on demand

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: unity-lens-music 5.8.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-20.32-generic 3.2.12
Uname: Linux 3.2.0-20-generic i686
ApportVersion: 1.95-0ubuntu1
Architecture: i386
Date: Sat Mar 24 15:13:12 2012
ExecutablePath: /usr/lib/unity-lens-music/unity-music-daemon
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta i386 (20110413)
ProcCmdline: /usr/lib/unity-lens-music/unity-music-daemon
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: unity-lens-music
Title: unity-music-daemon crashed with SIGSEGV in dee_index_lookup()
UpgradeStatus: Upgraded to precise on 2011-12-22 (92 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare tty users

Related branches

Chris Giltnane (chris-giltnane) wrote :

StacktraceTop:
 find_term_real (terms=<optimized out>, term=0x898ac40 "vl", col_key=0x8a51db0 "YO\001\030\030\001\t\t", analyzer=0x8994768, flags=DEE_TERM_MATCH_PREFIX) at dee-tree-index.c:273
 dee_tree_index_lookup (self=0x898a080, term=0x898ac40 "vl", flags=DEE_TERM_MATCH_PREFIX) at dee-tree-index.c:428
 dee_index_lookup (self=0x898a080, term=0x898ac40 "vl", flags=DEE_TERM_MATCH_PREFIX) at dee-index.c:227
 unity_music_lens_rhythmbox_collection_search (self=0x8982120, search=0x8a39d18, search_type=UNITY_SEARCH_TYPE_GLOBAL, filters=0x0, max_results=20, category_override=3) at rhythmbox-collection.c:1483
 unity_music_lens_rhythmbox_scope_real_perform_search_co (_data_=0x8993300) at rhythmbox-scope.c:565

Changed in unity-lens-music (Ubuntu):
importance: Undecided → Medium
summary: - unity-music-daemon crashed with SIGSEGV in dee_index_lookup()
+ unity-music-daemon crashed with SIGSEGV in find_term_real()
tags: removed: need-i386-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-lens-music (Ubuntu):
status: New → Confirmed
William Grant (wgrant) on 2012-03-30
visibility: private → public
summary: - unity-music-daemon crashed with SIGSEGV in find_term_real()
+ unity-music-daemon crashed with SIGSEGV in find_term_real() from
+ dee_tree_index_lookup() from dee_index_lookup() from
+ unity_music_lens_rhythmbox_collection_search()
Changed in unity-lens-music:
status: New → Confirmed
Michal Hruby (mhr3) on 2012-03-30
Changed in dee:
assignee: nobody → Michal Hruby (mhr3)
milestone: none → 1.0.10
importance: Undecided → High
status: New → Triaged
Changed in unity:
assignee: nobody → Michal Hruby (mhr3)
milestone: none → 5.10.0
importance: Undecided → High
status: New → Triaged
Sarrvesh (sarrfriend) wrote :

Opened transmission-gtk for the first time after installing ubuntu 12.04 and this happened.

Michal Hruby (mhr3) on 2012-04-02
Changed in dee:
status: Triaged → In Progress
Changed in unity:
status: Triaged → In Progress
Changed in dee:
status: In Progress → Fix Committed
Michal Hruby (mhr3) on 2012-04-03
Changed in unity:
status: In Progress → Fix Committed
tags: added: bugpattern-needed
devtry (devtry) wrote :

It happened to me once while opening Skype beta 2.2 on Ubuntu 12.04 (up to date). I can't reproduce the bug now.

Michal Hruby (mhr3) on 2012-04-10
no longer affects: unity-lens-music
Didier Roche (didrocks) on 2012-04-12
Changed in dee:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity-lens-music:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package dee - 1.0.10-0ubuntu1

---------------
dee (1.0.10-0ubuntu1) precise; urgency=low

  * New upstream release.
    - unity-music-daemon crashed with SIGSEGV in find_term_real() from
      dee_tree_index_lookup() from dee_index_lookup() from
      unity_music_lens_rhythmbox_collection_search() (LP: #963991)
    - unity-applications-daemon crashed with SIGSEGV in
      g_variant_get_type_info() (LP: #938382)
    - unity-applications-daemon crashed with SIGSEGV in
      g_variant_type_info_check() (LP: #953978)
  * debian/control:
    - update Standards-Version to latest
 -- Didier Roche <email address hidden> Thu, 12 Apr 2012 11:33:08 +0200

Changed in dee (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-music - 5.10.0-0ubuntu1

---------------
unity-lens-music (5.10.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - unity-music-daemon crashed with SIGSEGV in find_term_real() from
      dee_tree_index_lookup() from dee_index_lookup() from
      unity_music_lens_rhythmbox_collection_search() (LP: #963991)
    - unity-music-daemon using a huge amount of ram (LP: #964684)
  * debian/control:
    - as there is no more banshee u1 music store, make unity-scope-musicstores
      dep on rhythmbox-ubuntuone (LP: #969271)
    - removing libxml2-dev build-dep
    - bump Standards-Version to latest
 -- Didier Roche <email address hidden> Thu, 12 Apr 2012 11:41:51 +0200

Changed in unity-lens-music (Ubuntu):
status: Confirmed → Fix Released
Will Cooke (willcooke) on 2015-09-16
Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers