Clicking song/album in music lens loads in Banshee but does not focus on play queue

Bug #834933 reported by Jono Bacon on 2011-08-26
44
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Banshee
Invalid
Undecided
Unassigned
Music Lens
Medium
Alex Launi
Unity
Invalid
Medium
Alex Launi
banshee (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned
unity-lens-music (Ubuntu)
Medium
Alex Launi
Oneiric
Medium
Alex Launi

Bug Description

If I click on a song or album in the Music Lens it successfully gets added to the Banshee filesystem play queue but the focus inside Banshee does not switch to the queue - thus it looks like I want to play it and I see no change in Banshee. If I add a second song or album, the content gets added also successfully but then the focus changes to the queue as it should.

To reproduce:

 * Click on a song or album in the Music Lens.
 * Look at Banshee - if you were not focused on the filesystem play queue you see no change other than the number being added to the play queue. Focus does not change to the play queue.
 * Add a second song or album and the focus does change.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity-lens-music 0.1.2-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-9.14-generic 3.0.3
Uname: Linux 3.0.0-9-generic i686
Architecture: i386
Date: Fri Aug 26 11:04:21 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110202)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: unity-lens-music
UpgradeStatus: Upgraded to oneiric on 2011-07-13 (43 days ago)

Jono Bacon (jonobacon) wrote :
Alex Launi (alexlauni) on 2011-09-02
Changed in unity-lens-music (Ubuntu):
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Alex Launi (alexlauni)
milestone: none → ubuntu-11.10-beta-2
Changed in banshee (Ubuntu):
status: New → Confirmed
tags: added: rls-mgr-o-tracking
Michael Terry (mterry) wrote :

This is reproducable without the lens. Just use "banshee --play FILE" on the command line to get the same behavior. Also for me, banshee didn't start playing music the first time. It did start playing music after the second run, but it played my main music library, not the queued songs.

On 16/09/2011 23:15, Michael Terry wrote:
> This is reproducable without the lens. Just use "banshee --play FILE"
> on the command line to get the same behavior. Also for me, banshee
> didn't start playing music the first time. It did start playing music
> after the second run, but it played my main music library, not the
> queued songs.
>

That's because it's --play-enqueued FILE, not --play FILE.

--
Kind regards,
Loong Jin

David Barth (dbarth) wrote :

Priority medium, it's a nice to have, but since there is a solution, it's worth putting on the weekly bug list. Thanks for the help debugging the problem.

Changed in unity:
assignee: nobody → Alex Launi (alexlauni)
importance: Undecided → Medium
status: New → Triaged
milestone: none → 4.18.0
Martin Pitt (pitti) wrote :

Closing banshee task, apparently the lens just needs to call it with --play-enqueue instead of --play then?

Changed in banshee (Ubuntu Oneiric):
status: Confirmed → Invalid
Changed in banshee:
status: New → Invalid
Changed in unity-lens-music (Ubuntu Oneiric):
status: Confirmed → Triaged
importance: High → Medium
milestone: ubuntu-11.10-beta-2 → ubuntu-11.10
Chow Loong Jin (hyperair) wrote :

On 20/09/2011 21:49, Martin Pitt wrote:
> Closing banshee task, apparently the lens just needs to call it with
> --play-enqueue instead of --play then?

--play-enqueued, but yes. Rather than hard-coding the option, how about using
the Exec field from the .desktop file?

--
Kind regards,
Loong Jin

Alex Launi (alexlauni) wrote :

d'oh. fix committed...

Alex Launi (alexlauni) on 2011-09-21
Changed in unity-lens-music:
status: New → Fix Committed
Changed in unity-lens-music (Ubuntu Oneiric):
status: Triaged → Fix Committed
Alex Launi (alexlauni) on 2011-09-21
Changed in unity-lens-music:
importance: Undecided → Medium
assignee: nobody → Alex Launi (alexlauni)
Changed in unity:
status: Triaged → Invalid
Alex Launi (alexlauni) on 2011-09-27
Changed in unity-lens-music:
milestone: none → 0.2.4
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-music - 0.2.4-0ubuntu1

---------------
unity-lens-music (0.2.4-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - Clicking song/album in music lens loads in Banshee but does not
      focus on play queue (LP: #834933)
    - [FFE] Add support for U1 in the music lens (LP: #851691)
  * debian/control:
    - makes u-l-m now recommends u-s-m as we want it by default now.
 -- Didier Roche <email address hidden> Tue, 27 Sep 2011 18:30:39 +0200

Changed in unity-lens-music (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers