Unity's files lens fails to mount bookmarked remote shares

Bug #760309 reported by Laurent Dinclaux on 2011-04-13
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Mikkel Kamstrup Erlandsen
unity-2d
Undecided
Unassigned
unity-lens-files
High
Mikkel Kamstrup Erlandsen
unity (Ubuntu)
Undecided
Unassigned
unity-lens-files (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: unity

On my corporate network, I work a lot with smb shared.

I open an smb share and add it to nautilus bookmarks. Then after a reboot or after unmounting that share, if I open the file lens and click on that share from the favorite folders list, nothing happens: the share doesn't get mounted, nautilus doesn't open up, no error is thrown.

Regards

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.8.6-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,reflex,compiztoolbox,decor,gnomecompat,snap,resize,mousepoll,dbus,move,vpswitch,thumbnail,grid,place,session,imgpng,regex,unitymtgrabhandles,wall,animation,expo,workarounds,ezoom,animationaddon,staticswitcher,fade,scale,unityshell]
Date: Thu Apr 14 09:20:47 2011
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
ProcEnviron:
 LANGUAGE=fr_FR:en
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: Upgraded to natty on 2011-04-03 (10 days ago)

Related branches

Laurent Dinclaux (dreadlox) wrote :
affects: unity → unity-place-files
affects: unity (Ubuntu) → unity-place-files (Ubuntu)
Alex Launi (alexlauni) on 2011-04-26
Changed in unity:
status: New → Confirmed
Changed in unity-place-files (Ubuntu):
status: New → Confirmed
Changed in unity-place-files:
status: New → Confirmed
importance: Undecided → Low
Changed in unity-place-files (Ubuntu):
importance: Undecided → Low
importance: Low → Wishlist
Alex Launi (alexlauni) on 2011-04-26
Changed in unity-place-files (Ubuntu):
importance: Wishlist → Low
Changed in unity:
importance: Undecided → Low
SteveDude (stevedude-) wrote :

Confirmed for me too. Opening the File & Folders Lens or through Dash > Find Files the Samba share is not launched.

Didier Roche (didrocks) on 2011-05-31
Changed in unity-2d:
status: New → Confirmed
summary: - Unity's files lens fails to mount bookmarked SMB share
+ Unity's files lens fails to mount bookmarked remote shares
Changed in unity-lens-files:
assignee: nobody → Mikkel Kamstrup Erlandsen (kamstrup)
importance: Low → High
milestone: none → 0.6.10
status: Confirmed → In Progress
Changed in unity:
assignee: nobody → Mikkel Kamstrup Erlandsen (kamstrup)
importance: Low → High
milestone: none → 4.20.0
status: Confirmed → In Progress

The attached branch fixes this. I tested this with FTP and SSH shares. FTP works well, but it seems that SSH mounts doesn't play nicely except for the very first (auto) mount. If you eject an SSH mount it's having trouble auto-remounting. This may only be for me though, because ~mhr3 reports it working reliably for him.

Michal Hruby (mhr3) on 2011-09-29
Changed in unity:
status: In Progress → Fix Committed
Changed in unity-lens-files:
status: In Progress → Fix Committed
Changed in unity-2d:
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2011-09-29
affects: unity-place-files (Ubuntu) → unity-lens-files (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-files - 0.6.10-0ubuntu1

---------------
unity-lens-files (0.6.10-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - Unity's files lens fails to mount bookmarked remote shares (LP: #760309)
    - gedit fails to start on first try, but does on the second (LP: #827414)
    - Files lens should also search Downloads (LP: #748915)
    - Dash opens browser when selecting a FTP-bookmark (LP: #862112)
 -- Didier Roche <email address hidden> Thu, 29 Sep 2011 15:49:50 +0200

Changed in unity-lens-files (Ubuntu):
status: Confirmed → Fix Released
Michal Hruby (mhr3) on 2011-09-29
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity-2d:
status: Fix Committed → Fix Released
Changed in unity-lens-files:
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers