Regression: Installed apps not sorted alphabetically

Bug #964325 reported by peterzay on 2012-03-25
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Michal Hruby
unity-lens-applications
High
Michal Hruby
unity (Ubuntu)
Undecided
Unassigned
unity-lens-applications (Ubuntu)
Undecided
Unassigned

Bug Description

The list of installed apps is no longer in ascending sort order. They now appear to be random.

This makes viewing very difficult.

Searching is an option, but only if you know the name of the desired app.

Bring back the sort order for personal productivity.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.8.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-20.32-generic-pae 3.2.12
Uname: Linux 3.2.0-20-generic-pae i686
.tmp.unity.support.test.1:

ApportVersion: 1.95-0ubuntu1
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
Date: Sun Mar 25 00:20:27 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
DkmsStatus: virtualbox, 4.1.10, 3.2.0-20-generic-pae, i686: installed
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120324)
MachineType: HP Pavilion 061 D7222P-ABA M400Y
ProcEnviron:
 TERM=xterm
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-20-generic-pae root=UUID=0523c829-0e79-44ce-b046-a890ba40ce57 ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 04/14/2004
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 3.24
dmi.board.name: 'P4SD-LA'
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr3.24:bd04/14/2004:svnHPPavilion061:pnD7222P-ABAM400Y:pvr0qq1112RE101OXFOR10:rvnASUSTeKComputerINC.:rn'P4SD-LA':rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: D7222P-ABA M400Y
dmi.product.version: 0qq1112RE101OXFOR10
dmi.sys.vendor: HP Pavilion 061
version.compiz: compiz 1:0.9.7.2-0ubuntu1
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Related branches

peterzay (peterzay) wrote :
Omer Akram (om26er) wrote :

those are recently used apps. so the last used app is the one you see first.

Changed in unity (Ubuntu):
status: New → Opinion
peterzay (peterzay) wrote :

No, the installed apps are just below the recently used apps.

The installed apps are in random order. They should be in sort order.

Changed in unity (Ubuntu):
status: Opinion → New
Changed in unity:
status: New → Confirmed
Changed in unity-lens-applications:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
assignee: nobody → Michal Hruby (mhr3)
Changed in unity-lens-applications:
assignee: nobody → Michal Hruby (mhr3)
Michal Hruby (mhr3) on 2012-03-26
Changed in unity-lens-applications:
milestone: none → 5.10.0
Changed in unity:
milestone: none → 5.10.0
importance: Undecided → High
Changed in unity-lens-applications:
importance: Undecided → High
Michal Hruby (mhr3) wrote :

Looks like we're using the popularity sort even for empty searches which shouldn't be the case.

peterzay (peterzay) wrote :

The first icon in the installed apps list is OB Onboard. I have never clicked on this icon.

Here is the list of icons on the first row of the installed apps section:
- OB Onboard
- UXTerm
- xdiagnose
- XTerm
- Terminal
- Home Folder

The only ones I have ever clicked on since system installation are Terminal and Home Folder. I am not sure how this relates to popularity.

Hope this detail has been helpful to you and the team.

Michal Hruby (mhr3) on 2012-03-27
Changed in unity:
status: Confirmed → In Progress
Changed in unity-lens-applications:
status: Confirmed → In Progress
summary: - Dash home installed apps no longer in sort order
+ Regression: Installed apps not sorted alphabetically
Changed in unity-lens-applications:
status: In Progress → Fix Committed
Omer Akram (om26er) on 2012-03-27
Changed in unity:
status: In Progress → Fix Committed
affects: unity (Ubuntu) → unity-lens-applications (Ubuntu)
Changed in unity-lens-applications (Ubuntu):
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2012-04-12
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity-lens-applications:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-applications - 5.10.0-0ubuntu1

---------------
unity-lens-applications (5.10.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - Regression: Installed apps not sorted alphabetically (LP: #964325)
    - unity-applications-daemon crashed with SIGSEGV in
      g_variant_get_type_info() (LP: #938382)
    - Apps rank too high with exact matches in Keywords (LP: #960269)
  * debian/control:
    - bump Standards-Version to latest
 -- Didier Roche <email address hidden> Thu, 12 Apr 2012 11:48:26 +0200

Changed in unity-lens-applications (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers