Unity Applications lens crashed upon opening: unity-applications-daemon crashed with SIGSEGV in dee_model_remove()

Bug #940401 reported by Christopher D'Arcy on 2012-02-24
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
unity-lens-applications (Ubuntu)
Undecided
Unassigned

Bug Description

Upon opening the applications lens for the first time, the lens showed nothing, and crashed. Additionally, when searching for an application to launch in the unity menu, the applications come up, but you can't launch them by clicking on them or by selecting them and pressing Enter. Dragging them to the launcher makes them able to launch, though. This system is in a Oracle Virtualbox Virtual Machine. The other lenses were unaffected.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: unity-lens-applications 5.4.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-17.26-generic 3.2.6
Uname: Linux 3.2.0-17-generic i686
ApportVersion: 1.93-0ubuntu2
Architecture: i386
CrashCounter: 1
Date: Fri Feb 24 10:48:07 2012
EcryptfsInUse: Yes
ExecutablePath: /usr/lib/unity-lens-applications/unity-applications-daemon
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
ProcCmdline: /usr/lib/unity-lens-applications/unity-applications-daemon
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANGUAGE=en_CA:en
 LANG=en_CA.UTF-8
SegvAnalysis:
 Segfault happened at: 0xc5a978: mov (%edi,%esi,4),%eax
 PC (0x00c5a978) ok
 source "(%edi,%esi,4)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: unity-lens-applications
StacktraceTop:
 ?? () from /usr/lib/libdee-1.0.so.4
 ?? () from /usr/lib/libdee-1.0.so.4
 dee_model_remove () from /usr/lib/libdee-1.0.so.4
 ?? () from /usr/lib/libdee-1.0.so.4
 dee_model_remove () from /usr/lib/libdee-1.0.so.4
Title: unity-applications-daemon crashed with SIGSEGV in dee_model_remove()
UpgradeStatus: Upgraded to precise on 2012-02-21 (2 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Christopher D'Arcy (chrisd322) wrote :

Thank you for taking the time to report this crash and helping to make this software better. This particular crash has already been reported and is a duplicate of bug #939383, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

visibility: private → public
visibility: private → public
tags: removed: need-i386-retrace
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers