Can't launch applications from the launcher

Bug #938505 reported by Fabien Cortina on 2012-02-22
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Michal Hruby
unity-lens-applications
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned
unity-lens-applications (Ubuntu)
Undecided
Unassigned

Bug Description

After upgrading today I could not launch applications any more.
If I open the launcher after opening my session, I can click on an application and launch it.

But if I type something and try to launch an application by hitting ENTER or by clicking on one of the results it does not work anymore (same behavior as #934476?). After a few seconds I get the same error message as #930499.

After this bug occurs, the Application lens is always empty (the home lens looks fine, but I still can't launch applications).

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: unity-lens-applications 5.4.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-17.26-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
ApportVersion: 1.92-0ubuntu1
Architecture: amd64
CrashCounter: 1
Date: Wed Feb 22 17:58:59 2012
ExecutablePath: /usr/lib/unity-lens-applications/unity-applications-daemon
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120212)
ProcCmdline: /usr/lib/unity-lens-applications/unity-applications-daemon
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
SegvAnalysis:
 Segfault happened at: 0x7ff60c22733b: mov (%rdx),%eax
 PC (0x7ff60c22733b) ok
 source "(%rdx)" (0x00000001) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: unity-lens-applications
StacktraceTop:
 ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /usr/lib/libdee-1.0.so.4
 g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_emit_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: unity-applications-daemon crashed with SIGSEGV in g_closure_invoke()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

Fabien Cortina (fabien.cortina) wrote :
description: updated
description: updated

Thank you for taking the time to report this crash and helping to make this software better. This particular crash has already been reported and is a duplicate of bug #917194, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

visibility: private → public
visibility: private → public
tags: removed: need-amd64-retrace
Michal Hruby (mhr3) wrote :

Unmarking as duplicate, the issue where activating a result doesn't launch it is an issue that was introduced in 5.4 (the crash preceding this is a duplicate of #917194 though.)

Changed in unity:
status: New → Fix Committed
importance: Undecided → High
assignee: nobody → Michal Hruby (mhr3)
milestone: none → 5.6.0
Fabien Cortina (fabien.cortina) wrote :

Looking at the new recent comments on #930499 it really looks like my report should be marked as a duplicate of this one.
I could not reproduce this issue after yesterday's updates thought.

Didier Roche (didrocks) on 2012-03-12
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity-lens-applications:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-applications - 5.6.0-0ubuntu1

---------------
unity-lens-applications (5.6.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - unity-applications-daemon crashed with SIGSEGV in
      dee_sequence_model_free_row() (LP: #916356)
    - Can't launch applications from the launcher (LP: #938505)
    - Unity Dash should support Keywords parameter in .desktop (formerly X
      -GNOME-Keywords or X-AppInstall-Keywords) (LP: #941231)
    - Dash - Currently the app lens doesn't show applications that are
      available for purchase (LP: #916121)
    - non-existent icons are referenced: category-available and category-
      installed (LP: #932212)
 -- Didier Roche <email address hidden> Mon, 12 Mar 2012 11:52:14 +0100

Changed in unity-lens-applications (Ubuntu):
status: New → Fix Released
Will Cooke (willcooke) on 2015-09-16
Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers