unity-applications-daemon crashed with SIGSEGV in g_variant_unref()

Bug #936287 reported by alex82361 on 2012-02-19
92
This bug affects 21 people
Affects Status Importance Assigned to Milestone
unity-lens-applications (Ubuntu)
Medium
Unassigned

Bug Description

it wouldnt let me click on the update this morning when i clicked on it

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: unity-lens-applications 5.4.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-16.25-generic 3.2.6
Uname: Linux 3.2.0-16-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
Date: Sun Feb 19 10:20:39 2012
ExecutablePath: /usr/lib/unity-lens-applications/unity-applications-daemon
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120203)
ProcCmdline: /usr/lib/unity-lens-applications/unity-applications-daemon
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
SegvAnalysis:
 Segfault happened at: 0x7f04eed7297d <g_variant_unref+13>: mov 0x24(%rdi),%eax
 PC (0x7f04eed7297d) ok
 source "0x24(%rdi)" (0x00000044) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: unity-lens-applications
StacktraceTop:
 g_variant_unref () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /usr/lib/libdee-1.0.so.4
 ?? () from /usr/lib/libdee-1.0.so.4
 ?? () from /usr/lib/libunity.so.9
 g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: unity-applications-daemon crashed with SIGSEGV in g_variant_unref()
UpgradeStatus: Upgraded to precise on 2012-02-15 (3 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

alex82361 (alex-smith823) wrote :

StacktraceTop:
 g_variant_unref (value=0x20) at /build/buildd/glib2.0-2.31.16/./glib/gvariant-core.c:622
 dee_sequence_model_free_row (self=<optimized out>, iter=0x143b390) at dee-sequence-model.c:981
 dee_sequence_model_remove (self=0x15bdd80, iter_=0x143b390) at dee-sequence-model.c:482
 unity_results_synchronizer_on_row_removed (iter=0x7f04d4004560, provider=0x14552b0, self=0x15cb320) at unity-lens-tools.c:1228
 _unity_results_synchronizer_on_row_removed_dee_model_row_removed (_sender=<optimized out>, iter=0x7f04d4004560, self=0x15cb320) at unity-lens-tools.c:963

Changed in unity-lens-applications (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-lens-applications (Ubuntu):
status: New → Confirmed
Franco Bombi (franco.bombi) wrote :

test installation on a VirtualBox 4.1.2 (Ubuntu 11.10 Host)

PC just logged itself out and presented the greeter.
After logging in I could no longer start programs from the application lens. Searching worked.

Restarting the PC solved the problem.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers