unity-applications-daemon crashed with SIGSEGV in node_get_pos()

Bug #917194 reported by Gerry Boland on 2012-01-16
584
This bug affects 78 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Unassigned
Unity Distro Priority
Critical
Unassigned
unity-lens-applications
Critical
Michal Hruby
unity (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
unity-lens-applications (Ubuntu)
Critical
Canonical Desktop Experience Team
Precise
Critical
Canonical Desktop Experience Team

Bug Description

Bootup, just after updating my Precise install, running Unity 2D

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: unity-lens-applications 5.0.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-9.16-generic 3.2.1
Uname: Linux 3.2.0-9-generic x86_64
ApportVersion: 1.90-0ubuntu2
Architecture: amd64
CrashCounter: 1
Date: Mon Jan 16 15:38:21 2012
ExecutablePath: /usr/lib/unity-lens-applications/unity-applications-daemon
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64+mac (20120103)
ProcCmdline: /usr/lib/unity-lens-applications/unity-applications-daemon
SegvAnalysis:
 Segfault happened at: 0x7f8a31d46c2b: mov (%rdx),%eax
 PC (0x7f8a31d46c2b) ok
 source "(%rdx)" (0xaaaaaaaaaaaaaaaa) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: unity-lens-applications
StacktraceTop:
 ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /usr/lib/libdee-1.0.so.4
 g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_emit_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: unity-applications-daemon crashed with SIGSEGV in g_closure_invoke()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Gerry Boland (gerboland) wrote :

StacktraceTop:
 node_get_pos (node=0x7f8a20028a70) at /build/buildd/glib2.0-2.31.8/./glib/gsequence.c:1639
 on_self_row_removed (iter=0x7f8a20028a70, self=0xa02d00) at dee-shared-model.c:1374
 on_self_row_removed (self=0xa02d00, iter=0x7f8a20028a70) at dee-shared-model.c:1365
 g_closure_invoke (closure=0x7f8a20009170, return_value=0x0, n_param_values=2, param_values=0x7f8a2002da10, invocation_hint=<optimized out>) at /build/buildd/glib2.0-2.31.8/./gobject/gclosure.c:774
 signal_emit_unlocked_R (node=<optimized out>, detail=0, instance=<optimized out>, emission_return=0x0, instance_and_params=0x7f8a2002da10) at /build/buildd/glib2.0-2.31.8/./gobject/gsignal.c:3302

Changed in unity-lens-applications (Ubuntu):
importance: Undecided → Medium
summary: - unity-applications-daemon crashed with SIGSEGV in g_closure_invoke()
+ unity-applications-daemon crashed with SIGSEGV in node_get_pos()
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-lens-applications (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2012-02-01
Changed in unity:
status: New → Confirmed
Changed in unity-lens-applications:
status: New → Confirmed
Changed in unity-lens-applications (Ubuntu):
importance: Medium → Critical
tags: added: bugpattern-needed
visibility: private → public
Changed in unity-lens-applications (Ubuntu Precise):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
tags: added: rls-mgr-p-tracking
Didier Roche (didrocks) on 2012-02-20
Changed in unity-distro-priority:
status: New → Fix Committed
importance: Undecided → Critical
Changed in unity (Ubuntu):
status: New → Confirmed
Tim Penhey (thumper) on 2012-02-29
Changed in unity-lens-applications:
importance: Undecided → Critical
Changed in unity:
importance: Undecided → High
Tim Penhey (thumper) wrote :

We think this is the same as bug 916356, and so should have been fixed with the 5.6 release.

Changed in unity-lens-applications:
assignee: nobody → Michal Hruby (mhr3)
status: Confirmed → Fix Released
Changed in unity:
milestone: none → 5.6.0
status: Confirmed → Fix Released
Changed in unity (Ubuntu Precise):
status: Confirmed → Fix Released
Changed in unity-lens-applications (Ubuntu Precise):
status: Confirmed → Fix Released
Changed in unity-distro-priority:
status: Fix Committed → Fix Released
tags: added: rls-p-tracking
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers