when selecting an application, dash should match words in the middle of name

Bug #869888 reported by Romano Giannetti
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Fix Committed
Low
John Lea
Unity
Confirmed
Low
Unassigned
unity-lens-applications
Confirmed
Low
Mikkel Kamstrup Erlandsen
unity-lens-files
Confirmed
Low
Unassigned
unity (Ubuntu)
Confirmed
Low
Unassigned
unity-lens-applications (Ubuntu)
Confirmed
Low
Unassigned
unity-lens-files (Ubuntu)
Confirmed
Low
Unassigned

Bug Description

This could be seen as a wishlist, but in my opinion the current behavior is unexpected.

When using dash and starting writing the name of the application/file, I expected the match being done with *all* the name of the application, not just the *start*. I mean, if I type "dict", I expect to see both "Dictionary" and "StarDict". I notices this several time; you often remember part of the name of the application and sometime it is not the start of it.

Revision history for this message
Mikkel Kamstrup Erlandsen (kamstrup) wrote : Re: [Bug 869888] [NEW] when selecting an application, dash should match words in the middle of name

I really don't like full substring matching. I think it would be a
good idea to tokenize words with CamelCase, so StarDict becomes "star"
and "dict" (and still also matching "stardict" of course).

Technical note: This is currently not trivial to add though. The
proper solution requires patching to libxapian (which we use for
indexing apps) as manual working around it would break stuff like CJK.
The patch would add a "split on camel case" flag to
Xapian::TermGenerator.

John Lea (johnlea)
tags: added: onew udo
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Low
status: New → Fix Committed
Changed in unity:
status: New → Confirmed
Changed in unity-lens-applications:
status: New → Confirmed
Changed in unity-lens-files:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
status: Confirmed → Invalid
affects: unity (Ubuntu) → unity-lens-applications (Ubuntu)
John Lea (johnlea)
tags: added: udp
Changed in unity:
milestone: none → backlog
Changed in ayatana-design:
status: Fix Committed → Triaged
Revision history for this message
Marco Trevisan (Treviño) (3v1n0) wrote :

That's fine for the CamelCase names, but it's not enough to me.

Another possible solution to make this lens to be more powerful would be to add some fallback search methods, to make the lens to try to always give out results when possible.

I mean, if I write a string and I get back less than DELTA results, then try to fetch some more using the substring matching... If Either the substring matching gives out less values than DELTA, then we could also use a regex matching using the Gnome-DO / Synapse style.

So we always give priority to the standard search method, but if that's not enough to us we try to find something that could match to the user input.

Revision history for this message
Romano Giannetti (romano-giannetti) wrote :

Hmmm... I think I really like Marco proposal. Although (if I understand correctly the tech-speach) the CamelCase names could be sufficient.
Thanks!

(I

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-lens-files (Ubuntu):
status: New → Confirmed
Changed in unity:
status: Invalid → Confirmed
Mirco Müller (macslow)
Changed in unity-lens-applications:
assignee: nobody → Mikkel Kamstrup Erlandsen (kamstrup)
John Lea (johnlea)
Changed in ayatana-design:
status: Triaged → Fix Committed
tags: added: text-analysis
Revision history for this message
Mikkel Kamstrup Erlandsen (kamstrup) wrote :

As a note - I hacked together a "playground" we can use more easily to play around with different matching semantics in lp:unity-lens-bliss. See also http://www.grillbar.org/wordpress/?p=568

Changed in unity:
importance: Undecided → Low
Changed in unity-lens-files:
importance: Undecided → Low
Changed in unity (Ubuntu):
importance: Undecided → Low
Changed in unity-lens-applications (Ubuntu):
importance: Undecided → Wishlist
Changed in unity-lens-files (Ubuntu):
importance: Undecided → Low
Changed in unity-lens-applications (Ubuntu):
importance: Wishlist → Low
Changed in unity-lens-applications:
importance: Undecided → Low
Changed in unity (Ubuntu):
status: New → Confirmed
Revision history for this message
Sebastien Bacher (seb128) wrote :

is that a duplicate of bug #752259?

Revision history for this message
Marius B. Kotsbak (mariusko) wrote :

Yes.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Related blueprints