Eclipse sub menu are uncomplete with 16.04 xerius beta 1 (wily werewolf got such a problem )

Bug #1501340 reported by MV on 2015-09-30
54
This bug affects 11 people
Affects Status Importance Assigned to Milestone
eclipse (Ubuntu)
Undecided
Unassigned
unity-gtk-module (Ubuntu)
Undecided
Unassigned

Bug Description

Eclipse Mars on future ubuntu 15.10 Wily Werewolf

This bug seems to be an echo from old and painful :

https://bugs.launchpad.net/ubuntu/+source/unity-gtk-module/+bug/1208019

Eclipse submenus are mainly empty.

The old solution :

env UBUNTU_MENUPROXY=0 ./eclipse

solve the problem

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-gtk-module (Ubuntu):
status: New → Confirmed
William Hua (attente) wrote :

Sorry, but I'm on Wily and can't reproduce this with Eclipse Mars R (Java Enterprise Edition 64-bit). Are you using a different version? What menus are you talking about specifically?

Changed in unity-gtk-module (Ubuntu):
status: Confirmed → Incomplete
William Hua (attente) wrote :

The version I'm using is Mars Release 4.5.0, build ID is 20150621-1200.

MV (mvidal) wrote :

Same version than you 64bits

Build id: 20150621-1200

Your right this is not obvious at all.

Comparing with the working UBUNTY_MENUPROXY=0 instance, you can see that some sub-menu filled dynamically are all with their minimal menu list (static items I guess) almost empty

For instance menu "File/New" should contain 18 menus items above "others". If you select "others" nothing appear except, maybe, a crash

menu "window/view" more than 15 menu choices and nothing appear when you select others.

MV (mvidal) wrote :

Update Wily this morning.

This bug is gone.

submenus are ok.

HUD works perfectly.

I don't have a clue about which package solved this problem.

Retsamknaps (retsamknaps) wrote :

I have a problem where my JFace TreeViwer is messed up on Ubuntu 15.10. When the tree is expanded all the text for all the nodes including the root changes and they all say the same thing. Collapsing and expanding has no effect. This problem does not show up on ubuntu 14.04, or other operating systems.

MV (mvidal) wrote :

Does the UBUNTY_MENUPROXY=0 solve your problem ?

The bug here is (was) about menu and HUD system on unity.

MV (mvidal) wrote :

Something else to check about eclipse (if you update to Mars.1) is that with Mars and Mars.1, GTK3 is now the default SWT library. Try export SWT_GTK3=0 before launching your eclipse or RCP program to test with GTK2.

Retsamknaps (retsamknaps) wrote :

export SWT_GTK3=0 seems to fix it! Thank you!

Launchpad Janitor (janitor) wrote :

[Expired for unity-gtk-module (Ubuntu) because there has been no activity for 60 days.]

Changed in unity-gtk-module (Ubuntu):
status: Incomplete → Expired
MV (mvidal) wrote :

Not exactly the same problem but with Xenial xerus beta 1 (64) and eclipse MARS 1 and 2 working with the default GTK3 librairies: Many submenus are grayed the first time we unfold them :

File > New --> all the sub menus are grayed the first time then ok the second time
Window -> show views --> idem and some time only one item is shown

some dynamically fullfiled main menus can be empty or also grayed ( i.e. the Refactor menu for an XTEND file)

they are some flickerings when these menus are unfolded.

The problem is solved (now) working with GTK2 libraries (export SWT_GTK3=0 ; ./eclipse)

Changed in unity-gtk-module (Ubuntu):
status: Expired → New
MV (mvidal) on 2016-02-29
summary: - Eclipse sub menu are uncomplete with 15.10 wily
+ Eclipse sub menu are uncomplete with 16.04 xerius beta 1 (wily werewolf
+ got such a problem )
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-gtk-module (Ubuntu):
status: New → Confirmed
Ben M. (bmhm) wrote :

This problem has only a heat of 18. As Ubuntu 16.04 will roll out, this issue will have much more attention. I'd suggest, there should be a fix before the release. "Eclipse not working" is a blocker imho.

Confirmed:
Works by using this start command:
`env SWT_GTK3=0 UBUNTU_MENUPROXY=0 ./eclipse`

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in eclipse (Ubuntu):
status: New → Confirmed

Problem affects Ubuntu 16.04 for me: tested right now.
As @bmhm said, launching application using 'env SWT_GTK3=0 UBUNTU_MENUPROXY=0 /path/to/eclipse' worked.

Brett Sutton (bsutton) wrote :

I can confirm the same problem on 16.04 and the evn SWT_GTK3=0 also solved the problem for me.

Brett Sutton (bsutton) wrote :

I perhaps should say that I'm running gnome-ubuntu so unity isn't involved.

Clay Ferguson (wclayf) wrote :

I can also confirm this works:

env SWT_GTK3=0 UBUNTU_MENUPROXY=0 ./eclipse

I am running Eclipse MARS.2 and the menu wasn't showing anything at all, or responding to any clicks.

I had also put these two lines in my eclipse.ini

--launcher.GTK_version
2

but those two were for some different problem. Just throwing it in here, because others are likely to need it too.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers