Adding indicator-applet appmenu does not export/move all menu items to panel (Utopic)

Bug #1383382 reported by Khurshid Alam on 2014-10-20
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
unity-gtk-module (Ubuntu)
High
Dmitry Shachnev

Bug Description

Current Scenario

1. install indicator-applet-appmenu
2. add it to panel.

3. In the panel, For some gtk apps (gnome-terminal) It is showing only a single menu; File->close. All other menu items remains in the app. For some other gtk apps (i.e. Nautilus, eog) it doesn't show any menu at all.

4. Surprisingly for Firefox it does properly move all the menus to panel.

Expected Scenario:

Adding indicator-applet-appmenu or global menu should move all the menu items from local app to panel.

Gnome-Panel version on Utopic: 1:3.8.1-2ubuntu4
unity-gtk-module: 0.0.0+14.10.20140716-0ubuntu1
gtk3+: 3.12.2-0ubuntu14
indicator-applet: 12.10.2+14.04.20140403-0ubuntu1
indicator-appmenu: 13.01.0+14.04.20140404-0ubuntu1

Related branches

summary: Adding indicator-applet appmenu does not export all menu items to panel
+ (Utopic)
description: updated

Which application(s) did you test it with? Please make sure that you have these packages installed:

unity-gtk3-module (for Gtk+ 3 apps)
unity-gtk2-module (for Gtk+ 2 apps)
appmenu-qt (for Qt 4 apps)

Changed in gnome-panel (Ubuntu):
status: New → Incomplete
summary: - Adding indicator-applet appmenu does not export all menu items to panel
- (Utopic)
+ Adding indicator-applet appmenu does not export/move all menu items to
+ panel (Utopic)
description: updated
Khurshid Alam (khurshid-alam) wrote :

@Dmitry

I tested with mainly gtk3 apps (gnome-terminal, nautilus, eog..etc). For gnome-terminal the panel only have File->Close (Screenshot: http://i.imgur.com/cIcoSMW.png). For nautilus, it does NOT move any menu item to panel at all.

However for Firefox it is working alright.

And yes, I have unity-gtk2/3-module packages installed (updated in the bug description).

description: updated
description: updated
description: updated
tags: added: utopic
Dmitry Shachnev (mitya57) wrote :

Can you please also check that you have indicator-appmenu installed? (It is not the same as indicator-applet-appmenu).

Also, please paste output of this command somewhere:

gdbus introspect -e -d com.canonical.AppMenu.Registrar -o /com/canonical/AppMenu/Registrar

affects: gnome-panel (Ubuntu) → indicator-appmenu (Ubuntu)
Khurshid Alam (khurshid-alam) wrote :

Of-course indicator-appmenu is installed. Everything works fine in Unity. I have updated bug description.

I have also noticed that those gtk apps which are not directly patched by Ubuntu (to restore traditional horizontal menus) & uses a single all-in-one vertical menu, are working fine. For example, Geary or Claifornia. For those apps indicator-applet-appmenu shows a single vertical menu in the panel. screenshot: http://imgur.com/gMSAwCe

And here is the output of "gdbus introspect -e -d com.canonical.AppMenu.Registrar -o /com/canonical/AppMenu/Registrar"

node /com/canonical/AppMenu/Registrar {
  interface org.freedesktop.DBus.Properties {
    methods:
      Get(in s interface_name,
          in s property_name,
          out v value);
      GetAll(in s interface_name,
             out a{sv} properties);
      Set(in s interface_name,
          in s property_name,
          in v value);
    signals:
      PropertiesChanged(s interface_name,
                        a{sv} changed_properties,
                        as invalidated_properties);
    properties:
  };
  interface org.freedesktop.DBus.Introspectable {
    methods:
      Introspect(out s xml_data);
    signals:
    properties:
  };
  interface org.freedesktop.DBus.Peer {
    methods:
      Ping();
      GetMachineId(out s machine_uuid);
    signals:
    properties:
  };
  interface com.canonical.AppMenu.Registrar {
    methods:
      @org.freedesktop.DBus.GLib.Async("true")
      RegisterWindow(in u windowId,
                     in o menuObjectPath);
      UnregisterWindow(in u windowId);
      GetMenuForWindow(in u windowId,
                       out s service,
                       out o menuObjectPath);
      @com.trolltech.QtDBus.QtTypeName.Out0("MenuInfoList")
      GetMenus(out a(uso) menus);
    signals:
      WindowRegistered(u windowId,
                       s service,
                       o menuObjectPath);
      WindowUnregistered(u windowId);
    properties:
  };
};

description: updated
Khurshid Alam (khurshid-alam) wrote :

Upon deeper investigation I noticed that some default apps works & some doesn't. Here is the result so far:

Apps that does NOT move menubar to panel:

1. nautilus

2. gnome-terminal (only shows file>close)

3. gedit

4. file-roller (complete mess: export header-bar menus but also shows menus on the window & a single dropdown menu screenshot: http://i.imgur.com/XDVD9Ei.png)

5. eog

6. totem

7. mines ( a very big size menu remains on the window screenshot: http://i.imgur.com/ZD0xma0.png )

8. shotwell

9. transmission

Apps that does move menubar properly to the panel

1. evince
2. rhythmbox
3. disks
4. system-monitor
5. system-log (uses headerbar)

Khurshid Alam (khurshid-alam) wrote :

Since file-roller incident is also visible in Unity, I have also commented at bug: #1131664

Dmitry Shachnev (mitya57) wrote :

Thanks for investigation! Does all that happen in Unity as well, or are there differences in appearance between Unity and gnome-panel?

Khurshid Alam (khurshid-alam) wrote :

@Dmitry

Yes, for file-roller app (archive manager) the issue is something similar for both Unity & Flashback

On Unity:

1. Global menubar shows traditional horizontal menubar
2. it also export some portion of gtk header-bar menu along with traditional menubar
3. Some other portion of gtk header-bar menu remains on the application window ( single drop-down menu)which are also in traditional menubar (screenshot: http://i.imgur.com/SKFM9Ya.png)

On Gnome-Flashback (with global menu):
1. No traditional menubar
2. export same portion of gtk header-bar menu as in Unity
3. Same other portion of gtk header-bar menu remains on the application window as in Unity. (screenshot: http://i.imgur.com/XDVD9Ei.png)

Khurshid Alam (khurshid-alam) wrote :

As commented on the mailing list, resetting compiz (dconf reset /org/compiz) & then logging into metacity does solve the problem. But it reappears when I log back in compiz session. Running "compiz -replace" inside metacity session also works-> It brings back all compiz effect & doesn't affect indicator-applet-appmenu.

I think Unity's compiz plugin in someway interfering with flashback-compiz session ( compiz has tons of bugs on Utopic).

Dmitry Shachnev (mitya57) wrote :

This happened because /usr/share/upstart/sessions/unity-gtk-module.conf did not start in Compiz session, which was not whitelisted in Upstart. I have now prepared a merge proposal to fix this.

Changed in indicator-appmenu (Ubuntu):
status: Incomplete → Fix Released
Dmitry Shachnev (mitya57) wrote :

This needs a fix in unity-gtk-module as well.

affects: indicator-appmenu (Ubuntu) → unity-gtk-module (Ubuntu)
Changed in unity-gtk-module (Ubuntu):
assignee: nobody → Dmitry Shachnev (mitya57)
status: Fix Released → In Progress
Changed in unity-gtk-module (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-gtk-module - 0.0.0+15.04.20150118-0ubuntu1

---------------
unity-gtk-module (0.0.0+15.04.20150118-0ubuntu1) vivid; urgency=low

  [ Dmitry Shachnev ]
  * Support multiple desktop names in $XDG_CURRENT_DESKTOP. (LP:
    #1383382)
 -- Ubuntu daily release <email address hidden> Sun, 18 Jan 2015 09:59:10 +0000

Changed in unity-gtk-module (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers