Eclipse menus don't show up in Trusty

Bug #1208019 reported by Hans Joachim Desserud on 2013-08-03
This bug affects 291 people
Affects Status Importance Assigned to Milestone
Eclipse
Unknown
Critical
GTK+
Fix Released
Medium
Unity GTK+ module
Fix Released
Undecided
William Hua
gtk+3.0 (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
William Hua
unity-gtk-module (Ubuntu)
Critical
William Hua
Trusty
Undecided
William Hua

Bug Description

[Impact]

Switching tabs between open source files with different file types in Eclipse causes the Source and Refactor menus to be empty in the global menu bar under Unity.

This is a severe usability problem for many Eclipse users. The fix proposed has been available in a PPA and is well-tested.

[Test Case]

1. Open a new project in Eclipse.
2. Open two files: one with a .java extension, another with a .txt extension.
3. Switch between the .java file and the .txt file and back again.
4. Open the Source or Refactor menu in the Unity global menu bar.

Expected result: menus with menu items
Actual result: empty menus for both

[Regression Potential]

The fix involves changes to both gtk and unity-gtk-module.

The changes to gtk are minimal and only involve the reversal of a pair of signal emissions, in a part of the code (GtkMenuTracker) which is normally used by desktop environments, not typical user applications. Therefore regression potential for the gtk update is unlikely.

The changes to unity-gtk-module involve emitting show and hide signals where they were none before has some regression potential for applications that are explicitly watching for when their menus are opening and closing. But this is rare for applications to do, and we likely would have already received bug reports for those that do. Being completely sure would require extensive testing across all gtk apps though.

Both changes together have been available as a PPA, thoroughly tested for quite some time now.

[Other Info]

The changes to unity-gtk-module depend on the changes to gtk, so both must be tested in simultaneity. Suggested to upload both to trusty-proposed at the same time.

Original bug report follows:

=== %< ===

****************
HOW TO REPRODUCE
****************

1. Run Eclipse, Gimp or Inkscape.
2. Move the cursor to the top of the screen.
3. Click on any of the menu items (File, Edit, Navigate, ...)

******************
EXPECTED BEHAVIOUR
******************

- The content of the submenus show up.

**************
REAL BEHAVIOUR
**************

- Only the top-level headers are available.
- Nothing happens when clicking on them
- They don't show up in the HUD either.

***********
WORK-AROUND
***********

To modify "/usr/share/applications/eclipse.desktop" to look like this:

[Desktop Entry]
Type=Application
Name=Eclipse
Comment=Eclipse Integrated Development Environment
Icon=eclipse
Exec=env UBUNTU_MENUPROXY= eclipse
Terminal=false
Categories=Development;IDE;Java;

****************
RELEVANT DETAILS
****************

- Doesn't affect Ubuntu releases prior to 13.10.

**************
TECHNICAL INFO
**************

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: eclipse 3.8.1-1ubuntu1
ProcVersionSignature: Ubuntu 3.10.0-6.17-generic 3.10.3
Uname: Linux 3.10.0-6-generic i686
ApportVersion: 2.11-0ubuntu1
Architecture: i386
Date: Sat Aug 3 17:03:55 2013
InstallationDate: Installed on 2013-07-08 (25 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha i386 (20130708)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: eclipse
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Hans Joachim Desserud (hjd) wrote :
Hans Joachim Desserud (hjd) wrote :

I can only reproduce this issue in Unity, so that might be the cause somehow. Just tried in XFCE and the menus workd as expected without any issues.

Adolfo Jayme (fitojb) on 2013-08-03
no longer affects: unity (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in eclipse (Ubuntu):
status: New → Confirmed
Changed in unity-gtk-module (Ubuntu):
status: New → Confirmed
Fuad Hamidan (vootsugu) wrote :

I got the same issue

john ferrier (john-j-ferrier) wrote :

Same problem for me.

john ferrier (john-j-ferrier) wrote :

My Eclipse was the latest version (Kepler) downloaded from http://www.eclipse.org/downloads/, not the specific Ubuntu package "eclipse 3.8.1-1ubuntu1" which was mention above. It worked on Ubuntu 13.04 but had problem after I upgraded my OS from 13.04 to 13.10 yesterday.

john ferrier (john-j-ferrier) wrote :

The problem is caused by unity global menu. if I start eclipse "env UBUNTU_MENUPROXY= eclipse" then there is no problem.

john ferrier (john-j-ferrier) wrote :

Do you have a plan to fix this before the official release of Ubuntu 13.10?

arno_b (arno.b) wrote :

The workaround of comment #8 fixed this issues for me.

Franck (alci) wrote :

Workaround works, but this is a regression nonetheless...

Michael Prentice (splaktar) wrote :

I'm seeing this same issue and UBUNTU_MENUPROXY= eclipse isn't helping me. This really breaks things for me, please fix ASAP.

I'll try to push a fix for this problem into Debian over the upcoming
weekend. Will keep you guys posted.

Adnan

On Wed, Sep 25, 2013 at 8:48 AM, Michael Prentice <email address hidden>wrote:

> I'm seeing this same issue and UBUNTU_MENUPROXY= eclipse isn't helping
> me. This really breaks things for me, please fix ASAP.
>
> --
> You received this bug notification because you are subscribed to eclipse
> in Ubuntu.
> Matching subscriptions: eclipse bug mail
> https://bugs.launchpad.net/bugs/1208019
>
> Title:
> Eclipse menus doesn't show up in Saucy
>
> Status in “eclipse” package in Ubuntu:
> Confirmed
> Status in “unity-gtk-module” package in Ubuntu:
> Confirmed
>
> Bug description:
> Steps to reproduce:
> 1. Run Eclipse.
> 2. Move the cursor to the top of the screen.
> 3. Click on any of the menu items (File, Edit, Navigate, ...)
>
> Expected: The content of the submenus show up
>
> Actual: Only the top-level headers seem to be available. Nothing
> happens when I click on them either. They don't show up in the HUD
> either.
>
> It worked fine on 13.04, so I'm not sure what changed.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 13.10
> Package: eclipse 3.8.1-1ubuntu1
> ProcVersionSignature: Ubuntu 3.10.0-6.17-generic 3.10.3
> Uname: Linux 3.10.0-6-generic i686
> ApportVersion: 2.11-0ubuntu1
> Architecture: i386
> Date: Sat Aug 3 17:03:55 2013
> InstallationDate: Installed on 2013-07-08 (25 days ago)
> InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha i386
> (20130708)
> MarkForUpload: True
> PackageArchitecture: all
> SourcePackage: eclipse
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/eclipse/+bug/1208019/+subscriptions
>

Michael Prentice re#12: In order for workaround #8 to work, you have to type in one line:
env UBUNTU_MENUPROXY= eclipse
Notice the space bar after the '=' character. Do not use EXPORT etc, do not set environment variables, use this exact command provided that 'eclipse' is the command you would usually use.

George Shields (gherbs) wrote :

Using 13.10 (latest release 10-4-13) and clean of install fo Dart (eclipse).
Menus FAIL, solution is export UBUNTU_MENUPROXY= eclipse
Now menus work!

Basher Aobasher (aobasher) wrote :

it work fro me now, here is how to

sudo gedit /usr/share/applications/eclipse.desktop

update it to :

[Desktop Entry]
Version=1.0
Name=Eclipse
Exec=env UBUNTU_MENUPROXY= eclipse
Terminal=false
Icon=/opt/eclipse/icon.xpm
Type=Application
Categories=IDE;Development
X-Ayatana-Desktop-Shortcuts=NewWindow
[NewWindow Shortcut Group]
Name=New Window
Exec=env UBUNTU_MENUPROXY= eclipse
TargetEnvironment=Unity

Peter Salzmann (petersalzmann) wrote :

I just upgraded 13.04 to 13.10 today 18/10/2013 and issue still exists with eclipse Kepler SR x64 version.
no worries with ubuntu build.

Downloaded "http://download.eclipse.org/eclipse/downloads/drops4/R-4.3.1-201309111000/download.php?dropFile=eclipse-platform-4.3.1-linux-gtk.tar.gz" on Ubuntu 13.10, starting with OpenJDK 1.7.0_25: clicking the main menu bar entries does not show the menus.

j (j-the-k) wrote :

Eclipse Indigo works with 13.10, as it does not seem to have the gobal menu integration.
The #8 workaround helped with Kepler, thanks.

Anders Hall (a.hall) wrote :

Nr 8 worked for me. Nr 16 worked when running as root.

Daniel Korsak (daniel-korsak) wrote :

I do not have "/usr/share/applications/eclipse.desktop". Installed eclipse from eclipse download page.
I have also the same problem after upgrade ubuntu to 13.10.

How can I fix it?

I also have same problem after upgrading into 13.10.

ian stansbury (istansbury22) wrote :

Comment 16 fixed for me.

Did have to change one line to

Exec=env UBUNTU_MENUPROXY= /opt/eclipse/eclipse
                                                                (my eclipse installed directory)

Wanted to clarify if others were having problems with the solution. Thanks for the solution.

@Daniel-

if you got to eclipse directory in terminal and:

export UBUNTU_MENUPROXY= eclipse

it should allow you to have a fixed solution launching with ./eclipse

Megam Systems (megam) wrote :

I have an eclipse bundle downloaded (tar ball) with scala/go updates.
It works when you export it in your .bashrc.
You need to have a space after = and eclipse

曹树烽 (1033798960-n) wrote :

We can create a .desktop file ourself. Then use the "chmod u+x eclipse.desktop". Finally,we can cleak the Icon.

Does the problem happen when using Oracle JRE or happens only with OpenJDK 1.7?

I have only tried with OpenJDK.

Same problem, again on 13.10. This time with:
eclipse-SDK-4.4M2-linux-gtk-x86_64.tar.gz

and Java:
java -version
java version "1.8.0-ea"
Java(TM) SE Runtime Environment (build 1.8.0-ea-b111)
Java HotSpot(TM) 64-Bit Server VM (build 25.0-b53, mixed mode)

Since the package that configures the desktop file is "eclipse", " unity-gtk-module" has no relationship with this bug.

Changed in unity-gtk-module (Ubuntu):
status: Confirmed → Invalid
importance: Undecided → Critical
Changed in eclipse (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
gbolcer (gbolcer) wrote :

Used workaround. Menus work, Eclipse launches, but Ivy and Vaadin plugin menus do not. Eclipse assumes they are already installed, but no way to access them either through the toolbar or the right-click on project menus. Uinstall and reinstall have no effect.

Tin Tvrtkovic (tinchester) wrote :

UBUNTU_MENUPROXY makes Eclipse not use the global menu, right?

It works for me, but it's extra screen real-estate wasted and the HUD doesn't work.

Dac Chartrand (conner-bw) wrote :

Hi, this is a long shot but the symptoms are the same. That is, Java apps that used Global Menus working fine in 13.04 are now broken in 13.10 - the UBUNUTU_MENUPROXY being the same.

The possibly related (or unrelated?) bug was narrowed down to "Native crash in org.eclipse.swt.internal.gtk.OS._gtk_widget_show." Crash logs and test case here (in the thread):

https://bugs.eclipse.org/bugs/show_bug.cgi?id=419729

Ie. Launchpad bug #1241101. It would be nice to get some coordinated efforts on this?

Best regards,

Luis Martín (luismartinsev) wrote :

I've upgraded to Ubuntu 13.10 today and same problem. Everyone seems to fix their problem with:
env UBUNTU_MENUPROXY= path/to/eclipse
and editing eclipse.desktop to add the same to the Exec line,
but I'm still having this issue.

Netbeans (also Java) doesn't even start. I must say that just after upgrading Ubuntu, I tried to open Eclipse, but there was an error saying Java was not installed. It worked perfectly in Ubuntu 13.04 though.

So I've followed the steps provided here to reinstall Java: http://www.webupd8.org/2012/01/install-oracle-java-jdk-7-in-ubuntu-via.html
and then Eclipse starts with this annoying bug. The splash screen looks also buggy, displaying part of it repeated just below like a pattern.

Please I need this working. Any help would be really appreciated.

Enol (nfsu-2-91) wrote :

I have the same problem, the menus won't show. I did not install eclipse, just unpacked the jar.gz and run it. This worked fine in ubuntu 13.04, but doesn't in 13.10.

Patrick Roncagliolo (roncapat) wrote :

The problem affects my eclipse startup splash screen too...

Andrey T (tandrey-office) wrote :

I have exactly the same bug in eclipse - menus don't work. splash screen as in the previous message. Ubuntu 13.10.

Can you upload a screen-shot of you workspace?

Do you experience this same behaviour when:

- Editing images in GIMP?
- Cutting an image in Simple Scan?

Changed in eclipse (Ubuntu):
status: Triaged → Incomplete
Changed in unity-gtk-module (Ubuntu):
status: Invalid → Incomplete
Patrick Roncagliolo (roncapat) wrote :

Simple Scan works...
I don't have GIMP installed

"Can you upload a screen-shot of you workspace?"

This is a screenshot of my eclipse on a two-screens configuration... but i don't know how it can help us...

Marc-Andre Laperle (malaperle) wrote :

I think Eclipse used to be black-listed in raring in
/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/menuproxies/libappmenu.so
but now in Saucy it's in
/usr/lib/x86_64-linux-gnu/gtk-2.0/modules/libunity-gtk-module.so

Maybe it's not getting picked up because it's in a different .so?

I'm unable to reproduce this bug using two different computers.

Are you experiencing this bug after updating your system?

Marc-Andre Laperle (malaperle) wrote :

"Are you experiencing this bug after updating your system?"

Here is what I tested:

                                         eclipse ubuntu package eclipse kepler sr1
13.04 i386 fresh good good
13.10 i386 upgrade bad bad
13.10 x86_64 upgrade ? bad
13.10 i386 fresh bad bad
13.10 x86_64 fresh good bad

Marc-Andre Laperle (malaperle) wrote :

well, that was bad formatting, let's try this

13.04 i386 fresh install
    eclipse ubuntu package: good
    eclipse kepler sr1: good
13.10 i386 upgraded from 13.04
    eclipse ubuntu package: bad
    eclipse kepler sr1: bad
13.10 x86_64 upgraded from 13.0
    eclipse ubuntu package: ?
    eclipse kepler sr1: bad
13.10 i386 fresh install
    eclipse ubuntu package: bad
    eclipse kepler sr1: bad
13.10 x86_64 fresh install
    eclipse ubuntu package: good
    eclipse kepler sr1: bad

Thanks Marc, this is just what we needed. I will correct that line with "?":

13.04 i386 fresh install
    eclipse ubuntu package: good
    eclipse kepler sr1: good
13.10 i386 upgraded from 13.04
    eclipse ubuntu package: bad
    eclipse kepler sr1: bad
13.10 x86_64 upgraded from 13.0
    eclipse ubuntu package: good
    eclipse kepler sr1: bad
13.10 i386 fresh install
    eclipse ubuntu package: bad
    eclipse kepler sr1: bad
13.10 x86_64 fresh install
    eclipse ubuntu package: good
    eclipse kepler sr1: bad

The fix for this bug is simply to add the "UBUNTU_MENUPROXY= eclipse" to the .desktop file in the i386 Eclipse package.

Changed in unity-gtk-module (Ubuntu):
status: Incomplete → Invalid
Changed in eclipse (Ubuntu):
status: Incomplete → Triaged

Probably developers did in the AMD64 package, but forgot in the i386.

Patrick Roncagliolo (roncapat) wrote :

but in ubuntu 12.04 menus weren't in the global bar?

Patrick Roncagliolo (roncapat) wrote :

this is just a workaround... problems with ubuntu 13.10 are not solved since we have to do a workaround to fix part of the problem and there is still something wrong because for example we can se a bug even in the splash screen... correct me if i'm wrong

Mihai Vinaga (vinaga-mihai) wrote :

I agree with Patrick Roncagliolo. I upgraded from 13.04 and it broke my Eclipse and Zend Studio as well which by the way displayed the menus correctly integrated with Ubuntu, now I have to do the workaround. Can anyone tell us if this is eclipse or ubuntu problem?

Dac Chartrand (conner-bw) wrote :

Alberto, that's not a fix. That's a workaround.

Global Menus (appmenu, hud) is a flagship Ubuntu feature that needs attention by product owners who care about this feature.

 * Bug #1241101 has a simple, reproducible, test case and the dev on the Eclipse side is waiting for a patch.
 * Bug #618587 claims this issue is fixed (comment 33). So, this is either a regression, or a fix was never released in the first place?
 * Etc. I can dig up half a dozen reports like this but I wont.

It would be nice if people stopped sweeping this under the rug.

Thank you for your consideration.

Patrick Roncagliolo (roncapat) wrote :

good news... look at this... in my eclipse sr1 installation on ubuntu 13.10 only the menù "edit" works !!!

i discovered it after whitelisting eclipse with:

sudo sed -i 's/Eclipse/Eclipse/g' /usr/lib/x86_64-linux-gnu/gtk-2.0/modules/libunity-gtk-module.so
(found at http://www.webupd8.org/2013/01/eclipse-ide-get-ubuntu-appmenu-and-hud.html)

i'm not sure if that is due to the command i have posted just right now or if before the mod the edit menu could be seen...

Patrick Roncagliolo (roncapat) wrote :

here is the screen of that "miracle"

Marc-Andre Laperle (malaperle) wrote :

Alberto, just to be clear, by "good" I meant the global menu was disabled and the in-window menu worked and by "bad" I meant the global menu was enabled and broken.

IMO, on the short term, the workaround to remove the global menu should be applied by default, as it was in 13.04 because the real issue might take a while to fix.

Yes, sorry. So:

- Eclipse package in i386 needs to be workarounded.
- Then, "unity-gtk-module" shall be fixed.

Changed in unity-gtk-module (Ubuntu):
status: Invalid → Triaged
Patrick Roncagliolo (roncapat) wrote :

splash screen is another "stupid" bug, but i can't figure why we shouldn't consider it too.

Marc-Andre Laperle (malaperle) wrote :

"splash screen is another "stupid" bug, but i can't figure why we shouldn't consider it too."

I think it should be filled as a separate bug.

Yes, it's a different bug. Moreover filling it as a separate one will make it to be fixed faster than this one.

If you make a different report for the splash screen, tell the bug number here and we will confirm and triage it immediately.

Thank you.

Workaround: Those who have created the Unity menu entry from "Fix this to the panel" should add the "env UBUNTU_MENUPROXY= " in the .desktop file created in /home/user/.local/share/applications

Marc-Andre Laperle (malaperle) wrote :

Interesting: g_get_prgname() returns "Eclipse" in 13.04 and it returns "eclipse" (notice the case) in 13.10 but only Eclipse is blacklisted.

Ahmed Essam (decembermoon) wrote :

hi ,this is only my second day using ubuntu , so don't laugh at me .
all the above workaround didn't work for me , however launching eclipse as root did work flawlessly for me . so may be a permission problem ?
Version: Kepler Service Release 1
Build id: 20130919-0819
ubuntu 13.10

Ahmed, does your "/usr/share/applications/eclipse.desktop" look like this?:

[Desktop Entry]
Type=Application
Name=Eclipse
Comment=Eclipse Integrated Development Environment
Icon=eclipse
Exec=env UBUNTU_MENUPROXY= eclipse
Terminal=false
Categories=Development;IDE;Java;

description: updated
Ahmed Essam (decembermoon) wrote :

Alberto , here is my eclipse.desktop

[Desktop Entry]
Version=1.0
Name=Eclipse
Exec=env UBUNTU_MENUPROXY= /opt/eclipse/eclipse
Terminal=false
Icon=/opt/eclipse/icon.xpm
Type=Application
Categories=IDE;Development
X-Ayatana-Desktop-Shortcuts=NewWindow
[NewWindow Shortcut Group]
Name=New Window
Exec=env UBUNTU_MENUPROXY= /opt/eclipse/eclipse
TargetEnvironment=Unity

@Ahmed: I'm unable to tell myself where the problem is.

Ahmed,
Just guessing at the problem but are you launching eclipse from the command line? If you are launching as root from the command line the eclipse.desktop file doesn't take effect. This file is only for launching from the dash.

To launch from the command line with this fix type in:
env UBUNTU_MENUPROXY= /opt/eclipse/eclipse

(remembering the space after the "=").

Hope that helps

Ahmed Essam (decembermoon) wrote :

@David , Your Guess Was Correct (*^.^*) .
thx .

Same problem for Aptana (Standalone Version).

Same problem for me. When this bug will be fixed?

thanks!!

Sebastián Funicello (cuacrzz) wrote :

I did the eclipse.desktop file thing and now works, but it seems to be eclipse 3.8 version and i had Kepler. Splash screen looks old too. There's anyone else with this problem?

Marc-Andre Laperle (malaperle) wrote :

Sebastián, which eclipse.desktop file did you modify? The one from the Ubuntu Eclipse package or did you create your own? Ubuntu only packages Eclipse 3.8 so if you want to use kepler (4.3), you have to download, extract it manually (from the sound of it you already did that) then you need to create your own .desktop file that points to the executable, with the same menu workaround. You can drag that new .desktop file to the launcher.

The splash screen I believe got fixed recently in the upcoming version 4.4 because it looks fine with the latest build for me but not earlier versions. I'll poke around to see if the fix can be backported to the 4.3 stream but this is a bit off-topic...

I think a good temporary solution for the menu would be to fix the blacklist so Eclipse is blacklisted again at the "program name" level so that both the Ubuntu package and the eclipse.org packages have a working menu again. But from what I understand of the problem, it would only workaround the issue for Eclipse products that have "eclipse" or "Eclipse" has the executable name and not the other products that have a different executable name (Aptana? Dart?). Still, that would mean most people won't have to apply a workaround manually which is a big win IMO. I just need a few spare hours to verify all this and push a fix ;)

Kevin Navero (solstice333) wrote :

This might help clarify any desktop file ambiguity (in the case where Eclipse is downloaded directly from the website and unpacked):

http://askubuntu.com/questions/26632/how-to-install-eclipse

Sebastián Funicello (cuacrzz) wrote :

I made my own eclipse.desktop file, and pasted this:

[Desktop Entry]
Version=1.0
Name=Eclipse
Exec=env UBUNTU_MENUPROXY= /opt/eclipse/eclipse
Terminal=false
Icon=/opt/eclipse/icon.xpm
Type=Application
Categories=IDE;Development
X-Ayatana-Desktop-Shortcuts=NewWindow
[NewWindow Shortcut Group]
Name=New Window
Exec=env UBUNTU_MENUPROXY= /opt/eclipse/eclipse
TargetEnvironment=Unity

But it opens 3.8 version. Then I looked if unpacking eclipse folder and make desktop file again fixes it but nothing, it keeps showing 3.8 version.

Anyway, this bug it's about something else and have a temporary solution, my problem is different so maybe i should look somewhere else, idk.

waffen (mlacunza) wrote :

@cuacrzz:: thats fine, your desktop file is pointing to the by defuault eclipse installation, change the path to your local eclipse v.4 that works for me.

Sebastián Funicello (cuacrzz) wrote :

@waffen: You were right, somehow I pasted other path from another page I suppose, and not that I pasted here (kinda stupid, I know :P), now I fixed it and it works. Thanks everyone!

Marc-Andre Laperle (malaperle) wrote :

As a follow up to my previous comment: Unfortunately, adding "eclipse" to the blacklist (in addition to "Eclipse") only works for 32 bit because in 64 bit, the eclipse process forks a java process. Since the blacklist works on the executable name, that would mean blacklisting all java programs which would be overkill. It looks like the real solution will be to make the global menu work.

Here are my observations looking into blacklisting:

13.04:
- g_set_prgname is called first with "eclipse" when showing the splash screen
- A few seconds later g_set_prgname is called again with "Eclipse", from some java code
- Then, when a gtk_combo_box is constructed, the menu_proxy_module gets loaded and the blacklist is checked using g_get_prgname, "Eclipse" matches

13.10 (32 bit):
- g_set_prgname is called first with "eclipse" when showing the splash screen
- In the same call to show the splash screen, gtk_module gets initialized and the blacklist is checked using g_get_prgname, "eclipse" doesn't match "Eclipse"
- Then a few seconds later g_set_prgname is called again with "Eclipse", from some java code

13.10 (64 bit):
- g_set_prgname is called first with "java" when showing the splash screen
- In the same call to show the splash screen, gtk_module gets initialized and the blacklist is checked using g_get_prgname, "java" doesn't match "Eclipse"
- Then a few seconds later g_set_prgname is called again with "Eclipse", from some java code

Juan Carlos (qheolet) wrote :

Is not just eclipse Sublime Editor 2 /3 and today i feel the global menu using gimp laggi and slow...... i never use a ubuntu version so buggy.... is weirds what happen with the comunity?

tags: added: rls-t-incoming
Sergio (sergiorussia) wrote :

about splash screen issue i should note that the same problem appears in IntelliJ IDEA, however it sometimes shows with unneeded title bar instead of the garbage, which i think is the root of the problem. same Eclipse and IDEA installations worked fine in 13.04, so i guess it's related to Java and/or hmm… lets call it "broken window decorating"?

SoloTurn (soloturn) wrote :

the workaround does not solve the missing dropdown of the workspace selection right after the start. but - one can open the file browser so there is a workaround here as well.

deepak (deepatwal) wrote :

Hi guys,

I am very new to UBUNTU.

I have a question : eclipse ide 3.8 is very fine in 13.04 or not..?
 because as per the bug mentioned here I am facing the same problem.

igor (igoryonya) wrote :

The bug also affects GIMP and Inkscape

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

igor (igoryonya) on 2014-01-20
affects: eclipse-eclipsers → inkscape (Ubuntu)
Changed in inkscape (Ubuntu):
status: New → Confirmed
igor (igoryonya) on 2014-01-20
affects: inkscape → gimp (Ubuntu)
Changed in gimp (Ubuntu):
status: New → Confirmed

Since the origin of the bug is the "unity-gtk-module" package, this is the only affected one.

description: updated
no longer affects: eclipse (Ubuntu)
no longer affects: gimp (Ubuntu)
no longer affects: inkscape (Ubuntu)
Changed in unity-gtk-module:
status: New → Confirmed
Changed in hundredpapercuts:
status: New → Triaged
importance: Undecided → Critical
no longer affects: hundredpapercuts
vtec (vitekcvachoucek) wrote :

I have run a debugging session from the Eclipse side. When you click the global menu it is producing event that gets handed down to the main SWT loop, there Eclipse takes the event and gives it back to GTK calling gtk_main_do_event for precise targeting of the affected component. Without the global menu the event would popout back from GTK inside the Menu widget triggering something like menuIsAboutToShow callback. With global menu however the event is swallowed and never comes back.

The Java code in Eclipse has no role here nor the super-thin SWT native code. It an apparent regression in the behavior of the GTK library. In other words it is Ubuntu global menu back not being compatible with standard GTK behavior.

*** Bug 426707 has been marked as a duplicate of this bug. ***

*** Bug 424672 has been marked as a duplicate of this bug. ***

Revisiting this : I don't see this behaviour with Inkscape or with GIMP.

I still see this with Eclipse 4.3

The behaviour almost looks like the menu is being drawn behind the application window, but that could just be a product of the code flow mentioned above.

See attached image : the top of the menu visible in the menu bar area has been drawn, along with some of the menu spilling into the application window, but this seems to have stopped short of rendering the whole menu. This is the product of clicking the menu item.

In addition, the top-level menu titles are available in the HUD, but none of their content.

dapaldo (dpalomar) wrote :

Same behaviour with eclipse 3.8.1 and eclipse 4.3 and springsource tool suite (eclipse same version based) on ubuntu 14.04.
Tested with openjdk-7 and oracle-jdk7.
OS: ubuntu trusty 14.04
Only top-level menu items are available.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in oracle-jdk7-installer (Ubuntu):
status: New → Confirmed
Changed in oracle-jdk7-installer (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Critical
Raymond Wells (rfw2nd) wrote :

Confirmed on Trusty as well. Still no submenus w/ the gloabal menu.

matthieu vidal (mvidal0001) wrote :

Still a problem with trusty alpha ... except for the menu Edit

the problem is also there when "In Window Title Bars" is checked.

Changed in eclipse:
importance: Unknown → Critical
status: Unknown → Confirmed

have the same problem.

Anders (eddiedog988) on 2014-03-13
Changed in unity-gtk-module (Ubuntu):
status: Triaged → Confirmed
Changed in oracle-jdk7-installer (Ubuntu):
status: Triaged → Confirmed
Jörg Frings-Fürst (jff-de) wrote :

Hi Anders,

why do you change the status from triaged to confirmed??

Jörg

C de-Avillez (hggdh2) wrote :

returned oracle-jdk7-installer to triaged.

@all: please provide an explanation of any and all status changes you make.

Changed in oracle-jdk7-installer (Ubuntu):
status: Confirmed → Triaged
William Hua (attente) on 2014-03-20
Changed in unity-gtk-module:
assignee: nobody → William Hua (attente)
Changed in unity-gtk-module (Ubuntu):
assignee: nobody → William Hua (attente)
status: Confirmed → In Progress
Changed in unity-gtk-module:
status: Confirmed → In Progress
Teo (teo1978) on 2014-03-22
description: updated
description: updated

for the keyboard shortcuts with the global menu see Bug417601

This bug was fixed in the package unity-gtk-module - 0.0.0+14.04.20140328-0ubuntu1

---------------
unity-gtk-module (0.0.0+14.04.20140328-0ubuntu1) trusty; urgency=low

  [ CI bot ]
  * Stop using signal handler ids. Use
    g_signal_handlers_disconnect_by_data () instead.

  [ William Hua ]
  * Fix Eclipse and DBeaver menus. (LP: #1208019)
  * Watch use-underline on label instead of menu item. (LP: #1294947)
 -- Ubuntu daily release <email address hidden> Fri, 28 Mar 2014 10:54:34 +0000

Changed in unity-gtk-module (Ubuntu):
status: In Progress → Fix Released

Hooray! Any chance of a backport to Saucy or is it destined to be broken for that release forever? (although I suppose I'll be upgrading quite soon....)

matthieu vidal (mvidal0001) wrote :

Great !!! It works on the beta

but the icons of the menus are missing

Wiktor: Nizio (zap-4) wrote :

The proplem persists on Trusty in Eclipse. Menus 'Search', 'Source' and 'Refactor' become inaccessible after 1+ hour of working. They are okay only for a while when Eclipse is run. Not observed for any of the other menus.

Dan Jared (danjaredg) wrote :

I created the Java Ayatana Project http://code.google.com/p/java-swing-ayatana/, And I have a similar problem, when you change the menu items direct of menu bar, the menu items aren't refresh, and the Eclipse Kepler create and remove menu items direct of menu bar for a open file or selected project or resource.

William Hua (attente) wrote :

@zap-4 Hi Wiktor, my apologies, I'm not an Eclipse user. Is there a set of simple steps I could do to reproduce the missing menus problem?

William Hua (attente) wrote :

@zap-4 Also Wiktor, what Eclipse version are you using? Thanks.

Wiktor: Nizio (zap-4) wrote :

It's Eclipse Kepler Service Release 2 Build id: 20140224-0627 (Eclipse Standard) with Android plugin (ADT). I do not know the styeps. It happens about three times a day (sometimes in less than one hour) and requires Eclipse restart to heal..

matthieu vidal (mvidal0001) wrote :

IMPORTANT : I think this new problem (#101) is not specific to eclipse. Did you try the HUD (ALT+text of the menu) when this problem occurs ?

I've got this problem when playing (too long ... ) to FiveOrMore game. Only the HUD gives me access to the menu choices then the menus are accessible again with the mouse.

@mvidal0001 - Icons missing is the default GTK config option. The GNOME config panels don't show it, of course, because giving choices to users only confuses them, poor things. As does having icons on menus, which is "cluttered" and thus confusing. Apparently.

You can turn it back on like this...

http://ubuntuforums.org/showthread.php?t=1246454&p=7829482#post7829482

matthieu vidal (mvidal0001) wrote :

@adrian-wilkins

Thanks for the answer.

I've done this a long time ago and I have checked that it's still set like that.

I should have indicated that the icons are visible with the UBUNTU_MENUPROXY = 0 workaround.

Firefox is the only application having its menu icons in fact.

about #106 I'm working with the new option 'Menus in title bar"

This bug is still present in last daily build of ubuntu 14.04 LTS (16/04/2014). Is it planned to be solved before final release?

Thx

William Hua (attente) wrote :

Hi José, is the problem that some of the menus disappear after some Eclipse usage? Do you happen to know if there's an easy way to replicate that problem?

matthieu vidal (mvidal0001) wrote :

About Source and Refactor Menus the problem seems to appear when you work with two files of a different type.

ie. Java file vs a text file.

when focusing the text file as there are not Source and Refactor menus for a text file, these two menus are not reactivated when switching back to the Java file. They are empty as describes by the initial problem.

The HUD do not work for these menus and I do not see a workaround to reveale the content of these two menus.

This is a different problem of #106

William Hua (attente) wrote :

Hi matthieu, thanks, I managed to replicate it thanks to your instructions. I'll see if I can figure out what's happening...

I get this bug on new 14.04 and last stable eclipse 4.3.2. Fix by running ecluse with little bach

eclise_sh.sh :
export SWT_GTK3=true
/opt/eclipse/eclipse

eclipse.desktop :

[Desktop Entry]
Type=Application
Name=Eclipse
Comment=Eclipse Integrated Development Environment
Icon=/opt/eclipse/icon.xpm
Exec=sh /opt/eclipse/eclipse_sh.sh
Terminal=false
Categories=Development;IDE;Java;

I didn't try the UBUNTU_MENUPROXY

In fact no, bug appears again. I guess it's because I use PDT (PHP dev tool) and the PHP file type cannont be Refactored.... But the menu are still available on select code and right click, I can Format my php code at least

This should have been solved with Ubuntu 14.04. See https://bugs.launchpad.net/ubuntu/+source/unity-gtk-module/+bug/1208019

I mark this one as solved. Please reopen if you see any issue with Ubuntu 14.04

*** Bug 420099 has been marked as a duplicate of this bug. ***

This is indeed fixed in Ubuntu 14.04.

William Hua (attente) wrote :

Hello, I uploaded a fix for the Source/Refactor menu problem to a PPA.

To install:

sudo add-apt-repository ppa:attente/eclipse-menus
sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-mark hold libunity-gtk2-parser0 libunity-gtk3-parser0 unity-gtk2-module unity-gtk3-module

Once the fix is released, you can unhold the packages with:

sudo apt-mark unhold libunity-gtk2-parser0 libunity-gtk3-parser0 unity-gtk2-module unity-gtk3-module

Sérgio Faria (sergio91pt) wrote :

@attente I installed the ppa, but Eclipse now keeps crashing a few seconds after showing the UI. Both Kepler and the repo version.

Its a SIGSEGV in
C [libglib-2.0.so.0+0x38fe0] g_str_hash+0x0
when Eclipse calls
j org.eclipse.swt.internal.gtk.OS._gtk_widget_show(J)V+0

William Hua (attente) wrote :

@sergio91pt Hi, could you please list your output of:

apt-cache policy libglib2.0-0 libunity-gtk2-parser0 unity-gtk2-module eclipse-platform

I'm running these versions:

libglib2.0-0:
  Installed: 2.40.0-2
libunity-gtk2-parser0:
  Installed: 0.0.0+14.04.20140424-0ubuntu1ppa1
unity-gtk2-module:
  Installed: 0.0.0+14.04.20140424-0ubuntu1ppa1
eclipse-platform:
  Installed: 3.8.1-5.1

@attente Had already reverted the packages. Re-installed and the crash
still occurs. I'm using exactly the same versions.

I tested in a guest account and it works, so it must be because of plugins?

2014-04-24 13:15 GMT+01:00 William Hua <email address hidden>:

> @sergio91pt Hi, could you please list your output of:
>
> apt-cache policy libglib2.0-0 libunity-gtk2-parser0 unity-gtk2-module
> eclipse-platform
>
> I'm running these versions:
>
> libglib2.0-0:
> Installed: 2.40.0-2
> libunity-gtk2-parser0:
> Installed: 0.0.0+14.04.20140424-0ubuntu1ppa1
> unity-gtk2-module:
> Installed: 0.0.0+14.04.20140424-0ubuntu1ppa1
> eclipse-platform:
> Installed: 3.8.1-5.1
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1208019
>
> Title:
> Eclipse menus doesn't show up in Saucy
>
> Status in Eclipse:
> Confirmed
> Status in Unity GTK+ module:
> In Progress
> Status in “oracle-jdk7-installer” package in Ubuntu:
> Triaged
> Status in “unity-gtk-module” package in Ubuntu:
> Fix Released
>
> Bug description:
> ****************
> HOW TO REPRODUCE
> ****************
>
> 1. Run Eclipse, Gimp or Inkscape.
> 2. Move the cursor to the top of the screen.
> 3. Click on any of the menu items (File, Edit, Navigate, ...)
>
> ******************
> EXPECTED BEHAVIOUR
> ******************
>
> - The content of the submenus show up.
>
> **************
> REAL BEHAVIOUR
> **************
>
> - Only the top-level headers are available.
> - Nothing happens when clicking on them
> - They don't show up in the HUD either.
>
> ***********
> WORK-AROUND
> ***********
>
> To modify "/usr/share/applications/eclipse.desktop" to look like this:
>
> [Desktop Entry]
> Type=Application
> Name=Eclipse
> Comment=Eclipse Integrated Development Environment
> Icon=eclipse
> Exec=env UBUNTU_MENUPROXY= eclipse
> Terminal=false
> Categories=Development;IDE;Java;
>
> ****************
> RELEVANT DETAILS
> ****************
>
> - Doesn't affect Ubuntu releases prior to 13.10.
>
> **************
> TECHNICAL INFO
> **************
>
> ProblemType: Bug
> DistroRelease: Ubuntu 13.10
> Package: eclipse 3.8.1-1ubuntu1
> ProcVersionSignature: Ubuntu 3.10.0-6.17-generic 3.10.3
> Uname: Linux 3.10.0-6-generic i686
> ApportVersion: 2.11-0ubuntu1
> Architecture: i386
> Date: Sat Aug 3 17:03:55 2013
> InstallationDate: Installed on 2013-07-08 (25 days ago)
> InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha i386
> (20130708)
> MarkForUpload: True
> PackageArchitecture: all
> SourcePackage: eclipse
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/eclipse/+bug/1208019/+subscriptions
>

@sergio91pt Sounds very plausible, could you please let me know what plugins you're running? Thanks.

William Hua (attente) wrote :

@sergio91pt You're correct, I've replicated the problem by installing a couple of C/C++ plugins.

Verified it is fixed on Ubuntu 14.04. The current version of Unity in Ubuntu 14.04 still does not show the 'Source' and 'Refactor' menus but even that problem has a fix which should be made available in an update soon. See https://bugs.launchpad.net/ubuntu/+source/unity-gtk-module/+bug/1208019/comments/116 for installing the fixed packages now.

William Hua (attente) wrote :

@sergio91pt Hi, are you using Eclipse from the distro? Or upstream's more recent version?

William Hua (attente) wrote :

@sergio91pt The plugins crash disappeared when I upgraded to Eclipse Luna 4.4. I also tested with Kepler 4.3, so it might be exclusively the Ubuntu version with that crash.

If anyone else is experiencing the crash Sérgio mentioned re: plugins, you might want to try upstream's version.

Sérgio Faria (sergio91pt) wrote :

@attente I have both installed, but I always use my own install of Kepler (Java EE Developers suite, SR2, last update roughly 1 month ago).
I tested with both, using the same workspace (gets some shared plugins).

I also have jayata [1] installed, removed it and tested with JAVA_TOOL_OPTIONS="" but it still crashes.

Attached is a list of all plugins I have installed, some are from dev channels: gradle, groovy and the theme plugin.
I'll test Luna and report back.

[1]: https://code.google.com/p/java-swing-ayatana/

Sérgio Faria (sergio91pt) wrote :
Changed in eclipse:
status: Confirmed → Unknown

*** Bug 433399 has been marked as a duplicate of this bug. ***

@attente Sorry for taking so long. I've tried it on Luna, with most of my old plugins re-installed and it works without the constant crashing.

I deleted .metadata and restarted (which I think I didn't do before), now it also works on Kepler.

Sérgio Faria (sergio91pt) wrote :

*Rebooted not restarted...

William Hua (attente) wrote :

Sérgio, thanks for the workaround!

William Hua (attente) wrote :
Download full text (3.3 KiB)

Hmm... I seem to be getting a different crash on startup now:

Stack: [0x00007f4bd26d8000,0x00007f4bd27d9000], sp=0x00007f4bd27d5460, free space=1013k
Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
C [libwebkitgtk-1.0.so.0+0x461ca9] webkit_web_view_get_type+0x2489
C [libgtk-x11-2.0.so.0+0x12d7e5] gtk_marshal_VOID__UINT_STRING+0x105

Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)
j org.eclipse.swt.internal.gtk.OS._gtk_main_do_event(J)V+0
j org.eclipse.swt.internal.gtk.OS.gtk_main_do_event(J)V+8
j org.eclipse.swt.widgets.Display.eventProc(JJ)J+157
v ~StubRoutines::call_stub
j org.eclipse.swt.internal.gtk.OS._gdk_window_process_all_updates()V+0
j org.eclipse.swt.internal.gtk.OS.gdk_window_process_all_updates()V+7
j org.eclipse.swt.widgets.Display.update()V+10
j org.eclipse.swt.widgets.Display.runDeferredLayouts()Z+60
j org.eclipse.swt.widgets.Display.readAndDispatch()Z+10
j org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$9.run()V+638
j org.eclipse.core.databinding.observable.Realm.runWithDefault(Lorg/eclipse/core/databinding/observable/Realm;Ljava/lang/Runnable;)V+12
j org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(Lorg/eclipse/e4/ui/model/application/MApplicationElement;Lorg/eclipse/e4/core/contexts/IEclipseContext;)Ljava/lang/Object;+57
j org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(Lorg/eclipse/e4/ui/model/application/MApplicationElement;)V+20
j org.eclipse.ui.internal.Workbench$5.run()V+310
j org.eclipse.core.databinding.observable.Realm.runWithDefault(Lorg/eclipse/core/databinding/observable/Realm;Ljava/lang/Runnable;)V+12
j org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Lorg/eclipse/swt/widgets/Display;Lorg/eclipse/ui/application/WorkbenchAdvisor;)I+18
j org.eclipse.ui.PlatformUI.createAndRunWorkbench(Lorg/eclipse/swt/widgets/Display;Lorg/eclipse/ui/application/WorkbenchAdvisor;)I+2
j org.eclipse.ui.internal.ide.application.IDEApplication.start(Lorg/eclipse/equinox/app/IApplicationContext;)Ljava/lang/Object;+111
j org.eclipse.equinox.internal.app.EclipseAppHandle.run(Ljava/lang/Object;)Ljava/lang/Object;+135
j org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(Ljava/lang/Object;)Ljava/lang/Object;+88
j org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(Ljava/lang/Object;)Ljava/lang/Object;+82
j org.eclipse.core.runtime.adaptor.EclipseStarter.run(Ljava/lang/Object;)Ljava/lang/Object;+109
j org.eclipse.core.runtime.adaptor.EclipseStarter.run([Ljava/lang/String;Ljava/lang/Runnable;)Ljava/lang/Object;+132
v ~StubRoutines::call_stub
j sun.reflect.NativeMethodAccessorImpl.invoke0(Ljava/lang/reflect/Method;Ljava/lang/Object;[Ljava/lang/Object;)Ljava/lang/Object;+0
j sun.reflect.NativeMethodAccessorImpl.invoke(Ljava/lang/Object;[Ljava/lang/Object;)Ljava/lang/Object;+87
j sun.reflect.DelegatingMethodAccessorImpl.invoke(Ljava/lang/Object;[Ljava/lang/Object;)Ljava/lang/Object;+6
j java.lang.reflect.Method.invoke(Ljava/lang/Object;[Ljava/lang/Object;)Ljava/lang/Object;+57
j org.eclipse.equinox.launcher.Main.invokeFramework([Ljava/lang/String;[Ljava/net/URL;)V+211
j org....

Read more...

William Hua (attente) wrote :

Wiktor, how are you reproducing the bug? Are you using the PPA?

I can easily trigger this one by opening a new Window.
My wild guess would be a race of sorts in MenuItem.createHandle

C [libglib-2.0.so.0+0x38fe0] g_str_hash+0x0

Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)
j org.eclipse.swt.internal.gtk.OS._gtk_widget_show(J)V+0
j org.eclipse.swt.internal.gtk.OS.gtk_widget_show(J)V+8
j org.eclipse.swt.widgets.MenuItem.createHandle(I)V+249
j org.eclipse.swt.widgets.Widget.createWidget(I)V+2
j
org.eclipse.swt.widgets.MenuItem.<init>(Lorg/eclipse/swt/widgets/Menu;II)V+38
j
org.eclipse.ui.internal.SwitchToWindowMenu.fill(Lorg/eclipse/swt/widgets/Menu;I)V+97

2014-05-07 20:39 GMT+01:00 William Hua <email address hidden>:

> Wiktor, how are you reproducing the bug? Are you using the PPA?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1208019
>
> Title:
> Eclipse menus doesn't show up in Saucy
>
> Status in Eclipse:
> Unknown
> Status in Unity GTK+ module:
> In Progress
> Status in “oracle-jdk7-installer” package in Ubuntu:
> Triaged
> Status in “unity-gtk-module” package in Ubuntu:
> Fix Released
>
> Bug description:
> ****************
> HOW TO REPRODUCE
> ****************
>
> 1. Run Eclipse, Gimp or Inkscape.
> 2. Move the cursor to the top of the screen.
> 3. Click on any of the menu items (File, Edit, Navigate, ...)
>
> ******************
> EXPECTED BEHAVIOUR
> ******************
>
> - The content of the submenus show up.
>
> **************
> REAL BEHAVIOUR
> **************
>
> - Only the top-level headers are available.
> - Nothing happens when clicking on them
> - They don't show up in the HUD either.
>
> ***********
> WORK-AROUND
> ***********
>
> To modify "/usr/share/applications/eclipse.desktop" to look like this:
>
> [Desktop Entry]
> Type=Application
> Name=Eclipse
> Comment=Eclipse Integrated Development Environment
> Icon=eclipse
> Exec=env UBUNTU_MENUPROXY= eclipse
> Terminal=false
> Categories=Development;IDE;Java;
>
> ****************
> RELEVANT DETAILS
> ****************
>
> - Doesn't affect Ubuntu releases prior to 13.10.
>
> **************
> TECHNICAL INFO
> **************
>
> ProblemType: Bug
> DistroRelease: Ubuntu 13.10
> Package: eclipse 3.8.1-1ubuntu1
> ProcVersionSignature: Ubuntu 3.10.0-6.17-generic 3.10.3
> Uname: Linux 3.10.0-6-generic i686
> ApportVersion: 2.11-0ubuntu1
> Architecture: i386
> Date: Sat Aug 3 17:03:55 2013
> InstallationDate: Installed on 2013-07-08 (25 days ago)
> InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha i386
> (20130708)
> MarkForUpload: True
> PackageArchitecture: all
> SourcePackage: eclipse
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/eclipse/+bug/1208019/+subscriptions
>

@attente

For the webkit crash in webkit_web_view_get_type, either disable overlay-scrollbar with LIBOVERLAY_SCROLLBAR=0 or use a recent build of Eclipse Luna (which disables them at startup). See https://bugs.eclipse.org/bugs/show_bug.cgi?id=425614

With current Java 8u5 bug is still there in normal eclipse Download

@sergio91pt

I can reproduce the same crash using the PPA and doing New Window. I'm using Eclipse 4.4-I20140509-2000

I also got the crash when doing Window > Customize Perspective > Command Groups Availability then enabling command groups. But it's not 100% of the time.

I'm using the PPA:
0.0.0+14.04.20140424-0ubuntu1ppa1

matthieu vidal (mvidal0001) wrote :

Hi folks !!!

The bug is also there with the newborn eclipse 4.4

Hi think it's time to apply Ubunty (or Unitou .... I'm not sure of the name) to the Razzies awards

Category: Linux geeks have a big problem with Java technology which is kicking their ass for 20 years ....

or

Category: Ubunty (or Unitou) is a kind of gnome .... but not exactly ... something different ... but not the same ...

waffen (mlacunza) wrote :

In my ubuntu 14.04 64bits with unity I cant reproduce the bug anymore.

I has been setting menus in the top of the windows and not in the top OS bar maybe that helps.

William Hua (attente) wrote :

Matthieu, does the problem still happen with the PPA I mentioned from https://bugs.launchpad.net/ubuntu/+source/unity-gtk-module/+bug/1208019/comments/116?

matthieu vidal (mvidal0001) wrote :

Somebody told you it was working ?

Since #116 ? Since April ?

I'm not interesting with crashes : 141 ... 140 ... 138 ... 137 ?

I'm struggling with Eclipse Global menu since the first Unito (Ubunty ?) release .... and I do not use Unity anymore ... except for this test.

Sorry

Franck (alci) wrote :

I don't really get what is happening to you guys... I used to see this bug, but not anymore since at least 13.10. I'm using eclipse on a daily basis with no problem (with egit and a clovergui plugin based on GEF). I just upgraded to Luna (4.4.0), and things work just fine.

Here is my .desktop file:

[Desktop Entry]
Type=Application
Name=Eclipse
Comment=Eclipse Integrated Development Environment
Icon=/home/franck/devel/outils/eclipse-4.4.0/icon.xpm
Exec=/home/franck/devel/outils/eclipse-4.4.0/eclipse
Terminal=false
Categories=Development;IDE;Java;
StartupWMClass=Eclipse

So there must be another parameter kicking in than just eclipse + unity global menus, as this work out of the box for me and my coworkers.
Notice I don't use eclipse package as they are outdated, I just use plain tar.gz directly from eclipse.

William Hua (attente) wrote :
William Hua (attente) wrote :
William Hua (attente) on 2014-07-16
description: updated
William Hua (attente) on 2014-07-16
description: updated
description: updated
Changed in gtk:
importance: Unknown → Medium
status: Unknown → Fix Released
William Hua (attente) on 2014-07-16
Changed in oracle-jdk7-installer (Ubuntu):
status: Triaged → Invalid

The attachment "gtk+3.0_3.10.8-0ubuntu1.2.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Adolfo Jayme (fitojb) on 2014-07-20
no longer affects: oracle-jdk7-installer (Ubuntu)
William Hua (attente) on 2014-07-28
summary: - Eclipse menus doesn't show up in Saucy
+ Eclipse menus doesn't show up in Trusty
Changed in unity-gtk-module:
status: In Progress → Fix Released
Changed in gtk+3.0 (Ubuntu):
status: New → Fix Released
Changed in gtk+3.0 (Ubuntu Trusty):
status: New → Confirmed
Changed in unity-gtk-module (Ubuntu Trusty):
status: New → Confirmed

I uploaded these, thanks Will.

Changed in gtk+3.0 (Ubuntu Trusty):
status: Confirmed → In Progress
assignee: nobody → William Hua (attente)
Changed in unity-gtk-module (Ubuntu Trusty):
status: Confirmed → In Progress
assignee: nobody → William Hua (attente)

Hello Hans, or anyone else affected,

Accepted gtk+3.0 into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gtk+3.0/3.10.8-0ubuntu1.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

summary: - Eclipse menus doesn't show up in Trusty
+ Eclipse menus don't show up in Trusty
Changed in gtk+3.0 (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
William Hua (attente) wrote :

This fix isn't working because it requires both the gtk patch and the unity-gtk-module patch simultaneously.

Chris Halse Rogers (raof) wrote :

Hello Hans, or anyone else affected,

Accepted unity-gtk-module into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity-gtk-module/0.0.0+14.04.20140403-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity-gtk-module (Ubuntu Trusty):
status: In Progress → Fix Committed
William Hua (attente) wrote :

It fixed the problem in a 14.04 VM for me.

tags: added: verification-done
removed: verification-needed

The verification of the Stable Release Update for gtk+3.0 has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.10.8-0ubuntu1.2

---------------
gtk+3.0 (3.10.8-0ubuntu1.2) trusty; urgency=medium

  [ Iain Lane ]
  * Update Vcs-Bzr to a trusty branch.

  [ William Hua ]
  * Take upstream git-menu-binding-emit-submenu-close-after-activate.patch:
    - Ensures that menu item activations occur before GMenuModel
      submenu-action state changes (LP: #1208019)
 -- William Hua <email address hidden> Mon, 28 Jul 2014 15:56:01 +0100

Changed in gtk+3.0 (Ubuntu Trusty):
status: Fix Committed → Fix Released
murzzz (murzzz) wrote :

Also can confirm that proposed package fixed problem

Changed in unity-gtk-module (Ubuntu Trusty):
status: Fix Committed → Fix Released
Mathew Hodson (mathew-hodson) wrote :

unity-gtk-module is still in -proposed and has not been moved to -updates yet. unity-gtk-module should still be marked Fix Committed for trusty.

MV (mvidal) wrote :

Hi

Eclipse Mars on future Ubuntu Wily Werewolf

Sorry guys ... not the same bug but we have trouble with eclipse sub menus

Hopefully that can be solved with :

UBUNTU_MENUPROXY=0

I fulfilled this bug report :

https://bugs.launchpad.net/ubuntu/+source/unity-gtk-module/+bug/1501340

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.