Ubuntu

LightDM does not use users wallpaper if not selected from default

Reported by Sledge Sulaweyo on 2012-05-01
46
This bug affects 11 people
Affects Status Importance Assigned to Milestone
unity-greeter (Ubuntu)
Undecided
Unassigned

Bug Description

In Ubuntu 12.04 LTS (1.2.1-0ubuntu1) the wallpaper of the user is not used as long as it's not the right resolution and located under /usr/share/backgrounds.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightdm (Ubuntu):
status: New → Confirmed
Jimmy Merrild Krag (beruic) wrote :

Could this be rooted in localized name for the Pictures folder?

I doubt it but i will test it out as soon as possible.

Jakob (jodsalz2000-launchpad) wrote :

If this doesn't work for you: Is your home directory encrypted? Which would mean that it isn't readable before logging in. That's why you have to move the image to for instance /usr/share/backgrounds.

link (silveryahoo) wrote :

I can confirm this bug and I'm using Ubuntu 12.04 x64.

affects: lightdm (Ubuntu) → unity-greeter (Ubuntu)

I'm no longer able to reproduce this issue. Neither had my path localized names nor is it in an encrypted area. It just works now with files that did not when i opened up the bug.

Robert Ancell (robert-ancell) wrote :

Closing as the reporter no longer has the issue, thanks for the bug report!

Changed in unity-greeter (Ubuntu):
status: Confirmed → Fix Released
Sam Mackness (smackness) wrote :

this seems to be affecting several of our users on 12.04 -- lightdm shows the user's wallpaper if it's one from the standard set but if they select an image from the pictures directory then lightdm just shows the defualt wallpaper.

Michael Tanner (thonixx) wrote :

I have nearly the same issue. A few weeks ago I fresh installed my computer and set my own wallpaper with two monitors. I did also a fresh install on my notebook and set my custom wallpaper but which worked fine. Just the computer had the issue.
So the bug still remains and I don't know how to enable the custom wallpaper in lightdm.

Aibara Iduas (aibaraiduas) wrote :

LightDM will display the user added wallpaper (at any resolution I believe) - but only if it has permission to read the file (i.e. the relevant folders and file both allow "Others" read access). I had problems with this since even though my Pictures folder and image were readable, a subfolder therein was not. While this makes sense, I assume the default behavior should be more user-friendly: if a user adds a background image, LightDM will also display it.

I found this behavior both on a computer upgraded from Natty and one with a fresh Precise install.

Michael Tanner (thonixx) wrote :

It is bug as lightdm should copy the wallpaper to a readable directory. I had an encrypted home and forget about it, that was my fault. But I still think that this should be handled more properly as it could be copied to another directory - just for lightdm.

Michael Tanner (thonixx) wrote :

I did not want to say that this is bug and it would be the proper behaviour, it is more a feature request to do the copy process.

Dario Bertini (berdario) wrote :

I found out that actually (on top of the other possible requirements), at least in 13.04, lightdm doesn't pick up the custom wallpaper, even if the folder is a subfolder of ~/Pictures

I created this new bug: https://bugs.launchpad.net/ubuntu/+source/unity-greeter/+bug/1176447
since this has been erroneously marked as fixed

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers