No way to disable start-up sound using GUI

Bug #949782 reported by Jonathan Davies on 2012-03-08
This bug affects 76 people
Affects Status Importance Assigned to Milestone
Unity Greeter
Fix Released
unity-control-center (Ubuntu)
unity-greeter (Ubuntu)
Unity Greeter Development Team
Unity Greeter Development Team

Bug Description

There doesn't appear to be a way to disable the start-up sound when Unity Greeter first loads.

Related branches

Robert Ancell: Approve on 2012-04-17
Chris J Arges (arges) on 2012-03-16
Changed in unity-greeter (Ubuntu Precise):
assignee: nobody → Unity Greeter Development Team (unity-greeter-team)
tags: added: rls-p-tracking
tags: removed: rls-p-tracking
Ritesh Khadgaray (khadgaray) wrote :

Add a new settings sound-system-ready, and check if this is enabled before playing system sound.

The attachment "proposed patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
summary: - No way to disable lightdm start-up sound
+ No way to disable start-up sound
Changed in unity-greeter (Ubuntu Precise):
status: Triaged → Fix Committed
Changed in unity-greeter:
status: New → Fix Committed
importance: Undecided → Medium

Fixed in 0.2.8

Changed in unity-greeter:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-greeter - 0.2.8-0ubuntu1

unity-greeter (0.2.8-0ubuntu1) precise-proposed; urgency=low

  * New upstream release:
    - Add play-ready-sound option to control making a sound when the greeter
      loads (LP: #949782)
    - Add background-color option to set the background color before the
      background is rendered (LP: #969059)
    - some minor design fixups
  * debian/patches/ui-tweaks.patch:
    - Applied upstream
 -- Robert Ancell <email address hidden> Wed, 18 Apr 2012 17:21:34 +1000

Changed in unity-greeter (Ubuntu Precise):
status: Fix Committed → Fix Released
Tpugliese (thomas-pugliese) wrote :

I don't see an option for this in System Settings. How do I get to it?

Jonathan Davies (jpds) wrote :

@Tpugliese - it's not in System Settings, it's in dconf. You have to:

1. Ensure you have unity-greeter 0.2.8-0ubuntu1 installed

2. Creating a file called: /usr/share/glib-2.0/schemas/50_unity-greeter.gschema.override

3. Place in this file:

play-ready-sound = false

4. Run this command:

$ sudo glib-compile-schemas /usr/share/glib-2.0/schemas/

Log out and no sound should be played.

Tpugliese (thomas-pugliese) wrote :

hahaha. That's a good one. Seriously?

So the default behavior for an LTS release is going to be to play an annoying (and often very loud) drum sound on startup (and at every user switch), and when the user selects "No Effects" from the System Settings Sound menu, it won't actually honor that setting? On top of that, the only way to disable it is to create some cryptic config file that will be beyond the capabilities of many users? This has been a recurring usability issue for at least the past 4 releases. Every release, the login sound comes back and there is a new and more convoluted way to disable it.

Doug McMahon (mc3man) wrote :

Tpugliese - the option is now there, affected by different bug
Bug 981335

You can however turn the volume off when in the greeter screen which will work & be persistent

Jonathan Davies (jpds) wrote :

Tpugliese - the 'No Effects' option affects settings on a personal user level, not a system level (such as for example the start-up sound when you've logged in).

Tpugliese (thomas-pugliese) wrote :

Thanks for the tips, guys. Ranting aside, I appreciate the effort. My main source of frustration probably stems from the number of times I've run into this over the past few years. Each release, I have to google for an answer and most of the posts to the Ubuntu forums relate to earlier releases and the fixes are not applicable to the current release or current flavor of login manager (gdm, gdm2 or lightdm). Eventually a bug gets filed and a few weeks later, a solution is posted. I would guess that I've spent upwards of 15+ hours messing around with the various incarnations of this same issue when you add it all up. Each time it gets a little more frustrating.

I would like to point out that in prior releases (10.04 and earlier maybe?), when setting the "No Effects" option, the user was given the option to make the setting global and this did in fact disable the login sound. That's why I mentioned it in my prior comment. Also, my experience with turning the volume down on the login screen is that it not persistent. It seems to track to whatever setting the last logged in user set. I basically gave up and quit trying that so maybe it does work now. I'll test it out and file a separate bug report if that is still the case.

Philipp (sacridex) wrote :

Added my branch, pls review it.
It uses a config file instead of GSettings(easier to change values) and it also fixes bug #970024.

Stefano Forli (ntropia) wrote :

+1 Tpugliese
It seems a lack of planning when adding 'features'...

Oleg Cherkasov (o1e9) wrote :

It seems ubuntu-tweak has an option to disable login sound so it is more user friendly then compile glib schemas. Have not tried it yet myself but it shall work.

this is defenitly not solved. theres still no user configurable option.

is it really that difficult to add a checkbox in sound settings to set a dconf key?

Stuart Bishop (stub) wrote :

Linked to unity-control-center for a checkbox and user happiness.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-control-center (Ubuntu Precise):
status: New → Confirmed
Changed in unity-control-center (Ubuntu):
status: New → Confirmed
Robert Ancell (robert-ancell) wrote :

I've marked precise as "wont fix" since it seems very unlikely that a fix would be backported that far. It's certainly desirable for this feature to exist, though there are some technical difficulties in the way gsettings / unity-greeter work.

Changed in unity-control-center (Ubuntu Precise):
status: Confirmed → Triaged
Changed in unity-control-center (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
Changed in unity-control-center (Ubuntu Precise):
importance: Undecided → Medium
status: Triaged → Won't Fix
summary: - No way to disable start-up sound
+ No way to disable start-up sound using GUI
description: updated
Eric Ongerth (ericongerth) wrote :

In case anyone else finds this bug before a solution, I believe it's possible to turn down or mute the volume on the greeter screen and the setting will be persistent. There was a bug with this but it's reported fixed.

Gunnar Hjalmarsson (gunnarhj) wrote :

Couldn't gnome-session-canberra be changed from a depend to a recommend in ubuntu-desktop? That way those users who prefer silence could simply remove the package.

Take a look at this screenshot, comparing Ubuntu 15.04 to Windows 7 (regarding Sound Effects):

Notice that Windows 7 simply has a check box for "Play . . . Startup Sounds", and you don't have to install a 3rd party tweak-tool to achieve this.

Ubuntu's built-in Sound-Effects-settings menu has absolutely no functionality (as seen in the screenshot above).

You cannot:
1) Change any sound effects
2) There is no list of events to associate sound effects with.

tags: added: vivid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers