orca reads the password out loud

Bug #944159 reported by Alan Bell on 2012-03-01
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ORCA
Undecided
David Murphy
unity-greeter (Ubuntu)
High
Michael Terry
Quantal
High
Michael Terry

Bug Description

the password widget should have ATK role set to ROLE_PASSWORD_TEXT which will cause screen readers to avoid reading the password out loud to passers by
http://developer.gnome.org/atk/stable/AtkObject.html#AtkRole

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity-greeter 0.2.4-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
ApportVersion: 1.93-0ubuntu2
Architecture: amd64
Date: Thu Mar 1 17:23:59 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120217)
SourcePackage: unity-greeter
UpgradeStatus: No upgrade log present (probably fresh install)

Alan Bell (alanbell) wrote :
tags: added: a11y
Changed in unity-greeter (Ubuntu):
status: New → Triaged
importance: Undecided → High
Changed in unity-greeter:
status: New → Triaged
importance: Undecided → High
assignee: nobody → Luke Yelavich (themuso)

Digging into this some, it seems that the widget already has the correct accessible role. The bug is that something in unity greeter is causing the Orca splash screen to not be suppressed. As a result, the splash screen appears, goes away, and nothing in the greeter reclaims focus. So Orca doesn't know it's in the object with ROLE_PASSWORD_TEXT. When I disabled the splash screen, Orca does not echo the keys when the password is typed.

The good news is that it is my understanding that Luke already has a patch proposed to solve the splash-screen suppression bug, so this bug should just go away when that fix is committed.

Alan Bell (alanbell) wrote :

video of it reading the password out loud http://www.youtube.com/watch?v=biJRwpcJBa8

Alan Bell (alanbell) wrote :

this appears to be fixed now in the latest updates

Changed in unity-greeter:
status: Triaged → Fix Released
Changed in unity-greeter (Ubuntu):
status: Triaged → Fix Released

Hy Alan,

Unfortunately I doesn't see any change my installed system, I installed
all updates.
When the login screen presenting, Orca only spokening "Welcome to Orca.
Login frame" message. When I typing the default selected user password,
Orca spokening the password characters, not asterisk simbols.
Of course, when I press a TAB and a SHIFT+TAB key combination, or press
a down arrow key, password entry field are Orca detected.
I using unity-greeter 0.2.7-0ubuntu1 packaged version.

My /etc/lightdm/lightdm.conf file have following contents:
[SeatDefaults]
xserver-layout=hu
greeter-session=unity-greeter
user-session=gnome-fallback

Need I changing any setting in Unity Greeter, or my experienced issue is
a different bug with are not resolved yet?

Attila

Alan Bell (alanbell) wrote :

just done a fresh install of 12.04 daily and booted up and it reads out my password.

Changed in unity-greeter (Ubuntu):
status: Fix Released → Confirmed
Changed in unity-greeter:
status: Fix Released → Confirmed
Alan Bell (alanbell) wrote :

tabbing to the sessions option button then back again and it reads out asterisks rather than my password, but just booting from scratch and typing it reads out the letters.

Gema Gomez (gema) wrote :

This is happening to me with Quantal Beta 2 image as well (20120916)

tags: added: quantal rls-q-incoming
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/944159

tags: added: iso-testing
Changed in unity-greeter (Ubuntu Quantal):
assignee: nobody → Michael Terry (mterry)
tags: removed: rls-q-incoming
Michael Terry (mterry) wrote :

I've pushed a workaround for this to quantal. It's not ideal, and not something I want to propose for upstreaming yet.

I think the real issue is that orca does not read the currently focused widget on startup. It only reads the current window. So in unity-greeter, it never "notices" that it's in a password prompt without a focus switch to wake it up. This looks like a bug to me, but maybe it's intentional. We have to talk to orca people.

We can poke orca into noticing the prompt. But orca never tells us when it's finished initializing, so we have to guess when to poke it. I've done it two ways: (1) wait a second after starting orca, then poke. Obviously racy. (2) Once the first key press happens after starting orca, poke. This is racy in a different way, in that orca might speak the first character entered before realizing it's in a password prompt. But at least the rest of the characters are hidden. And ideally, the first one-second-poke already solved it for us.

The real fix should be in orca. Either have it claim a bus name or have some way of signaling when it is ready to rock. Or just speak the current focused widget on startup.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-greeter - 12.10.4-0ubuntu4

---------------
unity-greeter (12.10.4-0ubuntu4) quantal; urgency=low

  * debian/patches/close-orca.patch:
    - Make turning off the screen reader work again, now that the --quit
      argument to orca was dropped.
  * debian/patches/do-not-read-password.patch:
    - Workaround an orca problem where it doesn't notice the currently
      focused widget on startup. With this fix, it will no longer read
      your password as you type it. LP: #944159
 -- Michael Terry <email address hidden> Sun, 07 Oct 2012 17:12:31 -0400

Changed in unity-greeter (Ubuntu Quantal):
status: Confirmed → Fix Released
Attila Hammer (hammera) wrote :

Hy Michael,

Possible doing similar fixes with Ubuntu 12.04 awailable Unity-greeter
package? Random time if screen reader support enabled in login screen
Orca exiting, and only two CTRL+S keystroke to possible restart the
screen reader. I not found now what bug report I reported this issue,
but oldest time in Ubuntu Accessibility and Orca list lot of users
confirmed this issue.

In latest Quantal awailable unity-greeter package following patches are
applied, I think this patches not compatible with unity-greeter
0.2.8-0ubuntu1.2 precise-updates repository awailable version:
   * debian/patches/close-orca.patch:
     - Make turning off the screen reader work again, now that the --quit
       argument to orca was dropped.
   * debian/patches/do-not-read-password.patch:
     - Workaround an orca problem where it doesn't notice the currently
       focused widget on startup. With this fix, it will no longer read
       your password as you type it. LP: #944159

Attila

Luke Yelavich (themuso) wrote :

THis work-around could be backported to precise, but I am of the opinion that we should work out a proper fix, which can then be backported, the reason being less SRU testing and verification, and it is a work-around after all.

no longer affects: unity-greeter
David Murphy (dnamurphy) wrote :

Please raise this in gnome-orca. This is not orca-reader - sorry! (I'm not sure how I would migrate this bug to that project - let me know if it needs to be done)

Changed in orca:
status: New → Opinion
assignee: nobody → David Murphy (dnamurphy)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers