Don't allow starting programs via the greeter indicators

Bug #811853 reported by Hernando Torque on 2011-07-17
42
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Indicator Date and Time
Fix Released
Undecided
Michael Terry
Session Menu
Fix Released
Undecided
Michael Terry
The Sound Menu
Fix Released
Undecided
Michael Terry
Unity Greeter
Fix Released
Undecided
Michael Terry
indicator-power
Fix Released
Undecided
Michael Terry
unity-greeter (Ubuntu)
Undecided
Unassigned

Bug Description

Sound indicator:
 * Can start Banshee
 * Can enter sound settings

Date indicator:
 * Can enter time settings

Session indicator:
 * Can enter lots of settings
 * Additionally, can do some things like switching users and logging out that don't make sense

The solution I'm thinking of right now is to have some environment variable like INDICATOR_GREETER_MODE that when set, changes the behavior of the greeters.

Related branches

Hernando Torque (htorque) wrote :
Jeremy Bicha (jbicha) on 2011-07-19
Changed in unity-greeter (Ubuntu):
status: New → Confirmed
Michael Terry (mterry) on 2011-08-03
Changed in unity-greeter:
assignee: nobody → Michael Terry (mterry)
summary: - Don't allow starting music players via the sound indicator
+ Don't allow starting programs via the indicators
description: updated
Michael Terry (mterry) on 2011-08-03
summary: - Don't allow starting programs via the indicators
+ Don't allow starting programs via the greeter indicators
Michael Terry (mterry) on 2011-08-03
Changed in indicator-session:
assignee: nobody → Michael Terry (mterry)
status: New → In Progress
Changed in unity-greeter:
status: New → In Progress
Changed in indicator-sound:
assignee: nobody → Michael Terry (mterry)
status: New → In Progress
Michael Terry (mterry) on 2011-08-03
Changed in indicator-datetime:
assignee: nobody → Michael Terry (mterry)
status: New → In Progress
Michael Terry (mterry) on 2011-08-03
Changed in indicator-power:
assignee: nobody → Michael Terry (mterry)
status: New → In Progress
Conor Curran (cjcurran) on 2011-08-10
Changed in indicator-sound:
status: In Progress → Fix Committed
milestone: none → 0.7.5
Conor Curran (cjcurran) on 2011-08-10
Changed in indicator-session:
milestone: none → 0.3.1
status: In Progress → Fix Committed
Conor Curran (cjcurran) on 2011-08-10
Changed in indicator-session:
status: Fix Committed → Fix Released
Changed in indicator-sound:
status: Fix Committed → Fix Released
Ted Gould (ted) on 2011-08-11
Changed in indicator-datetime:
status: In Progress → Fix Committed
milestone: none → 0.2.92
Javier Jardón (jjardon) on 2011-08-11
Changed in indicator-power:
status: In Progress → Fix Committed
Ted Gould (ted) on 2011-08-11
Changed in indicator-datetime:
status: Fix Committed → Fix Released
Michael Terry (mterry) on 2011-08-15
Changed in unity-greeter:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-greeter - 0.0.2-0ubuntu3

---------------
unity-greeter (0.0.2-0ubuntu3) oneiric; urgency=low

  * debian/patches/update_to_trunk.patch:
    - backport the 3 commits which went to the vcs since the current version
    - Setup indicators to run in greeter mode (lp: #811853)
 -- Sebastien Bacher <email address hidden> Fri, 19 Aug 2011 11:01:32 +0200

Changed in unity-greeter (Ubuntu):
status: Confirmed → Fix Released
Changed in unity-greeter:
status: Fix Committed → Fix Released
Javier Jardón (jjardon) on 2011-08-24
Changed in indicator-power:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers