Cat causes login screen to hang

Bug #1538615 reported by Sarah Sharp on 2016-01-27
94
This bug affects 36 people
Affects Status Importance Assigned to Milestone
unity-greeter (Ubuntu)
Medium
Unassigned
Trusty
Medium
Unassigned

Bug Description

Steps to reproduce:

1. Leave laptop unattended in a cold room with a warm cat.
2. Cat will sit on laptop keyboard.
3. Wait 1 hour.
4. Lightdm will become unresponsive.

Symptoms:

Due to excessive password input by cat, lightdm acts oddly. I try to hit enter to try the invalid password and then type in the correct password, but enter has no affect. The cursor is not blinking, and hitting backspace has no effect. Using Ctrl+a or using shift+Ctrl+left arrow doesn't select the whole password to delete it. Hitting capslock causes the warning symbol to appear or disappear. The mouse moves, but clicking on the settings icon, date, sound icon, or language icon has no effect. One person suggested seeing if the cat had triggered scroll lock, but toggling between ctrl+q and ctrl+s had no effect. Logging in on a virtual terminal still works.

Alternative steps to reproduce if cat is unavailable or uncooperative about being placed on keyboard (see attached pictures):
0. Glare at cat.
1. Restart lightdm.
2. Log in as a normal user.
3. Lock screen with ctrl+alt+l (I'm running Ubuntu 15.10).
4. Weigh self. Weigh self + cat. Find books approximately equal to 10 lbs, and various household items to simulate cat paws (I used two large nail clippers, a fat key, and a bottle opener).
5. Put items on keyboard, avoiding function keys, backspace, and enter. Place books on top of household items.
6. Wait 1 hour.

Related branches

Sarah Sharp (sarah-b) wrote :
Sarah Sharp (sarah-b) wrote :
Sarah Sharp (sarah-b) wrote :
Sarah Sharp (sarah-b) wrote :

The Ubuntu 15.10 lightdm package version is 1.16.6-0ubuntu1

Sarah Sharp (sarah-b) wrote :

If you find the bug, please put a "Suggested-by: Miss Elisa Sharp" in the patch body. One could claim the cat was unintentionally finding bugs, but I'm pretty sure she's a furry security researcher in disguise. She has managed to send email from an unlocked laptop before.

Sarah Sharp (sarah-b) wrote :

Optionally, it would be great to have a "GTO Cat!" lightdm feature to beep in an extremely annoying way when excessive password input is detected.

Clint Byrum (clint-fewbar) wrote :

s/beep/hiss/

Jeremy (jermops) wrote :

Possible workaround? Train cat to also lay on Enter/Return key.

affects: lightdm → unity-greeter
summary: - Cat causes lightdm to hang
+ Cat causes login screen to hang
Denis Dupeyron (calchan) wrote :

Tried to reproduce using a PDF of "Analysis and Design of Analog Integrated Circuits, 5th Edition" loaded on a micro-SD card. Did not work. Added the entire Project Gutenberg archives on micro-SD card, still did not work. Please advise.

Robert Ancell (robert-ancell) wrote :

Sounds like the input field should limit the number of characters to something reasonable.

Nelson Castillo (nelsoneci) wrote :

I switched someone to Ubuntu 15.10 and she left something above the keyboard. This is the first time that her computer crashes with Ubuntu and I think it's because of this issue. A big string of asterisks is shown in the password field and they cannot be erased or selected.

Nelson Castillo (nelsoneci) wrote :

BTW, I was laughing when I first read this bug a few days ago. Karma exists :-)

Changed in unity-greeter:
importance: Undecided → Medium
status: New → Triaged
Changed in unity-greeter (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
no longer affects: unity-greeter
Changed in unity-greeter (Ubuntu Trusty):
status: New → Triaged
importance: Undecided → Medium
Robert Ancell (robert-ancell) wrote :

Please ask Miss Elisa Sharp to confirm if this fixes the issue and then we can SRU back to Trusty.

Adam Conrad (adconrad) wrote :

Just an aside, both this bug and the one I duped to it mention Ctrl-Alt-L in the reproduction steps, which would be the unity lock screen, not lightdm, right? Or do they both use the same unity-greeter theme and, thus, will both benefit from the 200 char limit?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-greeter - 16.04.2-0ubuntu1

---------------
unity-greeter (16.04.2-0ubuntu1) xenial; urgency=medium

  * New upstream release:
    - Limit prompt fields to 200 characters (LP: #1538615)

 -- Robert Ancell <email address hidden> Thu, 24 Mar 2016 14:03:38 +1300

Changed in unity-greeter (Ubuntu):
status: Triaged → Fix Released
piotrekkr (piotrekkr) wrote :

Ok. This bug should be reopened. My lock screen was frozen few times in last months by a cleaning lady who put my headphones on keyboard when cleaning my desk, and left them until next morning. Lock screen is frozen and keyboard or mouse actions do nothing. I wrote about it on https://askubuntu.com/questions/1121906/how-to-prevent-cleaner-from-hanging-my-lock-screen-in-ubuntu-16-04

I have version with this "fix" but it does not work.

$ apt policy unity-greeter
unity-greeter:
  Installed: 16.04.2-0ubuntu1
  Candidate: 16.04.2-0ubuntu1
  Version table:
 *** 16.04.2-0ubuntu1 500
        500 http://pl.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
        100 /var/lib/dpkg/status

Gerhard Gonter (gg-lp) wrote :

I also experience the same problem, cat sleeping on keyboard instead of nearby cushion, causing the login screen to lock up or hang on two Ubuntu 18.04 machines. With the desktop machine, unplugging and reattaching the USB keyboard helped, but this is not an option on my laptop which is also affected by the same cat or bug. Btw, hissing sounds do not help either.

$ apt policy unity-greeter
unity-greeter:
  Installed: 18.04.0+18.04.20180314.1-0ubuntu2
  Candidate: 18.04.0+18.04.20180314.1-0ubuntu2
  Version table:
 *** 18.04.0+18.04.20180314.1-0ubuntu2 500
        500 http://at.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status

flat (classic-forests) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers