indicator menus are misplaced when the display scaler is used

Bug #1434094 reported by Timo Aaltonen on 2015-03-19
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
GTK+
Fix Released
Medium
unity-greeter (Ubuntu)
High
Unassigned
unity-settings-daemon (Ubuntu)
Undecided
Unassigned

Bug Description

I have a system with a high-res panel, and the recent update to u-s-d makes it scale the login screen. With it though, the indicator menus are misplaced in the greeter.

Related branches

Timo Aaltonen (tjaalton) wrote :

misplaced so that the right edge of the menus is aligned with the middle of the screen

Sebastien Bacher (seb128) wrote :

Hey robert, could you have a look to this? It's easy to reproduce, just run unity-greeter with GDK_SCALE=2 (I replaced the binary with a shell script setting the env and calling the rename command to test).

It looks like the coordinates are off by the scale factor for indicators

Changed in unity-greeter (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
importance: Undecided → High
status: New → Confirmed
Changed in unity-greeter (Ubuntu):
status: Confirmed → Triaged
Robert Ancell (robert-ancell) wrote :

Can reproduce but haven't worked out which part of the code is doing this. I suspect it's due to us overriding the position of the menubar but it not being aware of this when popup menus are created.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-settings-daemon - 15.04.1+15.04.20150408-0ubuntu1

---------------
unity-settings-daemon (15.04.1+15.04.20150408-0ubuntu1) vivid; urgency=medium

  [ Sebastien Bacher ]
  * Don't scale under unity-greeter, it creates issues. That can be
    revisited once bug #1286878 and #1434094 are resolved but that's not
    going to be for this cycle (LP: #1434094, #1286878)
 -- CI Train Bot <email address hidden> Wed, 08 Apr 2015 14:46:48 +0000

Changed in unity-settings-daemon (Ubuntu):
status: New → Fix Released
tags: added: rls-w-incoming
Changed in unity-greeter (Ubuntu):
assignee: Robert Ancell (robert-ancell) → nobody
tags: added: rls-x-incoming
removed: rls-w-incoming
William Hua (attente) wrote :

Looks like an upstream GTK+ bug. In the X11 implementation that gets the size of the work area, the screen width and height are divided by the scale factor, but those values are already scaled down. So the screen size is halved again, causing the menus to get pushed into the top-right quadrant of the screen.

William Hua (attente) wrote :

Top-left I mean...

William Hua (attente) on 2016-02-02
affects: unity-greeter → gtk
Changed in gtk:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in gtk:
status: Confirmed → Fix Released
Will Cooke (willcooke) on 2016-02-15
tags: removed: rls-x-incoming
Sebastien Bacher (seb128) wrote :

the issue was a GTK one and got fixed, closing the unity-greeter side

Changed in unity-greeter (Ubuntu):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.