Doesn't scale well on a hidpi display

Bug #1286878 reported by Owais Lone on 2014-03-02
128
This bug affects 22 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
High
Unassigned
unity-greeter (Ubuntu)
Medium
Stephen M. Webb
Xenial
Medium
Stephen M. Webb
unity-settings-daemon (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned

Bug Description

unity-greeter does not scale on hidpi diplays like the rest of unity does in trusty.

Related branches

Adolfo Jayme (fitojb) on 2014-03-16
affects: unity-greeter → unity-greeter (Ubuntu)
Changed in unity-greeter (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Robert Ancell (robert-ancell) wrote :

Stephen - was there any design for hidpi and greeter? Do we just double the grid past a certain resolution?

Changed in unity-greeter (Ubuntu):
assignee: nobody → Stephen M. Webb (bregma)

I think it should just follow unity's per monitor scale ratio setting.

On Monday, 17 March 2014, Robert Ancell <email address hidden> wrote:

> Stephen - was there any design for hidpi and greeter? Do we just double
> the grid past a certain resolution?
>
> ** Changed in: unity-greeter (Ubuntu)
> Assignee: (unassigned) => Stephen M. Webb (bregma)
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1286878
>
> Title:
> Doesn't scale well on a hidpi display
>
> Status in “unity-greeter” package in Ubuntu:
> Triaged
>
> Bug description:
> unity-greeter does not scale on hidpi diplays like the rest of unity
> does in trusty.
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/unity-greeter/+bug/1286878/+subscriptions
>

--
Sent from Gmail Mobile

Stephen M. Webb (bregma) wrote :

Using the the per-monitor scaling setting of the currently logged in use doesn't make a lot of sense in the greeter, because there is no logged in user.

The only sensible thing is a best-guess attempt, knowing that hardware has a tendency to lie about its specs.

Owais Lone (loneowais) wrote :

LightDM scales perfectly on my MBPro after I resume from suspend. However, it does not scale at all on first boot. If I close the lib of the laptop once and open it, Unity greeter waits for me in full HiDPI glory.

Owais Lone (loneowais) wrote :

BTW I'm running 14.10 with all packages upgraded

Owais Lone (loneowais) wrote :

I was wrong. It has nothing to do with suspend-resume. Lightdm scales properly right after I login to Unity. Logging into the unity session and locing the screen shows properly scaled lightdm.

Is there a way to set the DPI for lightdm somewhere so it scales on first boot as well?

maxiclo (maxiclo) wrote :

I'm running 14.10 with all packages upgraded and the issue is still present.

Shih-Yuan Lee (fourdollars) wrote :

Hi,

I made a patch for unity-settings-daemon that can detect the HiDPI display and change the scale factor automatically.
However the unity-greeter itself doesn't work well when the scale factor is 2.
The patch I made is for Bug #1382291 originally.
https://bugs.launchpad.net/oem-priority/+bug/1382291/+attachment/4254190/+files/hidpi_display.patch

Shih-Yuan Lee (fourdollars) wrote :

I made this patch and it can fix the problem.
Please help to review it, thanks in advance.

The attachment "hidpi_support.patch" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Shih-Yuan Lee (fourdollars) wrote :

I have revised the patch to wait for the xsettings plugin of unity-settings-daemon.

Bruce.Ma (bruce.ma) wrote :

The hidpi_support.patch works well with kittyhawk2-trusty-amd64-20150127-0 on Mystique-2-3.

Changed in oem-priority:
importance: Undecided → High
Bruce.Ma (bruce.ma) wrote :

Merged Shih-Yuan's patch to the packages of trusty. And uploaded the code to lp.

$ bzr push lp:~oem-solutions-group/kittyhawk/unity-greeter.lp1286878
Created new branch.

$ bzr push lp:~oem-solutions-group/kittyhawk/unity-settings-daemon.lp1382291
Created new branch.

$ bzr push lp:~oem-solutions-group/kittyhawk/ubiquity.lp1382291
Created new branch.

Bruce.Ma (bruce.ma) wrote :

Merged Shih-Yuan's patch to newest code from vivid. And uploaded the code to lp.
$ bzr push lp:~bruce.ma/vivid/unity-greeter.lp1286878
Created new branch.

Bruce.Ma (bruce.ma) wrote :

I don't have the permission to propose a merging to lp:unity-greeter.
 Who can help me to do that ?

Bruce.Ma (bruce.ma) wrote :

I already proposed a merging from lp:~bruce.ma/unity-greeter/support-hidpi-lp1286878 to lp:unity-greeter , waiting to review.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-settings-daemon (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Review seems to be ongoing on the merge proposals, unsubscribing sponsors from the bug, no need to have that as well in the queue

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-settings-daemon - 15.04.1+15.04.20150318-0ubuntu1

---------------
unity-settings-daemon (15.04.1+15.04.20150318-0ubuntu1) vivid; urgency=medium

  [ Ryan Tandy ]
  * Don't call XSyncQueryCounter with a null counter. Avoids a crash
    under FreeNX/X2Go which don't support the IDLETIME counter. (LP:
    #1416081)

  [ Sebastien Bacher ]
  * Open the battery info dialog when using the corresponding hotkey.
    The current code was trying to display a notification with the info
    but we don't have design on how that should look like with notify-
    osd so go back to what we were doing before (LP: #1432976)
  * Restore code that set the scaling factor according the screen dpi,
    but only when not under and Unity session. That was desactived in
    r4020 because Unity is handling those values, but this is not the
    case under ubiquity or unity-greeter. (LP: #1286878)
 -- CI Train Bot <email address hidden> Wed, 18 Mar 2015 12:07:44 +0000

Changed in unity-settings-daemon (Ubuntu):
status: Confirmed → Fix Released
Alessio Treglia (quadrispro) wrote :

Hi,

any news on unity-greeter?

arty (me-arty) wrote :

I have unity-settings-daemon 15.04.1+15.04.20150408-0ubuntu1 and I see the bug

I am experiencing the same bug on a Dell XPS 13.

Radics Ottó (saboteur777) wrote :

I am experiencing the bug on XPS 15 9530 4K.

1) Login screen is not scaled properly, should this resolve login screen scaling?
2) Locking the screen goes well, I get the correctly scaled lightdm screen.

Marcus (marcus-hewat) wrote :

I am experiencing this bug with a desktop with 24 inch 3840x2160 monitor. i use a scale of 2 in Unity.
Login screen text is tiny but lock screen is fine.

Petro (petrochemicals) wrote :

Is there nay update on this fix? Been months now and will be going on three releases since its been reported that it has not been fixed. Gnome has had this working for their greeter for ages, why can't Ubuntu seem to solve it?

maxiclo (maxiclo) wrote :

Is there any update on this fix?
A lot of new notebooks has hidpi screen.

This make this software obsolete.

Please fix.

tags: added: rls-w-incoming
Will Cooke (willcooke) on 2015-10-16
tags: added: u7-import-trello
Will Cooke (willcooke) on 2015-10-16
tags: removed: u7-import-trello
Alessio Treglia (quadrispro) wrote :

Hi! Any news on this?

Sebastien Bacher (seb128) wrote :

It's on the list for next cycle, if somebody wants to help and debug bug #1434094 that would be useful though

tags: added: rls-x-incoming
removed: rls-w-incoming
Will Cooke (willcooke) on 2016-02-15
tags: removed: rls-x-incoming
Ara Pulido (ara) on 2016-05-19
Changed in oem-priority:
status: New → Fix Released
no longer affects: oem-priority/trusty
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers