hotkeys for keyboard layout switching do not work in unity-greeter in Trusty, Wily and Xenial

Bug #1245137 reported by Norbert on 2013-10-27
302
This bug affects 72 people
Affects Status Importance Assigned to Milestone
unity-greeter (Ubuntu)
Low
Unassigned

Bug Description

On clean Ubuntu 13.10 install with enabled proposed updates Super+Space and Shift+Super+Space are default options for keyboard layout change.
But they do not work in Unity greeter.
----------
For other layout switching problems introduced in Ubuntu 13.10 you can see bug 1218322.
----------

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: unity-greeter 13.10.3-0ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-13.20-generic 3.11.6
Uname: Linux 3.11.0-13-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 2.12.5-0ubuntu2.1
Architecture: i386
Date: Sun Oct 27 12:43:18 2013
InstallationDate: Installed on 2013-10-20 (6 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release i386 (20131016.1)
MarkForUpload: True
SourcePackage: unity-greeter
UpgradeStatus: No upgrade log present (probably fresh install)

Norbert (nrbrtx) wrote :
Norbert (nrbrtx) wrote :

Installed packages from ppa:attente/1218322
(
gnome-control-center 3.6.3-0ubuntu45ppa1
gnome-control-center-data 3.6.3-0ubuntu45ppa1
libgnome-control-center1 3.6.3-0ubuntu45ppa1
)
bug still here.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-greeter (Ubuntu):
status: New → Confirmed
Norbert (nrbrtx) on 2013-10-29
description: updated
Changed in unity-greeter (Ubuntu):
importance: Undecided → Low
Norbert (nrbrtx) on 2013-10-31
tags: added: keyboard-layout-switching-hotkeys
Sebastien Bacher (seb128) wrote :

Did switching layouts in the greeter, using the keyboard, worked in previous Ubuntu versions?

summary: - Super+Space and Shift+Super+Space hotkeys for keyboard layout switching
- do not work in unity-greeter in Saucy
+ hotkeys for keyboard layout switching do not work in unity-greeter in
+ Saucy

Yes, Sebastien. It used to work. I don't remember in which version of Ubuntu it stopped working.

Norbert (nrbrtx) wrote :

I made a clean install of Ubuntu 14.04 beta2 ( 4cf9e5ef2c1c362317c90312c76cfda0 *ubuntu-14.04-beta2-desktop-i386.iso).
The bug is still here.

Please fix it before final Ubuntu 14.04 release.

summary: hotkeys for keyboard layout switching do not work in unity-greeter in
- Saucy
+ Saucy and Trusty
Tamir (sugip) wrote :

Something is being done to fix this very unpleasant phenomena??

Axa-Ru (akhromov) wrote :

Оn Ubuntu 14.04 (unity) x64 the same.

Fedo (jonn-pasevish) wrote :

Yes, on Ubuntu 14.04 (unity) x64 and x86 bug confirmed.

Alex (alex-serpuxov) wrote :

Confirms bug on Trusty Ubuntu 14.04 (unity).

Valentin (valentin-putko) wrote :

Confirms on Ubuntu 14.04 unity.

Vitaliy (tsvitaliy) on 2014-04-03
Changed in unity-greeter (Ubuntu):
assignee: nobody → Vitaliy (tsvitaliy)
Norbert (nrbrtx) wrote :

Ubuntu 14.04 with all updates for today - bug exists. Please fix it as soon as possible.

JmAbuDabi (dambldor91) wrote :

I'm press Ctrl+Alt+T
and press any button or mouse button.

After Shift+Alt for change input source. And Source not changed. Click Mouse Left Button for icons Lang, source changed.

After input my password and sing in my system.

After Shitf+Alt Changed source. i.e. I can write any lang.

no longer affects: unity-greeter

The bug still present on 14.04 x64.
It's totally inconvenient to use the mouse or touchpad each time the screen is locked and the layout happens to be the wrong one.
Every time the updates come I keep hoping this issue is finally solved.

Simplehuman (simplehuman) wrote :

This problem is still actual for Ubuntu 14.10 x64

Wonka (dushman666) wrote :

Ubuntu 14.04 64x with all updates for today - bug exists.

Ubuntu 14.10 x86 beta2 - bug exists.

summary: hotkeys for keyboard layout switching do not work in unity-greeter in
- Saucy and Trusty
+ Saucy, Trusty and Utopic
tags: added: trusty utopic
Norbert (nrbrtx) on 2014-10-01
tags: removed: i386
Norbert (nrbrtx) wrote :

Bug exists in Ubuntu Utopic 14.10 final.

Bug exists in Ubuntu 15.04 beta2.

summary: hotkeys for keyboard layout switching do not work in unity-greeter in
- Saucy, Trusty and Utopic
+ Saucy, Trusty, Utopic and Vivid
tags: added: vivid
Norbert (nrbrtx) wrote :

Bug exist in Ubuntu 15.04 final in GNOME sessions.

Changed in unity-greeter (Ubuntu):
assignee: Vitaliy (tsvitaliy) → nobody
Norbert (nrbrtx) wrote :

Bug exist in Ubuntu 15.10 beta2 in GNOME sessions.

tags: added: wily

Bug exist in Ubuntu 15.10 final.

summary: hotkeys for keyboard layout switching do not work in unity-greeter in
- Saucy, Trusty, Utopic and Vivid
+ Saucy, Trusty, Utopic, Vivid and Wily
MrRomanze (mrromanze) wrote :

Still exist in 16.04 Alpha.

summary: hotkeys for keyboard layout switching do not work in unity-greeter in
- Saucy, Trusty, Utopic, Vivid and Wily
+ Saucy, Trusty, Utopic, Vivid, Wily and Xenial
tags: added: xenial

removed unsupported Ubuntu versions

tags: removed: saucy utopic vivid
summary: hotkeys for keyboard layout switching do not work in unity-greeter in
- Saucy, Trusty, Utopic, Vivid, Wily and Xenial
+ Trusty, Wily and Xenial
Simplehuman (simplehuman) wrote :

Tested this bug on full updated Ubuntu 16.04 x64 on VirtualBox and then on real hardware. And it seems to be fixed.
Tested hotkeys for keyboard layout switching was Ctrl+Shift, Alt+Shift and Shift+Tab.
So marking this bug as Invalid.

Changed in unity-greeter (Ubuntu):
status: Confirmed → Invalid
Simplehuman (simplehuman) wrote :

Hotkeys Super+Space and Shift+Super+Space are working too.

On my Ubuntu 16.04 x64 the bug is not fixed.

Alt+Shift still not working in unity-greeter - neither on boot, nor on switching users.

Pavel Dmitriev (dmitrievp) wrote :

On my Ubuntu 16.04 x32 the bug is not fixed.

Changed in unity-greeter (Ubuntu):
status: Invalid → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers