add network (nm-applet) to login screen

Bug #1240088 reported by Ritesh Khadgaray on 2013-10-15
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
network-manager-applet (Ubuntu)
Wishlist
Unassigned
Precise
Wishlist
Seyeong Kim
unity-greeter (Ubuntu)
Wishlist
Unassigned
Precise
Wishlist
Seyeong Kim

Bug Description

[Impact]
 * User has a hard time to login via network, (krb5) if nm-applet is not accessible via login screen.

[Test Case]
1) make sure the system is configure to authenticate via krb5
2) login with user "A" and disconnect from the network via nm-applet, logout
3) Try to login with user B

 a. Actual Results:
User B is not able to authenticate because the system is not connected to the network so we are not able to talk to the krb servers

 b. Expected Results:
Users should be able to use network manager from within unity greater and reconnect to the network before attempting to login.

[Regression Potential]
 * n/a . The patch is a backport from upstream

tags: added: precise
Changed in unity-greeter (Ubuntu Precise):
importance: Undecided → Wishlist
status: New → Triaged
Changed in unity-greeter (Ubuntu):
status: New → Fix Released
importance: Undecided → Wishlist
Sebastien Bacher (seb128) wrote :

Hey Michael, you wrote that patch, do you have any opinion on SRUing to precise?

@Ritesh: that's somewhat a feature/UI change, can you check with the SRU team if they are fine with that change in a SRU?

Michael Terry (mterry) wrote :

Seb, this patch looks like it would work technically. I do think it would need an SRU.

But... I believe we decided to delay adding this feature in precise for a reason? I think we should confirm with cyphermox.

Marc Deslauriers (mdeslaur) wrote :

NACK. This needs the unity-greeter policykit file so the network settings can't get modified at the login screen.
I believe network-manager also needs some modifications so the policykit permissions are properly enforced.

Ritesh Khadgaray (khadgaray) wrote :

backport of nm support in unity-greeter, along with pkla file.

Ritesh Khadgaray (khadgaray) wrote :

patch to nm-applet to work with unity-greeter

Robert Ancell (robert-ancell) wrote :

Marc - do you know if the updated patch is sufficient?

Ritesh - is your last comment missing a patch attachment? Should this bug be marked as also affecting network-manager?

Changed in network-manager-applet (Ubuntu):
status: New → Fix Released
Changed in network-manager-applet (Ubuntu Precise):
status: New → Triaged
importance: Undecided → Wishlist
Changed in network-manager-applet (Ubuntu):
importance: Undecided → Wishlist
Robert Ancell (robert-ancell) wrote :

I've updated Ritesh's work into a branch [1] and backported the nm-applet changes into another [2]. From my precise virtual machine I the network indicator shows and I don't seem to be able to do anything inappropriate.

It's quite a large amount of code backported and I'm not too familiar with the code so I'd like a review from Marc and Mathieu before proposing this for SRU.

[1] lp:~robert-ancell/unity-greeter/lp1240088
[2] lp:~robert-ancell/network-manager-applet/lp1240088

Changed in network-manager-applet (Ubuntu Precise):
status: Triaged → In Progress
Changed in unity-greeter (Ubuntu Precise):
assignee: nobody → Robert Ancell (robert-ancell)
status: Triaged → In Progress
Changed in network-manager-applet (Ubuntu Precise):
assignee: nobody → Robert Ancell (robert-ancell)
Seyeong Kim (xtrusia) wrote :

Thank you robert I tested your branch on precise and looks good

Do you have an update from Marc or Mathieu on code review for this?

Robert Ancell (robert-ancell) wrote :

No update from either.

Dave Chiluk (chiluk) on 2014-10-13
tags: added: cts

The changes look fine. It seems like there was a lot of patch refreshing on nm-applet when it probably shouldn't have been required; but the added patches are indeed those that are required to support showing nm-applet in the greeter.

Seyeong Kim (xtrusia) wrote :

Modified unity-greeter revision 4

because of the customer's feedback

"""
unity-greeter needs the "Breaks" bit in control file lowered from "network-manager-gnome << 2.4" to "network-manager-gnome << 2.3"
"""

Changed in network-manager-applet (Ubuntu Precise):
assignee: Robert Ancell (robert-ancell) → nobody
Changed in unity-greeter (Ubuntu Precise):
assignee: Robert Ancell (robert-ancell) → nobody
Changed in network-manager-applet (Ubuntu Precise):
status: In Progress → Triaged
Changed in unity-greeter (Ubuntu Precise):
status: In Progress → Triaged
Seyeong Kim (xtrusia) on 2014-10-30
Changed in unity-greeter (Ubuntu Precise):
status: Triaged → In Progress
Changed in network-manager-applet (Ubuntu Precise):
status: Triaged → In Progress
assignee: nobody → Seyeong Kim (xtrusia)
Changed in unity-greeter (Ubuntu Precise):
assignee: nobody → Seyeong Kim (xtrusia)
Chris J Arges (arges) wrote :

Can you fix the following issues and re-submit?

precise-unity-greeter:
dpkg-source: error: cannot read unity-greeter-0.2.9/debian/patches/show-nm-applet.patch: No such file or directory

precise-network-manager-applet:
Explain rebuild_menu_after_init refresh

You should ensure the debdiff can apply cleanly on the current precise-updates version and is buildable.
Thanks,

Seyeong Kim (xtrusia) wrote :
Seyeong Kim (xtrusia) wrote :
Chris J Arges (arges) wrote :

Sponsored unity-greeter/network-manager-applet for precise .

Sebastien Bacher (seb128) wrote :

seems it was sponsored, unsubscribing sponsors

Hello Ritesh, or anyone else affected,

Accepted unity-greeter into precise-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/unity-greeter/0.2.9-0ubuntu1.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity-greeter (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in network-manager-applet (Ubuntu Precise):
status: In Progress → Fix Committed
Brian Murray (brian-murray) wrote :

Hello Ritesh, or anyone else affected,

Accepted network-manager-applet into precise-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/network-manager-applet/0.9.4.1-0ubuntu2.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Seyeong Kim (xtrusia) wrote :

unity-greeter 0.2.9-0ubuntu1.5
network-manager-gnome 0.9.4.1-0ubuntu2.4

tags: added: verification-done
removed: verification-needed

The verification of the Stable Release Update for unity-greeter has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager-applet - 0.9.4.1-0ubuntu2.4

---------------
network-manager-applet (0.9.4.1-0ubuntu2.4) precise; urgency=medium

  * Backport support to show the applet in the greeter: (LP: #1240088)
  * debian/patches/hide_policy_items_env_var.patch:
  * debian/patches/make_menu_items_insensitive_based_on_permissions.patch:
    - Provide a method to desensitize or hide menu items which are useless given
      the current policykit policy level of the user.
  * debian/patches/lp1048516_dont_req_keyring_in_greeter.patch:
    - Don't try to load the keyring if the user has no permissions to edit their
      own connections.
  * debian/patches/lp1048520_delay_pin_dialog_in_greeter.patch:
    - Only ask for PIN entry when a connection is being established rather than
      when a modem is detected.
  * debian/patches/position_dialogs_to_center_of_the_screen.patch:
    - Position dialogs to the center of the screen.
 -- Seyeong Kim <email address hidden> Tue, 20 Jan 2015 11:07:05 -0600

Changed in network-manager-applet (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-greeter - 0.2.9-0ubuntu1.5

---------------
unity-greeter (0.2.9-0ubuntu1.5) precise; urgency=medium

  * Show network manager applet in greeter: (LP: #1240088)
  * debian/control:
    - Recommend network-manager-gnome version that supports working in greeter
  * debian/install:
  * debian/unity-greeter.pkla:
    - Install PolicyKit policy for unity-greeter
  * debian/patches/show-nm-applet.patch:
    - Show network manager applet
 -- Seyeong Kim <email address hidden> Tue, 20 Jan 2015 11:11:41 -0600

Changed in unity-greeter (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers