Ubuntu

[FFe] Allow custom indicators

Reported by Michael Terry on 2013-03-14
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity Greeter
Undecided
Unassigned
unity-greeter (Ubuntu)
Wishlist
Unassigned
Declined for Quantal by Scott Kitterman
Precise
Wishlist
Unassigned
Raring
Wishlist
Unassigned

Bug Description

[Impact]

  * Would allow system administrators to load custom indicators, and allow one to control the active user

[Impact]
 * This would improve the polish of unity greeter for kiosk/corporate deployment
 * This will allow admins to select the active entry on login screen ( such as with smart card)

[Test Case]
 * Edit dconf key "com.canonical.unity-greeter" using dconf-editor to load or not load existing indicator .

[Regression Potential]
 * I dont see any regression potential , as this unity-greeter is not linked by any other application and this only adds a bus method.
 * Worst case, user mis-configures (typo/invalid indicators) the indicators to load and ends up without them.

[Other Info]

 * https://lists.ubuntu.com/archives/technical-board/2013-May/001622.html

----------------------------------------------------------------------------------------

I'd like to upload a new unity-greeter to raring with a new feature. System administrators have been requesting the ability to add new custom indicators to the greeter. And to be able to control the greeter slightly with those indicators.

In trunk, we've added support for this in two ways:
 * Have the list of loaded indicators be controlled by a gsettings variable under the lightdm user, which system administrators can customize.
 * Add a session DBus interface to the greeter to allow switching which user is selected. This is only available to the greeter session bus, not on the system bus.

Note that these features are not used by default, they'd only be used if an administrator specifically chose to use them.

Is the greeter session bus used by default now?

Scott Kitterman (kitterman) wrote :

<mterry> ScottK, hello! I don't quite understand your question in bug
1155157
, could you explain?
<ubottu> bug 1155157 in unity-greeter (Ubuntu Raring) "[FFe] Allow custom
indicators" [Undecided,New] https://launchpad.net/bugs/1155157
<ScottK> mterry: I recall some discussion the other day on IRC about session
buses needing to be manually enabled. It may have been irrelevant, but my
question was are we already using a greeter session bus by default or does the
greeter normally use the system bus?
<mterry> ScottK, the greeter has a session bus already. I know because it
spawns some things that have used it. But it's never exposed an interface on
the bus before. That's new
<mterry> (things like indicators use it)

Scott Kitterman (kitterman) wrote :

Why didn't this land before feature freeze?

Michael Terry (mterry) wrote :

As I mentioned on IRC, and adding here for posterity:
The greeter has a session bus already. Things like the indicators use it. But the greeter's never exposed an interface on the bus before. That's new.

Michael Terry (mterry) wrote :

As for why it didn't land, no especially good reason. Between the lateness of the request from customers (it wasn't a known desire at UDS) and developers being busy, it landed only this week.

Jonathan Davies (jpds) on 2013-03-15
Changed in unity-greeter:
status: New → Incomplete
status: Incomplete → Fix Committed
Scott Kitterman (kitterman) wrote :

New features aren't, by policy, generally allowed post-release. After this is in the development series, which it's not yet, it should go to the TB for approval.

Scott Kitterman (kitterman) wrote :

For raring though, this seems low impact, off by default, and low risk, so FFe approved.

Changed in unity-greeter (Ubuntu Raring):
importance: Undecided → Wishlist
milestone: none → ubuntu-13.04-beta-2
status: New → Triaged
Michael Terry (mterry) on 2013-03-15
Changed in unity-greeter:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-greeter - 13.04.2-0ubuntu1

---------------
unity-greeter (13.04.2-0ubuntu1) raring; urgency=low

  * New upstream release.
    - Fix duplicate entries showing for multiple users on the same remote
      login service.
    - Add custom indicator support for system administrators (LP: #1155157)
  * debian/control:
    - Switch Vcs-Bzr to point at Unity Greeter trunk, since we are inlining
      the packaging
    - Use debhelper 9
  * debian/rules:
    - Use upstream ./autogen.sh for autoreconf
  * debian/patches/do-not-read-password.patch,
    debian/patches/move-nm-applet.patch,
    debian/patches/spawn-gsd-directly.patch:
    - Drop, included upstream
 -- Michael Terry <email address hidden> Fri, 15 Mar 2013 14:04:08 -0400

Changed in unity-greeter (Ubuntu Raring):
status: Triaged → Fix Released
Ritesh Khadgaray (khadgaray) wrote :
Michael Terry (mterry) wrote :

The tech board approved this SRU for precise:
https://lists.ubuntu.com/archives/technical-board/2013-May/001622.html

Subject to double confirming that there are no regressions.

description: updated
Changed in unity-greeter (Ubuntu Precise):
importance: Undecided → Wishlist
status: New → Triaged
Sebastien Bacher (seb128) wrote :

Thanks, I've sponsored the debdiff there

Changed in unity-greeter (Ubuntu Precise):
status: Triaged → In Progress

Hello Michael, or anyone else affected,

Accepted unity-greeter into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity-greeter/0.2.9-0ubuntu1.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity-greeter (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Ezio de Mauro (pancro) on 2013-07-02
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-greeter - 0.2.9-0ubuntu1.2

---------------
unity-greeter (0.2.9-0ubuntu1.2) precise; urgency=low

  * debian/patches/user_selection.patch:
    - Add custom indicator support for system administrators (LP: #1155157)
 -- Ritesh Khadgaray <email address hidden> Mon, 15 Apr 2013 10:47:46 +0530

Changed in unity-greeter (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers