Lightdm does not display correct resolution in multimonitor setup

Bug #1082952 reported by _dan_ on 2012-11-25
72
This bug affects 16 people
Affects Status Importance Assigned to Milestone
unity-greeter (Ubuntu)
Undecided
Unassigned

Bug Description

When a second Monitor is connected, lightdm displays wrong resolution (the one from the smaller) on the primary monitor.
I have one display with 1900x1200 and a secondary monitor with 1280x1024. When lightdm starts it gets displayed on both monitors with 1280x1024 which looks terrible on the primary instead of using the native resolution on both or only displaying on the primary.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: lightdm 1.4.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.5.0-18.29-generic 3.5.7
Uname: Linux 3.5.0-18-generic x86_64
ApportVersion: 2.6.1-0ubuntu6
Architecture: amd64
Date: Sun Nov 25 20:17:10 2012
MarkForUpload: True
SourcePackage: lightdm
UpgradeStatus: No upgrade log present (probably fresh install)

_dan_ (dan-void) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, does it happen if you use the gtk greeter? lightdm itself doesn't decide on resolution, it's either and xorg issue or a problem with gnome-settings-daemon in the unity-greeter

_dan_ (dan-void) wrote :

The same happens with the gtk greeter.

The problem here is, that lightdm/xorg mirrors the display per default (at least with intel drivers, not with nvidia tho), so on both monitors i see the lightdm login screen and with one monitor being lower resolution, the second monitor gets the lower resolution aswell, otherwise its not possible to mirror.
If the 2 Monitors would be the same resolution, it would be fine.

Console gets mirrored on both screens aswell with the bigger screen not utilized fully.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightdm (Ubuntu):
status: New → Confirmed
Richard Hansen (rhansen) wrote :

Changing affected package to unity-greeter (the login screen launched by lightdm) since lightdm itself doesn't do anything graphical.

affects: lightdm (Ubuntu) → unity-greeter (Ubuntu)
Richard Hansen (rhansen) wrote :

Workaround:
  1. log in
  2. use xrandr or the Displays control utility to configure your monitors how you'd like them to be configured in the login screen
  3. copy ~/.config/monitors.xml to /var/lib/lightdm/.config

_dan_ (dan-void) wrote :

Thanks for the workaround. Does the trick for me.

Rex Tsai (chihchun) on 2013-07-02
Changed in unity-greeter (Ubuntu):
status: Confirmed → Invalid
_dan_ (dan-void) wrote :

How is this invalid?

Changed in unity-greeter (Ubuntu):
status: Invalid → Confirmed
Rex Tsai (chihchun) wrote :

default using mirrored mode with lower resolution make sense and cover most of use cases.

What do you expect the system works?

_dan_ (dan-void) wrote :

Where do you get your "most" from? Mirrored mode makes sense if you give a presentation on your laptop, besides that i can not think of a single usecase.
Since when is it not a bug when it works on some maschines?

I would expect it to work to extend the display and have every display at max resolution and i would expect it to be configureable without chaning xml files manually.
Otherwise the first screen you see when you boot up ubuntu looks garbage and ppl think "iih ubuntu can not even handle my two monitors properly, windows can do it, macos can do it"

Steps to reproduce the issue:

Setting screen resolution, primary display and desktop mode to the desired values as well as screen positioning.
Setup is: Primary display: 1366x768, Secondary display: 1600x900, extended desktop, secondary display left of primary display.

Expected result: Lightdm and unity-greeter are using display setup by the user.

Actual result: Primary display is running with a resolution of 1024x768 with black borders left and right, while secondary display is running the same resolution (1024x768), streched. The displays are mirrored.

Notes: Workaround #6 does work for me. While my primary display is showing the login screen now, the secondary screen displays a Ubuntu logo.

Richard Hansen (rhansen) wrote :

> Notes: Workaround #6 does work for me. While my primary display is
> showing the login screen now, the secondary screen displays a Ubuntu
> logo.

That is how it is designed to work. When you move your mouse to the other screen the list of users will move to the other screen as well.

I have noticed that unity-greeter does not initially put the user list on the primary display (as indicated in monitors.xml), which is annoying. But that's a separate bug.

The workaround #6 didn't work for me because Ubuntu 12.04 doesn't have a /var/lib/lightdm/.config directory. Will it work if I create the directory?

Instead, I have managed to force multiple monitors correct resolutions for LightDM using the script suggested in:
http://askubuntu.com/questions/119843/how-to-force-multiple-monitors-correct-resolutions-for-lightdm

I've changed the script to accept either VGA, DP1, HDMI1 output connections.

Here's the script.
(I'm sorry if this is not the correct place to put this - but do tell me - I'm learning)

> I have noticed that unity-greeter does not initially put the user
> list on the primary display (as indicated in monitors.xml), which is
> annoying. But that's a separate bug.

For this bug fix is available here - https://code.launchpad.net/~albertsmuktupavels/unity-greeter/add-primary-monitor-support/+merge/202627

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers