onboard assert failure: python3: ../../src/xcb_io.c:528: _XAllocID: Assertion `ret != inval_id' failed.

Bug #1055698 reported by Michael Terry
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Unity Greeter
Fix Released
Undecided
Unassigned
unity-greeter (Ubuntu)
Undecided
Unassigned

Bug Description

I reliably get this after logging in with onboard enabled in the greeter.

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: onboard 0.98.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.5.0-15.22-generic 3.5.4
Uname: Linux 3.5.0-15-generic i686
ApportVersion: 2.5.2-0ubuntu4
Architecture: i386
AssertionMessage: python3: ../../src/xcb_io.c:528: _XAllocID: Assertion `ret != inval_id' failed.
Date: Mon Sep 24 14:37:46 2012
ExecutablePath: /usr/bin/onboard
ExecutableTimestamp: 1348023093
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110422)
InterpreterPath: /usr/bin/python3.2mu
ProcCmdline: /usr/bin/python3 /usr/bin/onboard --xid
ProcCwd: /var/lib/lightdm
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 6
SourcePackage: onboard
StacktraceTop:
 __assert_fail_base (fmt=0xb76a76d8 "%s%s%s:%u: %s%sAssertion `%s' failed.\n%n", assertion=0xb65bc179 "ret != inval_id", file=0xb65bc0ea "../../src/xcb_io.c", line=528, function=0xb65bc1fe <__PRETTY_FUNCTION__.14071> "_XAllocID") at assert.c:94
 __GI___assert_fail (assertion=assertion@entry=0xb65bc179 "ret != inval_id", file=file@entry=0xb65bc0ea "../../src/xcb_io.c", line=line@entry=528, function=function@entry=0xb65bc1fe <__PRETTY_FUNCTION__.14071> "_XAllocID") at assert.c:103
 _XAllocID (dpy=0xa136ba0) at ../../src/xcb_io.c:528
 XCreatePixmap (dpy=0xa136ba0, d=10486629, width=width@entry=76, height=height@entry=36, depth=32) at ../../src/CrPixmap.c:56
 _cairo_xlib_surface_create_similar (abstract_src=0xa949348, content=CAIRO_CONTENT_COLOR_ALPHA, width=76, height=36) at /build/buildd/cairo-1.12.2/src/cairo-xlib-surface.c:306
Title: onboard assert failure: python3: ../../src/xcb_io.c:528: _XAllocID: Assertion `ret != inval_id' failed.
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Related branches

Revision history for this message
Michael Terry (mterry) wrote :
Revision history for this message
Apport retracing service (apport) wrote :

StacktraceTop:
 __assert_fail_base (fmt=0xb76a76d8 "%s%s%s:%u: %s%sAssertion `%s' failed.\n%n", assertion=0xb65bc179 "ret != inval_id", file=0xb65bc0ea "../../src/xcb_io.c", line=528, function=0xb65bc1fe "_XAllocID") at assert.c:94
 __GI___assert_fail (assertion=assertion@entry=0xb65bc179 "ret != inval_id", file=file@entry=0xb65bc0ea "../../src/xcb_io.c", line=line@entry=528, function=function@entry=0xb65bc1fe "_XAllocID") at assert.c:103
 _XAllocID (dpy=0xa136ba0) at ../../src/xcb_io.c:528
 XCreatePixmap (dpy=0xa136ba0, d=10486629, width=width@entry=76, height=height@entry=36, depth=32) at ../../src/CrPixmap.c:56
 _cairo_xlib_surface_create_similar (abstract_src=0xa949348, content=CAIRO_CONTENT_COLOR_ALPHA, width=76, height=36) at /build/buildd/cairo-1.12.2/src/cairo-xlib-surface.c:306

Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : StacktraceSource.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
Changed in onboard (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Michael Terry (mterry)
visibility: private → public
Revision history for this message
marmuta (marmuta) wrote :

There is little we can do about this from Onboard's side, unfortunately. Something with the interaction between libcairo and libx11 seems to cause _XAllocID to fail. See bug #905686 and bug #507062.

However, the fact that you can reproduce the failure reliably may be of interest. Perhaps this can be a test case to finally figure out the cause. I was so far unable to reproduce this here, though, but these asserts seem more common on i386 systems like yours (see bug #954318) and I'm testing on x86_64.

I'll mark this as a duplicate of bug #905686 for now.

Revision history for this message
Michael Terry (mterry) wrote :

I'm unmarking as a dup because it can easily be worked around in unity-greeter and has been upstream.

no longer affects: onboard (Ubuntu)
Changed in unity-greeter:
milestone: none → 12.10.4
status: New → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-greeter - 12.10.4-0ubuntu1

---------------
unity-greeter (12.10.4-0ubuntu1) quantal; urgency=low

  * New upstream bug fix release
    - Fix rendering of password entry's spinner (LP: #1059447)
    - Fix rendering of password entry's cursor after closing a dialog
      (LP: #1049261)
    - Fix slight pixel jump in names as they finish scrolling (LP: #1056941)
    - Fix not being able to click on first few sessions in session chooser
      (LP: #1052453)
    - Cleanly close onboard keyboard to prevent it crashing on login
      (LP: #1055698)
    - Use a lightdm hint for controlling whether remote login is enabled
  * debian/patches/trunk_session_chooser.patch,
    debian/patches/02_use_remote_login_hint.patch:
    - Dropped, included upstream
 -- Michael Terry <email address hidden> Mon, 01 Oct 2012 12:33:16 -0400

Changed in unity-greeter (Ubuntu):
status: New → Fix Released
tags: added: raring
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers