onboard should be launched everytime after user enabled it in unity-greeter

Bug #1051946 reported by Rex Tsai on 2012-09-17
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OEM Priority Project
Medium
James M. Leddy
Precise
Medium
James M. Leddy
unity-greeter (Ubuntu)
Medium
Unassigned
Precise
Medium
Michael Terry

Bug Description

[IMPACT]
onboard is not `visible` when the user click/enable it in unity-greeter indicator, it only shows when user click the menu item of unity-greeter indicator again.

[TESTCASE]
Reproduce steps:
1. In lightdm, click a11y `on screen keyboard' menu item. onboard launched, and user logined into desktop session.
2. Logout the user. lightdm restarted.
3. a11y menu items shows `on screen keyboard' is still active, and onboard is running in the background. But it does not show on the screen. The user must click the menu item again, to get it `visible'.

[Regression Potential]
N/A (Unknown).

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity-greeter 0.2.8-0ubuntu1.2 [modified: usr/sbin/unity-greeter]
ProcVersionSignature: Ubuntu 3.2.0-30.48-generic 3.2.27
Uname: Linux 3.2.0-30-generic x86_64
ApportVersion: 2.0.1-0ubuntu13
Architecture: amd64
Date: Mon Sep 17 20:45:17 2012
DistributionChannelDescriptor:
 # This is a distribution channel descriptor
 # For more information see http://wiki.ubuntu.com/DistributionChannelDescriptor
 canonical-oem-stella-osaka-precise-amd64-20120912-0
InstallationMedia: Ubuntu 12.04 "Precise" - Build amd64 LIVE Binary 20120912-03:05
SourcePackage: unity-greeter
UpgradeStatus: No upgrade log present (probably fresh install)

Rex Tsai (chihchun) wrote :
Rex Tsai (chihchun) wrote :

Duplicated bug of https://bugs.launchpad.net/ubuntu/+source/unity-greeter/+bug/973922 But also need it to be fixed in precise.

Rex Tsai (chihchun) wrote :
description: updated
Rex Tsai (chihchun) on 2012-09-17
Changed in oem-priority:
importance: Undecided → Medium
Changed in oem-priority:
assignee: nobody → James M. Leddy (jm-leddy)
Rex Tsai (chihchun) on 2012-09-25
Changed in unity-greeter (Ubuntu):
assignee: nobody → Rex Tsai (chihchun)
status: New → In Progress
Sebastien Bacher (seb128) wrote :

Hey Michael, could you review the patch here?

Changed in unity-greeter (Ubuntu):
importance: Undecided → Medium
Changed in unity-greeter (Ubuntu Precise):
assignee: nobody → Michael Terry (mterry)
importance: Undecided → Medium
status: New → Triaged
Michael Terry (mterry) wrote :

As was mentioned, this was already fixed for quantal in bug 973922, so closing that task.

Changed in unity-greeter (Ubuntu):
assignee: Rex Tsai (chihchun) → nobody
status: In Progress → Fix Released
Changed in oem-priority:
status: New → Fix Released
Michael Terry (mterry) wrote :

I uploaded a fix for this in unity-greeter 0.2.8-0ubuntu1.3 in precise-proposed. It didn't actually need this specific patch from upstream. Rather, backporting the up-to-date focus logic from upstream was enough (since it includes code to keep the onboard window above the main unity-greeter window).

Once it's accepted into precise-proposed, I'd appreciate testing.

Sebastien Bacher (seb128) wrote :

settings to "in progress" and unsubscribing sponsors since that has been uploaded (it's waiting in the queue for review)

Changed in unity-greeter (Ubuntu Precise):
status: Triaged → In Progress
Rex Tsai (chihchun) wrote :

Confirmed unity-greeter 0.2.8-0ubuntu1.3 fixed the issue as well.

Rex Tsai (chihchun) wrote :

The fix is not landing precise-proposed yet, is there anything I can do?

Rex Tsai (chihchun) wrote :

$ ./ubuntu-archive-tools/queue -s precise-proposed -Q unapproved info|grep unity-greeter
 4659523 | S- | unity-greeter | 0.2.8-0ubuntu1.3 | 10 days
  | * unity-greeter/0.2.8-0ubuntu1.3 Component: main Section: x11

It's mostly the same people trying to finish up quantal that review these
changes, so SRU acceptance is somewhat behind. Whining won't help.

Hello Rex, or anyone else affected,

Accepted unity-greeter into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity-greeter/0.2.8-0ubuntu1.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity-greeter (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Rex Tsai (chihchun) wrote :

I tested the deb from archive[1] again, it works

[1] http://launchpad.net/ubuntu/+source/unity-greeter/0.2.8-0ubuntu1.3

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-greeter - 0.2.8-0ubuntu1.3

---------------
unity-greeter (0.2.8-0ubuntu1.3) precise-proposed; urgency=low

  * debian/patches/fix-focus.patch:
    - Backport better keyboard focus handling from upstream as new windows
      appear and disappear. This fixes keyboard navigation in dialogs
      (LP: #986289) and the onboard keyboard not showing up on startup
      if it was enabled before (LP: #1051946)
 -- Michael Terry <email address hidden> Fri, 14 Sep 2012 15:47:42 -0400

Changed in unity-greeter (Ubuntu Precise):
status: Fix Committed → Fix Released
James M. Leddy (jm-leddy) wrote :

Marking fixed released in oem-prio based off comment #15

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers