No web asking about integration in Ubuntu 14.10

Bug #1387357 reported by costales on 2014-10-29
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
WebApps: unity-chromium-extensions
Undecided
Unassigned
unity-firefox-extension (Ubuntu)
Medium
Justin McPherson

Bug Description

Hi!
I tried Ubuntu 14.10 today and I saw 2 bugs:
1. Webs as Gmail, Twitter... are not asking about Webapp integration.

2. The webbrowser is in blank then I open the webapp. I installed Telegram webapp:
sudo add-apt-repository ppa:costales/unity-webapps-telegram
sudo apt-get update && sudo apt-get install unity-webapps-telegram

Best regards and thanks in advance!

Olivier Tilloy (osomon) wrote :

I assume this is on desktop, please correct me if this assumption is incorrect.

1. do you mean that websites opened in webbrowser-app do not offer webapp integration, or is this when opening them in chromium/firefox?

2. I’m not seeing that, the telegram app installed from your PPA works fine here.

Changed in webbrowser-app:
status: New → Incomplete

Hi Olivier!

I assume this is on desktop, please correct me if this assumption is
> incorrect.
>

Yes, Utopic version with:
  Enabled all repositories.
  Updated wide system.
  Installed Telegram webapp
  Rebooted.
  Testing > Same bug.

> 1. do you mean that websites opened in webbrowser-app do not offer
> webapp integration, or is this when opening them in chromium/firefox?
>

Opening in Firefox.

2. I’m not seeing that, the telegram app installed from your PPA works
> fine here.
>

I upload an attachment with the result of open Telegram: Blank window in
webbrowser-app, nothing to do, no menu, no available clicks in
webbrowser-app...

Best regards and thanks in advance!

Hi Olivier!

  > I assume this is on desktop, please correct me if this assumption is
    incorrect.

Yes, Utopic version with:
  Enabled all repositories.
  Updated wide system.
  Installed Telegram webapp
  Rebooted.
  Testing > Same bug.

  > 1. do you mean that websites opened in webbrowser-app do not offer
    webapp integration, or is this when opening them in chromium/firefox?

Opening in Firefox.

 > 2. I’m not seeing that, the telegram app installed from your PPA works
    fine here.

I upload an attachment with the result of open Telegram: Blank window in webbrowser-app, nothing to do, no menu, no available clicks in webbrowser-app...

Best regards and thanks in advance!

Olivier Tilloy (osomon) wrote :

Not sure how to debug the issue you’re seeing with the telegram webapp, it works fine here (attaching a screenshot just to prove I’m not making it up).

Regarding webapp integration in firefox, I’m not sure whether this is still supposed to work, I’ll get someone from the webapps team to comment.

David Barth (dbarth) wrote :

You should see a prompt with Firefox. It's probably a regression in the extension.

summary: - No web asking about integration and webbrowser-app is empty in Ubuntu
- 14.10
+ No web asking about integration in Ubuntu 14.10
David Barth (dbarth) wrote :

I have updated the bug title to only cover the firefox extension issue, since Olivier wasn't able to reproduce the issue. That last one, ie the webapp container being blank maybe due to local config files producing errors. Can you attach the logs of the webapp while it (tries to) start?

Changed in unity-firefox-extension (Ubuntu):
assignee: nobody → Justin McPherson (justinmcp)
importance: Undecided → Medium
Olivier Tilloy (osomon) wrote :

Could it be that the extension is not installed at all? It’s not on my utopic setup (upgraded from trusty, itself upgraded from saucy, it might be that at some point I manually uninstalled it).

$ apt-cache policy xul-ext-unity
xul-ext-unity:
  Installed: (none)
  Candidate: 3.0.0+14.04.20140416-0ubuntu1

Hi David.
OK :) How can I get the webapp logs?
Best regards!

David Barth (dbarth) wrote :

Just launch it from the command line and send back a pastebin of the logs.

To know exactly which parameters to use, just start it first from the
launcher, ps ax | grep webapp-container

On Tue, Nov 4, 2014 at 7:13 PM, costales <email address hidden> wrote:

> Hi David.
> OK :) How can I get the webapp logs?
> Best regards!
>
> --
> You received this bug notification because you are a member of WebApps
> Team, which is subscribed to WebApps: unity-chromium-extensions.
> https://bugs.launchpad.net/bugs/1387357
>
> Title:
> No web asking about integration in Ubuntu 14.10
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/unity-chromium-extension/+bug/1387357/+subscriptions
>

costales (costales) wrote :

I think is missing a QT dependence:
http://paste.ubuntu.com/8852229/

This is a fresh install of Ubuntu 14.10, updated to today and installed
Telegram webapp from the PPA.

Best regards!

David Barth (dbarth) wrote :

Yup. What happens if you install the missing dep? does it work as expected?

In all cases, keep the bug open and we can turn that into a packaging bug
to add the missing dependencies.

Thanks

On Thu, Nov 6, 2014 at 7:46 PM, costales <email address hidden> wrote:

> I think is missing a QT dependence:
> http://paste.ubuntu.com/8852229/
>
> This is a fresh install of Ubuntu 14.10, updated to today and installed
> Telegram webapp from the PPA.
>
> Best regards!
>
> --
> You received this bug notification because you are a member of WebApps
> Team, which is subscribed to WebApps: unity-chromium-extensions.
> https://bugs.launchpad.net/bugs/1387357
>
> Title:
> No web asking about integration in Ubuntu 14.10
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/unity-chromium-extension/+bug/1387357/+subscriptions
>

Eric (ericvb69) wrote :

Same problem here. Running utopic, upgraded from trusty. Telegram webapp window is blank. Screenshot attached.

Eric (ericvb69) wrote :
Download full text (4.1 KiB)

Even after installing missing dependencies, webapp window is blank.

sudo apt-get install qml-module-qtquick-controls qml-module-qt-labs-folderlistmodel qml-module-qt-labs-settings

$ unity-webapps-runner -n 'VGVsZWdyYW0=' -d 'zhukov.github.io' %u
** Message: Launching webapp 'Telegram' with the webapp container (command line 'webapp-container --app-id='Telegramzhukovgithubio' --webapp='VGVsZWdyYW0=' --enable-back-forward ')
eric@pico-T60:~$ libGL error: Version 4 or later of flush extension not found
libGL error: failed to load driver: i915
The schema com.canonical.Unity.Thumbnailer is missing
Skipping "webapp-properties.json" as a webapp definition search: "/usr/share/unity-webapps/userscripts/unity-webapps-amazon/webapp-properties.json"
Invalid webapp webapp definition: homepage not found or fails predicate isString
Could not open manifest file: "/usr/share/unity-webapps/userscripts/unity-webapps-amazon/manifest.json"
Invalid webapps manifest found in: "/usr/share/unity-webapps/userscripts/unity-webapps-amazon"
Skipping "webapp-properties.json" as a webapp definition search: "/usr/share/unity-webapps/userscripts/unity-webapps-gmail/webapp-properties.json"
Skipping "webapp-properties.json" as a webapp definition search: "/usr/share/unity-webapps/userscripts/unity-webapps-googledocs/webapp-properties.json"
Skipping "webapp-properties.json" as a webapp definition search: "/usr/share/unity-webapps/userscripts/unity-webapps-launchpad/webapp-properties.json"
Skipping "webapp-properties.json" as a webapp definition search: "/usr/share/unity-webapps/userscripts/unity-webapps-telegram/webapp-properties.json"
Skipping "webapp-properties.json" as a webapp definition search: "/usr/share/unity-webapps/userscripts/unity-webapps-youtube/webapp-properties.json"
Skipping "webapp-properties.json" as a webapp definition search: "/usr/share/unity-webapps/userscripts/unity-webapps-amazon/webapp-properties.json"
Invalid webapp webapp definition: homepage not found or fails predicate isString
Could not open manifest file: "/usr/share/unity-webapps/userscripts/unity-webapps-amazon/manifest.json"
Invalid webapps manifest found in: "/usr/share/unity-webapps/userscripts/unity-webapps-amazon"
Skipping "webapp-properties.json" as a webapp definition search: "/usr/share/unity-webapps/userscripts/unity-webapps-gmail/webapp-properties.json"
Skipping "webapp-properties.json" as a webapp definition search: "/usr/share/unity-webapps/userscripts/unity-webapps-googledocs/webapp-properties.json"
Skipping "webapp-properties.json" as a webapp definition search: "/usr/share/unity-webapps/userscripts/unity-webapps-launchpad/webapp-properties.json"
Skipping "webapp-properties.json" as a webapp definition search: "/usr/share/unity-webapps/userscripts/unity-webapps-telegram/webapp-properties.json"
Skipping "webapp-properties.json" as a webapp definition search: "/usr/share/unity-webapps/userscripts/unity-webapps-youtube/webapp-properties.json"
Using Oxide as the web engine backend
Empty path in webapps model search path update request
QQmlExpression: Expression file:///usr/share/webbrowser-app/webcontainer/WebApp.qml:179:25 depends on non-NOTIFYable properties:
    u...

Read more...

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-firefox-extension (Ubuntu):
status: New → Confirmed
Olivier Tilloy (osomon) on 2015-06-08
no longer affects: webbrowser-app
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers